Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 426654

Summary: media-sound/baudline-1.08 : Fails to start because of missing fonts
Product: Gentoo Linux Reporter: Eric F. GARIOUD <eric-f.garioud>
Component: Current packagesAssignee: No maintainer - Look at if you want to take care of it <maintainer-needed>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 427302    
Bug Blocks:    

Description Eric F. GARIOUD 2012-07-14 22:34:45 UTC
Starting baudline displays the following error message :

could not open 10x20 font
could not open 5x7 font
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x0
  Serial number of failed request:  491
  Current serial number in output stream:  492

My emerge --info :

Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.2.6-ck.3 x86_64)
System uname: Linux-3.2.6-ck.3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Fri, 13 Jul 2012 04:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo PrimaPratica_ovl
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--color y --alphabetical --autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="24bpp X accessibility alsa amd64 amr atm bzip2 caps cdda cdio cli cracklib crypt css cups custom-cflags custom-cpuopts custom-optimization cxx dbus dga dri dts dvd enca exceptions exif flac fortran glib handbook hardcoded-tables iconv icu id3tag idn inotify introspection ipc jack jit kipi kontact libnotify libsamplerate mmx mmxext modplug modules mudflap multilib ncurses nptl ocamlopt openal opencl openmp optimized-qmake orc pam pch pcre pgo plasma policykit ppp pppd private-headers pth qt-faststart qt3support readline schroedinger semantic-desktop session shared-dricore shared-glapi smp sse sse2 sse3 sse4_1 ssl ssse3 startup-notification system-sqlite taglib tcpd threads twolame udev unicode uuid vaapi vdpau vim-syntax vpx wallpapers wavpack xa xattr xcb xorg xvmc zlib" ALSA_CARDS="hda-intel ice1712" ALSA_PCM_PLUGINS="asym dmix dsnoop ioplug plug rate hooks route" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" FFTOOLS="cws2fws" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Eric F. GARIOUD 2012-07-14 23:19:19 UTC
On baudline's blog, it is specified that baudline needs 


To be installed.

For a reason I ignore, under my /usr/share/fonts/75dpi, I get :

helvB12.pcf.gz -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso10646-1
helvR12.pcf.gz -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso10646-1

Could the difference of charset be the reason for the trouble ?
Comment 2 Michael Weber (RETIRED) gentoo-dev 2012-07-20 06:32:25 UTC

(In reply to comment #1)
> On baudline's blog, it is specified that baudline needs 
> -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
> -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
> To be installed.
> For a reason I ignore, under my /usr/share/fonts/75dpi, I get :
> helvB12.pcf.gz -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso10646-1
> helvR12.pcf.gz -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso10646-1

these are from media-fonts/font-adobe-75dpi (a specified dependency in the baudline package), and its identical to my system.

My /usr/share/fonts/75dpi/fonts.dir lists
helvB12-ISO8859-1.pcf.gz -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
helvR12-ISO8859-1.pcf.gz -adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
which are both part of media-fonts/font-adobe-75dpi, too.

> Could the difference of charset be the reason for the trouble ?
I don't think so.

(In reply to comment #0)
> Starting baudline displays the following error message :
> could not open 10x20 font
> could not open 5x7 font
^^ this might be a pixel font specification.
`locate 10x20 5x7` shows /usr/share/fonts/misc/10x20.pcf.gz and /usr/share/fonts/misc/5x7.pcf.gz plus some -<encoding>- variants, all belonging to media-fonts/font-misc-misc, bingo. I get the same error w/o this package.

Please `emerge -av media-fonts/font-misc-misc` for now, I fix the package.

Thanks for the report.
Comment 3 Michael Weber (RETIRED) gentoo-dev 2012-07-20 06:38:57 UTC
+*baudline-1.08-r1 (20 Jul 2012)
+  20 Jul 2012; Michael Weber <> +baudline-1.08-r1.ebuild:
+  Revbump to add missing font (thanks Eric F. GARIOUD, bug 426654)

+  20 Jul 2012; Michael Weber <> -baudline-1.08.ebuild,
+  baudline-1.08-r1.ebuild:
+  Transfer stable keywords (old stable was broken), drop old.
Comment 4 Eric F. GARIOUD 2012-07-20 12:53:30 UTC
1/ Thank you Michael for actually fixing the bug and taking care of this package.
The font-misc-misc package was indeed necessary for baudline to start.


2/ baudline might still refuse to start with the same error.

Do not bother with this Michael, I think it's on media-fonts/font-alias responsibility : Bug 427302

That is the reason why I reopen this bug specifying its dependency on Bug 427302

3/ If some users can't wait for Bug 427302 to be fixed, they can :

3.a/ Consider that baudline will need the 5x7 - 7x13 - 10x20 fonts from font-misc-misc.
3.b/ Edit /usr/share/fonts/misc/fonts.alias
3.c/ Change 8859 for 10646 in the lines associated with the aliases previously mentioned
3.d/ Quit and restart X or, if impossible, fire `xset fp rehash` under any xterm.