Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 425522

Summary: =app-misc/sphinx-2.0.4 fails to build with GCC 4.7
Product: Gentoo Linux Reporter: Brennan Shacklett <bpshacklett>
Component: Current packagesAssignee: Hans de Graaff <graaff>
Status: RESOLVED FIXED    
Severity: normal CC: bpshacklett
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 390247    
Attachments: Build log
Patch to compile with gcc 4.7

Description Brennan Shacklett 2012-07-09 16:45:45 UTC
The compile phase of app-misc/sphinx dies due to errors from the changes in C++ name lookups in gcc 4.7. Tested with gcc 4.5 and it worked fine.

Reproducible: Always

Steps to Reproduce:
1. Unmask and emerge gcc-4.7
2. emerge app-misc/sphinx
Actual Results:  
src_compile failed

Expected Results:  
compilation and installation succeed and app-misc/sphinx is installed

emerge --info:
Portage 2.1.11.5 (default/linux/amd64/10.0, gcc-4.7.1, glibc-2.15-r2, 3.4.2-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.4.2-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-2640M_CPU_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Sun, 08 Jul 2012 17:45:01 +0000
app-shells/bash:          4.2_p29
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo perl-experimental pd-overlay local_overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/perl-experimental /var/lib/layman/pd-overlay /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 avx branding dga dri gmp ipv6 mmx mmxext multilib nptl opengl openmp readline smp sse sse2 sse3 sse4 sse4_1 ssse3 threads udev unicode vaapi vdpau vim-syntax xcb xorg" ALSA_CARDS="hda-intel" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack proxy proxy_http" CURL_SSL="openssl" ELIBC="glibc" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LINGUAS="en" QEMU_SOFTMMU_TARGETS="arm mips mips64 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64 mips ppc ppc64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Brennan Shacklett 2012-07-09 16:48:49 UTC
Created attachment 317710 [details]
Build log

This is the build log, it's from my local overlay because I have to apply my patch from bug 425380 to build with automake 1.12
Comment 2 Brennan Shacklett 2012-07-09 16:50:56 UTC
Created attachment 317712 [details, diff]
Patch to compile with gcc 4.7

This is the debian patch from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667378

I just cut out all the debian parts and made it into a normal patch, rather than a patch creating a patch.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-10 16:27:35 UTC
Patch LGTM.
Comment 4 Hans de Graaff gentoo-dev 2012-07-21 08:01:27 UTC
Applied in sphinx-2.0.4-r1