Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 423827

Summary: kde-base/kdm fails to start using binpkgs
Product: Gentoo Linux Reporter: Stefan Hübner <st0ff>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Severity: normal CC: vivo75
Priority: Normal    
Version: 10.1   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info of the binpkg machine

Description Stefan Hübner 2012-06-27 12:50:22 UTC
Created attachment 316423 [details]
emerge --info of the binpkg machine

since using binpackages I have run into this problem twice: kdm fails to start, kdm.log contains this:
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged. PAM logs messages related to authentication to authpriv.*.

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
klauncher(8419) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(8413)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" 

kdmgreet(8413)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned 
Server terminated successfully (0). Closing log file.

DBUS is started, on the "buildpkg" machine this problem does not exist.  Differences regarding Xorg: the buildpkg machine runs xf86-video-intel, the other runs xf86-video-mga.

I've had this problem a few weeks ago at home on two very different machines, but I solved it there by copying the whole system of the buildpgk-machine to the binpkg-machine.  I would not do this here at work.  But as that "bad" solution worked, I fear it's some configuration file or even permissions issue.  Question: which files should be considered?
Comment 1 Francesco Riosa 2012-07-30 16:12:44 UTC
me too,
plasma-desktop hang at start, deep inside qtwebkit, specifically the WTF library inside of it.
This is a mostly stable system.

Found no solution as of yet and re-installed half of kde.
Comment 2 Francesco Riosa 2012-07-30 16:47:05 UTC
USE=-jit emerge x11-libs/qt-webkit helped
Comment 3 Francesco Riosa 2012-07-30 17:36:41 UTC
ok, my problem was that CC and CXX were set to gcc-4.7.1 in the shell environment, slipped in portage and broke kinda everything
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2013-02-17 22:50:42 UTC
Is this still happening with current KDE?
Comment 5 Michael Palimaka (kensington) gentoo-dev 2013-03-14 15:55:21 UTC
(In reply to comment #4)
> Is this still happening with current KDE?