Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 421363

Summary: x11-apps/xinput_calibrator-0.7.5[-gtk] installs incorrect desktop entry
Product: Gentoo Linux Reporter: Maxim Kammerer <mk>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: xinput_calibrator.desktop

Description Maxim Kammerer 2012-06-16 11:37:57 UTC
For USE=-gtk, /usr/share/applications/xinput_calibrator.desktop contains:

  Exec=/bin/sh -c "xinput_calibrator; cat"

The reason for "cat" is that xinput_calibrator prints vital information on standard output upon termination. At least on LXPanel + Openbox setup, this results in "Cannot parse command line arguments" message. The problem is with the quotes; suggest replacing the line with (working with LXPanel):

  Exec=sh -c xinput_calibrator;read\ x

Using "read" instead of "cat" here so that the user can just it Enter instead of closing the window (or non-intuitive Ctrl-D). An argument to "read" is required in dash.

Another option would be a wrapper script.
Comment 1 Maxim Kammerer 2013-08-20 22:35:12 UTC
Created attachment 356538 [details]
xinput_calibrator.desktop
Comment 2 Larry the Git Cow gentoo-dev 2020-06-24 20:39:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f6ad7d8754c7f4cf9d871d78a191d3ba6f198b64

commit f6ad7d8754c7f4cf9d871d78a191d3ba6f198b64
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2020-06-24 20:36:07 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-06-24 20:38:57 +0000

    x11-apps/xinput_calibrator: Port to EAPI 7
    
    And drop IUSE=gtk since it depends on gtkmm:2.4.
    
    Closes: https://bugs.gentoo.org/421363
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 ...-0.7.5-r1.ebuild => xinput_calibrator-0.7.5-r2.ebuild} | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)