Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 420185

Summary: mysql-workbench seems to require /etc/my.cnf
Product: Gentoo Linux Reporter: <erict>
Component: New packagesAssignee: Hans de Graaff <graaff>
Severity: minor CC: alex
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: build.log

Description 2012-06-08 04:53:53 UTC
In New Server Instance Profile one selects linux distro type.
if you choose generic linux (tarball) 
it seems to require /etc/my.cnf (i made a symlink and it worked).

maybe the symlink could be created or a gentoo linux type could be added somehow?

Reproducible: Always
Comment 1 Hans de Graaff gentoo-dev Security 2012-06-09 08:06:08 UTC
(In reply to comment #0)
> In New Server Instance Profile one selects linux distro type.
> if you choose generic linux (tarball) 
> it seems to require /etc/my.cnf (i made a symlink and it worked).
> maybe the symlink could be created or a gentoo linux type could be added
> somehow?

Providing a Gentoo profile has been on my todo list for a long time. Patches welcome!
Comment 2 Alex Barker 2013-08-25 22:04:32 UTC
Created attachment 357014 [details]

Portage (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo x86_64)
System uname: Linux-3.10.7-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.2
KiB Mem:    12302992 total,    734188 free
KiB Swap:    2000088 total,   2000028 free
Timestamp of tree: Sun, 25 Aug 2013 02:15:01 +0000
ld GNU gold (GNU Binutils 2.23.2) 1.11
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo proaudio sunrise steam-overlay local_overlay
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/pro-audio /var/lib/layman/sunrise /var/lib/layman/steam /usr/local/portage"
USE="X a52 aac accessibility acl acpi alsa amd64 amr berkdb bitmap-fonts bmp branding bzip2 cairo cdda cddb cdinstall cdr cifs cli consolekit cracklib crypt curl custom-cflags cxx dbus divx dri dts dvd dvdr dvdread emboss encode exif faac fam ffmpeg firefox firefox3 flac flash fortran ftp g3dvl gdbm gif gles2 gnutls gpm gsm gstreamer gtk gtk2 hal iconv icu ipv6 java java6 jpeg jpg jpg2k kde lame lcms libnotify lto lzma mad minizip mmx mmx2 mmxext mng modules mozilla mp3 mp4 mpeg mudflap multilib musepack ncurses nfs nls nptl nptlonl nsplugin nvidia offensive ogg openal openexr opengl openmp opus osc pam pango pcre pdf pic png policykit ppds python3 qt qt3support qt4 quciktime rar rdesktop rdp readline real samba scanner sdl semantic-desktop session speex spell sqlite sse sse2 sse3 sse4 sse41 sse42 ssl ssse3 startup-notification svg system-sqlite tcpd theora tiff truetype truetype-fonts type1-fonts udev udisks unicode upower usb v4l v4l2 vdpau videos vnc vorbis vpx wav wavpack wxwidgets x264 xcb xml xscreensaver xulrunner xv xvid xvmc zip zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="access_compat actions alias auth_basic authn_core authz_core authz_host autoindex dir env filter log_config mime negotiation rewrite setenvif unique_id unixd" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" NETBEANS_MODULES="apisupport cnd dlight harness ide java nb php profiler websvccommon" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="artec_eplus48u" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Alex Barker 2013-08-26 15:27:39 UTC
Sorry, not sure how this got attached here, It should have been attached to bug #482156