Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 419963

Summary: dev-lang/perl-5.16.0 should PDEPEND virtual/perl-ExtUtils-ParseXS
Product: Gentoo Linux Reporter: Kent Fredric (IRC: kent\n) (RETIRED) <kentnl>
Component: [OLD] DevelopmentAssignee: Gentoo Perl team <perl>
Status: RESOLVED WONTFIX    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2012-06-06 17:16:45 UTC
In testing perl-5.16.0, I found quite a few things break due old versions of modules in perl-core/  taking priority over the ones in perl itself, yeilding fun errors like:

Failed to load or import from ExtUtils::ParseXS (version 2.2206). Please check that ExtUtils::ParseXS is installed correctly and that the newest version will be found in your @INC path: "report_error_count" is not exported by the ExtUtils::ParseXS module
Can't continue after import errors at /usr/lib64/perl5/5.16.0/ExtUtils/xsubpp line 6.

=dev-lang/perl-5.16.0
=virtual/perl-ExtUtils-ParseXS-2.22.06
=perl-core/ExtUtils-ParseXS-2.22.06

Unmasking the virtual and perl-core packages, and upgrading above will solve some problems in a few packages, such as:

app-editors/gvim
app-editors/vim
x11-terms/rxvt-unicode
Comment 1 Torsten Veller (RETIRED) gentoo-dev 2012-06-06 20:36:55 UTC
That's why i added the "ExtUtils-ParseXS-3" to the "perl-5.16" tracker bug. And I also mentioned it in the package.mask.
Comment 2 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2012-06-07 02:24:27 UTC
(In reply to comment #1)
> That's why i added the "ExtUtils-ParseXS-3" to the "perl-5.16" tracker bug.
> And I also mentioned it in the package.mask.

Indeed. Noticed. However, if you didn't scrape the package.mask file or read aforementioned bug and just did 

echo =dev-lang/perl-5.16.0 >> /etc/portage/package.unmask

You'll still be left with the impression that something is broken.
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-02-21 10:11:56 UTC
5.16.0 never will go stable, i think this bug no make sense.