Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 419591

Summary: Create an OpenJDK ebuild based on the FreeBSD port
Product: Gentoo/Alt Reporter: Peter Stuge <peter>
Component: FreeBSDAssignee: Gentoo/BSD Team <bsd+disabled>
Status: RESOLVED OBSOLETE    
Severity: enhancement CC: devurandom, gentoo.2019
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: FreeBSD   
Whiteboard:
Package list:
Runtime testing required: ---

Description Peter Stuge 2012-06-04 09:05:30 UTC
The dev-java/icedtea build system is quite complicated, targeted to Linux, and on top of that has tons of build dependencies which are not runtime dependencies, including X, cups and ALSA. Per https://bugs.gentoo.org/show_bug.cgi?id=409901#c2 "upstream doesn't see this as a priority" so it will be several years before icedtea can be built sanely on any platform.

Meanwhile ryao pointed to the FreeBSD upstream port for OpenJDK at http://www.freebsd.org/cgi/cvsweb.cgi/~checkout~/ports/java/openjdk6/Makefile?rev=1.64;content-type=text%2Fplain and mentioned the idea to convert this into an ebuild for Gentoo/BSD, which could possibly be more sane. Maybe it could even end up replacing icedtea for Gentoo in general, if it turns out that the approach used in the port file fits better with how Portage works, which I find not too unlikely.

Reproducible: Always



Expected Results:  
A JRE on my Gentoo/BSD system without a million dependencies.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-11 17:37:09 UTC
*-fbsd is gone.