Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 419511

Summary: <sys-kernel/genkernel-3.4.35 fails to build initramfs w/ >=sys-kernel/linux-headers-3.4 (no /usr/include/linux/ext2_fs.h)
Product: Gentoo Linux Reporter: Hongjiu Zhang <noctuorare>
Component: [OLD] UnspecifiedAssignee: Gentoo Genkernel Maintainers <genkernel>
Status: RESOLVED FIXED    
Severity: normal CC: DrWilken, gentoo-bugs, gentoo, herber, swnpnt, zerochaos
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 417707    
Bug Blocks:    
Attachments: Genkernel Log
Kernel Config for 3.3.7-hardened-r1

Description Hongjiu Zhang 2012-06-03 17:57:05 UTC
I am not sure whether I should submit this bug to core system or genkernel.

There is no /usr/include/linux/ext2_fs.h in sys-kernel/linux-headers-3.4, which is required by genkernel to build busybox.

Reproducible: Always




Portage 2.1.10.64 (hardened/linux/amd64/desktop, gcc-4.6.3, glibc-2.15-r2, 3.3.7-hardened x86_64)
=================================================================
System uname: Linux-3.3.7-hardened-x86_64-Intel-R-_Core-TM-_i5-2450M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sun, 03 Jun 2012 14:15:01 +0000
app-shells/bash:          4.2_p29
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo gentoo-zh gentoo-haskell science sunrise kde local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 google-talkplugin skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -ggdb -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -ggdb -march=native -pipe"
DISTDIR="/var/pkg/dist"
EMERGE_DEFAULT_OPTS="--keep-going y --with-bdeps y --quiet-build y"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2"
GENTOO_MIRRORS="http://mirrors.xmu.edu.cn/gentoo"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB en zh_TW zh af ak am ar as as_IN ast az be be_BY bg bn bn_BD bn_IN bo br brx bs ca ca_XV ca@valencia crh cs csb cy da de de_FR dgo dz ee el en_CA en_US en_ZA eo es es_AR es_CL es_CR es_ES es_LA es_MX et et_EE eu fa fi fil fo fr fr_CA fy fy_NL ga ga_IE gd gl gu gu_IN ha he hi hi_IN hne hr hsb hu hy hy_AM ia id is it ja ka kk km kn kn_IN ko ko_KR kok ks ku ky la lb lg lo lt lv mai me mi mk ml ml_IN mn mni mr mr_IN ms mt my nb nb_NO nds ne nl nn nn_NO no nr ns nso oc om or or_IN pa pa_IN pap pl ps pt pt_BR pt_PT rm ro ru rw sa_IN sat sd se sh sh_YU son si sk sl sq sr sr@ijekavian sr@ijekavianlatin sr@latin sr@Latn sr_CS ss st sv sv_SE sw sw_TZ ta ta_IN ta_LK te te_IN tg th ti ti_ER tk tl tn tr ts tt ug uk ur_IN ur_PK uz uz@cyrillic ve ven vi wa xh zh_CN zh_HK zu"
MAKEOPTS="-j4"
PKGDIR="/var/pkg/bin"
PORTAGE_COMPRESS="/usr/bin/xz"
PORTAGE_COMPRESS_FLAGS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/pkg/portage"
PORTDIR_OVERLAY="/var/pkg/gentoo-zh /var/pkg/haskell /var/pkg/science /var/pkg/sunrise /var/pkg/kde /var/pkg/usr"
SYNC="rsync://rsync2.cn.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cjk cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac gdbm gif gpm gsm gstreamer hardened iconv introspection ipv6 jpeg jpeg2k justify kde lame lcms ldap libnotify lzma mad mms mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pax_kernel pcre pdf png policykit ppds pppd qt3support qt4 readline samba sdl semantic-desktop session spell sqlite sse sse2 ssl startup-notification svg taglib tcpd theora threads tiff truetype udev udisks unicode upnp upower urandom usb v4l vaapi vim-syntax vorbis wifi wxwidgets x264 xcb xcomposite xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2 adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a jl2005c kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en zh_TW zh af ak am ar as as_IN ast az be be_BY bg bn bn_BD bn_IN bo br brx bs ca ca_XV ca@valencia crh cs csb cy da de de_FR dgo dz ee el en_CA en_US en_ZA eo es es_AR es_CL es_CR es_ES es_LA es_MX et et_EE eu fa fi fil fo fr fr_CA fy fy_NL ga ga_IE gd gl gu gu_IN ha he hi hi_IN hne hr hsb hu hy hy_AM ia id is it ja ka kk km kn kn_IN ko ko_KR kok ks ku ky la lb lg lo lt lv mai me mi mk ml ml_IN mn mni mr mr_IN ms mt my nb nb_NO nds ne nl nn nn_NO no nr ns nso oc om or or_IN pa pa_IN pap pl ps pt pt_BR pt_PT rm ro ru rw sa_IN sat sd se sh sh_YU son si sk sl sq sr sr@ijekavian sr@ijekavianlatin sr@latin sr@Latn sr_CS ss st sv sv_SE sw sw_TZ ta ta_IN ta_LK te te_IN tg th ti ti_ER tk tl tn tr ts tt ug uk ur_IN ur_PK uz uz@cyrillic ve ven vi wa xh zh_CN zh_HK zu" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Hongjiu Zhang 2012-06-03 17:57:35 UTC
Created attachment 314071 [details]
Genkernel Log
Comment 2 Hongjiu Zhang 2012-06-03 17:58:28 UTC
Created attachment 314073 [details]
Kernel Config for 3.3.7-hardened-r1
Comment 3 C D 2012-06-08 05:29:53 UTC
I am having what looks like the same problem.
I haven't been able to compile a kernel for over a week.
Not even older kernels that I have already compiled work.
Read this http://forums.gentoo.org/viewtopic-p-7057712.html#7057712.

Portage 2.1.10.65 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.15-r2, 3.3.5-gentoo x86_64)
=================================================================
System uname: Linux-3.3.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-2670QM_CPU_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Fri, 08 Jun 2012 04:00:01 +0000
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.1.4-r4, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going y -j 4"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X a52 aac acl acpi addns ads alsa amd64 apache2 apcupsd aperfmperf apic apng arat arch_perfmon audacious avx bash-completion battery berkdb bluetooth branding bts bzip2 cairo caps cdda cdr clamav clamd clamdtop clflush cli cmov connection-sharing consolekit constant_tsc cracklib crypt cscope cups curl custom-cflags custom-optimization cx16 cx8 cxx dbus de dedicated derby device-mapper dga dhcpcd dirac direct2d directfb directx dmx dri ds_cpl dshow dtes64 dts dv dvd dvdr dxva2 eds egl emboss encode epb ept equalizer est eve exif extensions fam fat fbcon fbosd ffmpeg fftw firefox firefox-bookmarks flac flexpriority fltk fluidsynth fortran fpu freerdp fuse fxsr gcj gdbm gif gme gnome gnome-keyring gpm growl gstreamer gtk gtk3 hddtemp high-ints ht httpd iconv icu ida imlib iostats iptables ipv6 jack java java6 javascript jce joystick jpeg kate kdrive keychain lahf_lm lame laptop lcms ldap libass libkms libnotify libproxy libsamplerate libtiger libv4l libv4l2 libvisual linsys live lm lock lzo mad maps matroska mca mce midi mikmod minizip mmx mng moc modplug modules monitor mouse mozdom mp3 mp4 mpd mpeg msr mtp mtrr mudflap multilib musepack nautilus ncurses netbeans netlink networkmanager nls nonstop_tsc nopl nptl nsplugin nss ntfs nx odk offlinehelp ogg omxil openal opengl openldap openmp openpgp openrc opensc openssl pae pam pango pat pbe pclmulqdq pcre pcsc-lite pdcm pdf pdfimport pebs pge pidgin pkcs11 pln png pni policykit popcnt postgres ppds pppd projectm pse pse36 pts pulseaudio pvr python qt3support qt4 quicktime rdesktop rdesktop-vrdp rdtscp readline remote rep_good resolvconf rss rtsp samba schroedinger sdk sdl sdl-image sendto sep server servletapi session shine shout sid sip smartcard smbclient smbkrb5passwd smbsharemodes smbtav2 smp sna speech speex spell sqlite ss sse sse2 sse3 sse4 sse4_1 sse4_2 sse4a ssh ssl ssse3 stars startup-notification stk svg swat switcher symlink syscall syslog taglib tcpd telepathy templates theora thunar thunderbird tiff tint2conf tm tm2 toolbar tools tpr_shadow tracker truetype tsc twolame udev udisks unicode upnp upower usb utils v4l v4l2 vaapi vala vcdx video vlm vme vmx vnc vnmi vorbis vpid vte wav waveout webcam webdav webdav-neon webdav-serf wifi wingdi wma-fixed wxwidgets x264 x2apic xcb xdmcp xforms xfs xine xinerama xinetd xml xmms2 xmp xorg xplanet xrandr xsave xsaveopt xtopology xtpr xulrunner xv xvfb xvid zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse joystick synaptics vmmouse virtualbox" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="dummy fbdev intel i915 i965 v4l vesa virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 4 Yan-Fa Li 2012-06-08 05:53:10 UTC
I had this problem. It turns out the version of busybox, 1.9, that genkernel requires is too old to build never 3.* kernels because some of the ext2 headers have been moved. Changing my busybox version to

BUSYBOX_VER="1.20.1"

and copying busybox to genkernel's cache fixed it for me

cp /usr/portage/distfiles/busybox-1.20.1.tar.bz2 /var/cache/genkernel/src/

This would probably fix genkernel too.
Comment 5 Anthony Basile gentoo-dev 2012-06-09 16:34:05 UTC
(In reply to comment #4)
> I had this problem. It turns out the version of busybox, 1.9, that genkernel
> requires is too old to build never 3.* kernels because some of the ext2
> headers have been moved. Changing my busybox version to
> 
> BUSYBOX_VER="1.20.1"
> 
> and copying busybox to genkernel's cache fixed it for me
> 
> cp /usr/portage/distfiles/busybox-1.20.1.tar.bz2 /var/cache/genkernel/src/
> 
> This would probably fix genkernel too.

Yep, this works and it is the correct solution since its busybox's util-linux that's looking for linux/ext2_fs.h.

@genkernel folks.  Can we accelerate this since everyone using genkernel is going to hit it.  I'd add a blocking depend on linux-headers-3.4 for older versions of genkernel and bump BUSYBOX_VER on the next candidate for stabilization.
Comment 6 Sebastian Pipping gentoo-dev 2012-06-10 16:57:37 UTC
(In reply to comment #5)
> @genkernel folks.  Can we accelerate this since everyone using genkernel is
> going to hit it.

Everyone
- on testing,
- without a busybox cache and
- with a beeling edge kernel around, yes.

The current patches of busybox 1.19.3 do not apply against 1.20.1 as is.  Let's see what I can do.
Comment 7 Sebastian Pipping gentoo-dev 2012-06-10 17:22:48 UTC
+*genkernel-3.4.35 (10 Jun 2012)
+
+  10 Jun 2012; Sebastian Pipping <sping@gentoo.org> +genkernel-3.4.35.ebuild:
+  Bump to 3.4.35
+

Should be fixed.  Please try 3.4.35 and re-open as needed.
Comment 8 St├ęphane BARBARAY 2012-07-03 05:18:49 UTC
kernel 3.3.8 is now amd64 stable, so the problem is now happening on stable amd64 arch...
Even if we could unmask genkernel-3.4.35, this would also require to unmask >=openrc-0.9.9 and so on

A stable genkernel with a stable openrc is now needed for being able to build a stable kernel
Comment 9 Michael Mol 2012-07-03 13:32:30 UTC
I've just synced. Stable sys-kernel/gentoo-sources (3.3.8), stable sys-apps/openrc (0.9.8.4) and stable sys-kernel/genkernel (3.4.24_p1) don't result in a working genkernel build. These are the latest stable versions of each package for amd64, from what eix tells me. (found my way over here from Bug 424759)

Which versions are you using?
Comment 10 Michael Mol 2012-07-03 13:33:00 UTC
Er. Bug 424579.
Comment 11 Rick Farina (Zero_Chaos) gentoo-dev 2012-07-03 18:28:57 UTC
This is actually a significant problem for stable users, 3.4.35 isn't marked stable, the package versions causing this bug are, hence, this is not *resolved* until genkernel 3.4.35 is also marked stable.
Comment 12 swanpoint 2012-07-08 00:09:00 UTC
With BUSYBOX_VER="1.20.1" genkernel gets through a compile of sources 3.3.8 for me. But, on reboot my initramfs can't find my ext2 root under dmraid/mdadmin/lvm. The last 4 kernel versions have been flawless.
Comment 13 Sebastian Pipping gentoo-dev 2012-07-08 18:33:32 UTC
(In reply to comment #11)
> This is actually a significant problem for stable users, 3.4.35 isn't marked
> stable, the package versions causing this bug are, hence, this is not
> *resolved* until genkernel 3.4.35 is also marked stable.

if I am not mistaken, the stabilization of 3.4.24_p2 (using busybox 1.20.1) should solve the problem for users of Gentoo stable.  As bug #425360 is dedicated to that now, I dare closing this bug as fixed.(In reply to comment #12)


> With BUSYBOX_VER="1.20.1" genkernel gets through a compile of sources 3.3.8
> for me. But, on reboot my initramfs can't find my ext2 root under
> dmraid/mdadmin/lvm. The last 4 kernel versions have been flawless.

Please try with genkernel 3.4.36 and report a new bug against it, if the problem persists.