Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 419389

Summary: www-client/lynx-2.8.8_pre12 fails to build: ../../../WWW/Library/Implementation/HTUtils.h:735:17: fatal error: ssl.h: No such file or directory
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: Current packagesAssignee: Tim Harder <radhermit>
Status: RESOLVED FIXED    
Severity: normal CC: wormo
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log

Description Dennis Schridde 2012-06-02 18:34:59 UTC
ia64-unknown-linux-gnu-gcc -DHAVE_CONFIG_H  -I../../.. -I../../../src -I../../.. -I../../../src  -I../../../WWW/Library/Implementation  -D_GNU_SOURCE  -DLINUX -I/usr/include/ncursesw -pipe -mtune=mckinley -O2    -I../../../WWW/Library/Imp$
In file included from ../../../WWW/Library/Implementation/HTParse.c:8:0:
../../../WWW/Library/Implementation/HTUtils.h:735:17: fatal error: ssl.h: No such file or directory

Reproducible: Always




Portage 2.2.0_alpha109 (hardened/linux/ia64/server, gcc-4.5.3, glibc-2.14.1-r3, 2.6.27-openvz-repin.1 ia64)
=================================================================
System uname: Linux-2.6.27-openvz-repin.1-ia64-31-with-gentoo-2.1
Timestamp of tree: Sat, 02 Jun 2012 15:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r1, 3.2.3-r1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo local sunrise
Installed sets: @system
ACCEPT_KEYWORDS="ia64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="ia64-unknown-linux-gnu"
CFLAGS="-pipe -mtune=mckinley -O2"
CHOST="ia64-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-pipe -mtune=mckinley -O2"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--usepkg --buildpkg --binpkg-respect-use --with-bdeps y --keep-going"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parallel-install parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS=" 	--delete-excluded 	--exclude='/games*/' --exclude='/gnome*/' --exclude='/gnustep*/' --exclude='/gpe*/' --exclude='/kde*/' --exclude='/lxde*/' --exclude='/rox*/' --exclude='/xfce*/'"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/local /var/cache/portage/overlays/sunrise"
[...]
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, USE_PYTHON
Comment 1 Dennis Schridde 2012-06-02 18:35:14 UTC
Created attachment 313955 [details]
build.log
Comment 2 Tony Saigut 2013-12-22 13:43:43 UTC
Openssl installs head files in /usr/include/openssl/ directory rather than straightly in /usr/include/. 
So "#include <ssl.h>" should be modified to "#include <openssl/ssl.h>", and the include of other head files from openssl should also do the same modifications.
Comment 3 Thomas Dickey 2014-02-02 21:03:29 UTC
This might be the same as an issue fixed in 2.8.8pre.3:

2014-01-11 (2.8.8pre.3)
* fix a check in configure-script for openssl subdirectory in includes. It
  happened to work in most cases due to a spurious blank in the pkg-config
  file; this was removed recently, e.g., for Fedora20 -TD
Comment 4 Tim Harder gentoo-dev 2014-03-06 03:40:55 UTC
Closing since this is probably fixed in current versions.