Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 419167

Summary: games-rpg/bastion-20120529-r2 - an original action role-playing game set in a lush imaginative world
Product: Gentoo Linux Reporter: Zorzo Luca <lucazorzo>
Component: New packagesAssignee: Default Assignee for New Packages <maintainer-wanted>
Severity: enhancement CC: creideiki+gentoo-bugzilla, games, openhs, rdwald
Priority: Normal Keywords: EBUILD
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: bastion-20120529-r2.ebuild

Description Zorzo Luca 2012-06-01 23:02:09 UTC
Created attachment 313895 [details]

Description from
"Bastion is the first title from Supergiant Games, an original action role-playing game set in a lush imaginative world, in which players must create and fight for civilization’s last refuge as a mysterious narrator marks their every move."

This game is included in HumbleBundle V - .

Please test it on x86_64, thanks.
Comment 1 Randall Wald 2012-06-08 08:58:58 UTC
I tried this ebuild (using the more recent file, and renaming the ebuild appropriately), but I get the following error:

>>> Emerging (1 of 1) games-rpg/bastion-20120601-r1 from local
 * RMD160 SHA1 SHA256 size ;-) ...                                          [ ok ]
>>> Unpacking source...
 * Checking for at least 2400 mebibytes disk space at "/var/tmp/portage/games-rpg/bastion-20120601-r1/t [ ok ].
>>> Unpacking to /var/tmp/portage/games-rpg/bastion-20120601-r1/work
tar: instarchive_all: Not found in archive
tar: instarchive_linux_amd64: Not found in archive
tar: Exiting with failure status due to previous errors

Are you sure the unpacking code is working correctly, and doesn't have any unlisted dependencies on other things you've got on your system?

Incidentally, your Amnesia: The Dark Descent ebuild worked fine for me, so whatever the problem is, it lies in the difference between those two.
Comment 2 Zorzo Luca 2012-06-08 19:23:00 UTC
Created attachment 314721 [details]

Updated ebuild. Unpack phase changed to respect archive's new structure.
Comment 3 Randall Wald 2012-06-08 19:32:43 UTC
The new ebuild works for me. I'm still having difficulty getting the game to run, but that's beyond the scope of this bug.
Comment 4 Karl-Johan Karlsson 2012-09-25 08:31:15 UTC
I haven't tried the ebuild, only used the Humble Indie Bundle installer directly. However, that version had to have all PaX features disabled before the game would run on a hardened AMD64. I ran:

   /usr/sbin/paxctl-ng -sempr Bastion.bin.x86_64

From reading other ebuilds which set PaX markings, I think something like this should work (inserted before doexe "${executable}"):

   pax-mark sempr "${executable}"
Comment 5 Julian Ospald 2013-03-17 11:40:38 UTC
add it to sunrise

or send a pull request directly to me
Comment 6 Julian Ospald 2013-03-21 22:17:24 UTC
+*bastion-20120620 (21 Mar 2013)
+  21 Mar 2013; Julian Ospald <> +bastion-20120620.ebuild,
+  +metadata.xml:
+  initial import wrt #419167