Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 417711

Summary: media-gfx/graphviz-2.26.3-r4 + distcc - iffe: x86_64-pc-linux-gnu-gcc : not a C compiler: should not compile '(;'
Product: Gentoo Linux Reporter: Franz Trischberger <franz.trischberger>
Component: Current packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: molari.alessandro
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log
build log (2016)

Description Franz Trischberger 2012-05-27 06:15:35 UTC
Created attachment 313209 [details]
build log

Package Manager Information:
    Package Name              paludis
    Package Version           0.74.1
    Build Date                2012-05-03T14:21:11+0200
    Built with CXX            x86_64-pc-linux-gnu-g++ 4.6.3
    Built with CXXFLAGS        -march=amdfam10 -O2 -pipe -pedantic
    Built with LDFLAGS        -Wl,-O1 -Wl,--as-needed

Environment Information:
    Format                    paludis
    Config dir                /etc/paludis
    Root                      /
    System Root               /
    World file                /var/db/pkg/world

Repository gentoo:
    format                    e
    location                  /var/paludis/repositories/gentoo
    builddir                  /var/tmp/paludis
    cache                     /var/paludis/repositories/gentoo/metadata/md5-cache
    distdir                   /var/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /var/paludis/repositories/gentoo/eclass
    layout                    traditional
    manifest_hashes           RMD160 SHA1 SHA256
    names_cache               /var/paludis/repositories/gentoo/.cache/names
    newsdir                   /var/paludis/repositories/gentoo/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /etc/make.profile  /var/paludis/repositories/local/profiles
    securitydir               /var/paludis/repositories/gentoo/metadata/glsa
    setsdir                   /var/paludis/repositories/gentoo/sets
    sync                      rsync://rsync.de.gentoo.org/gentoo-portage
    sync_options              
    thin_manifests            false
    use_manifest              use
    write_cache               /var/cache/paludis/metadata
    Package information
        app-shells/bash       4.2_p20
        dev-java/java-config  2.1.11-r3
        dev-lang/python       2.7.3-r1 3.1.4-r3 3.2.3
        dev-util/ccache       3.1.7
        dev-util/cmake        2.8.8-r2
        dev-util/pkgconfig    0.26
        sys-apps/baselayout   2.1-r1
        sys-apps/openrc       0.10.1
        sys-apps/sandbox      2.5
        sys-devel/autoconf    2.13 2.68
        sys-devel/automake    1.11.1
        sys-devel/binutils    2.21.1-r1
        sys-devel/gcc         4.6.3
        sys-devel/gcc-config  1.5-r2
        sys-devel/libtool     2.4-r1
        sys-devel/make        3.82-r1
        sys-freebsd/freebsd-lib (none)
        sys-kernel/linux-headers 3.4
        sys-libs/glibc        2.14.1-r3
        sys-libs/uclibc       (none)

Extra Information for media-gfx/graphviz-2.26.3-r4:0::gentoo:
        >>> Running ebuild phase killold as paludisbuild:paludisbuild...
        >>> Starting builtin_killold
        >>> Done builtin_killold
        >>> Completed ebuild phase killold
        >>> Running ebuild phases initmisc infovars as paludisbuild:paludisbuild...
        >>> Starting builtin_initmisc
        >>> Done builtin_initmisc
        >>> Starting builtin_infovars
        ACCEPT_KEYWORDS=amd64
        CBUILD=x86_64-pc-linux-gnu
        CFLAGS=-march=amdfam10 -O2 -pipe
        CHOST=x86_64-pc-linux-gnu
        CONFIG_PROTECT= 
        CONFIG_PROTECT_MASK= 
        CPPFLAGS=
        CTARGET=
        CXXFLAGS=-march=amdfam10 -O2 -pipe
        DISTDIR=/var/distfiles
        FEATURES=
        FFLAGS=
        GENTOO_MIRRORS=
        INSTALL_MASK=
        LANG=
        LC_ALL=C
        LDFLAGS=-Wl,-O1 -Wl,--as-needed
        LINGUAS=de
        MAKEOPTS=-j22
        PORTAGE_COMPRESS=
        PORTAGE_COMPRESS_FLAGS=
        PORTAGE_CONFIGROOT=
        PORTAGE_RSYNC_EXTRA_OPTS=
        PORTAGE_RSYNC_OPTS=
        PORTAGE_TMPDIR=/var/tmp/paludis
        PORTDIR=/var/paludis/repositories/gentoo
        PORTDIR_OVERLAY=
        SYNC=
        USE=cairo nls amd64 alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_authn_alias apache2_modules_authn_anon apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_cgi apache2_modules_cgid apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_rewrite apache2_modules_setenvif apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias calligra_features_braindump calligra_features_flow calligra_features_karbon calligra_features_kexi calligra_features_krita calligra_features_plan calligra_features_sheets calligra_features_stage calligra_features_tables calligra_features_words cameras_ptp2 collectd_plugins_df collectd_plugins_interface collectd_plugins_irq collectd_plugins_load collectd_plugins_memory collectd_plugins_rrdtool collectd_plugins_swap collectd_plugins_syslog elibc_glibc gpsd_protocols_aivdm gpsd_protocols_ashtech gpsd_protocols_earthmate gpsd_protocols_evermore gpsd_protocols_fv18 gpsd_protocols_garmin gpsd_protocols_garmintxt gpsd_protocols_gpsclock gpsd_protocols_itrax gpsd_protocols_mtk3301 gpsd_protocols_navcom gpsd_protocols_nmea gpsd_protocols_ntrip gpsd_protocols_oceanserver gpsd_protocols_oldstyle gpsd_protocols_oncore gpsd_protocols_rtcm104v2 gpsd_protocols_rtcm104v3 gpsd_protocols_sirf gpsd_protocols_superstar2 gpsd_protocols_timing gpsd_protocols_tnt gpsd_protocols_tripmate gpsd_protocols_tsip gpsd_protocols_ubx input_devices_evdev input_devices_wacom kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text libreoffice_extensions_presenter-console libreoffice_extensions_presenter-minimizer linguas_de php_targets_php5-3 python_targets_python3_2 ruby_targets_ruby18 ruby_targets_ruby19 sane_backends_epson sane_backends_epson2 userland_GNU video_cards_fbdev video_cards_nouveau video_cards_nvidia xtables_addons_account xtables_addons_chaos xtables_addons_condition xtables_addons_delude xtables_addons_dhcpmac xtables_addons_fuzzy xtables_addons_geoip xtables_addons_iface xtables_addons_ipmark xtables_addons_ipp2p xtables_addons_ipset xtables_addons_ipv4options xtables_addons_length2 xtables_addons_logmark xtables_addons_lscan xtables_addons_pknock xtables_addons_psd xtables_addons_quota2 xtables_addons_rawnat xtables_addons_steal xtables_addons_sysrq xtables_addons_tarpit xtables_addons_tee amd64 
        USE_PYTHON=
        >>> Done builtin_infovars
        >>> Completed ebuild phases initmisc infovars
        >>> Running ebuild phase tidyup as paludisbuild:paludisbuild...
        >>> Starting builtin_tidyup
        rm -fr /var/tmp/paludis/media-gfx-graphviz-2.26.3-r4-info
        >>> Done builtin_tidyup
        >>> Completed ebuild phase tidyup
Comment 1 Franz Trischberger 2012-06-05 19:16:19 UTC
Finally solved. I simply had to turn off distcc :D
Comment 2 Daniel Santos 2015-01-29 17:08:31 UTC
What a wonderfully stupid error.
Comment 3 Pacho Ramos gentoo-dev 2015-10-03 09:32:57 UTC
Is this still failing with 2.38.0?
Comment 4 Alessandro Molari 2016-10-16 11:10:04 UTC
Created attachment 450380 [details]
build log (2016)
Comment 5 Alessandro Molari 2016-10-16 11:10:31 UTC
The issue is not resolved.
I'm having the same problem.