Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 417709

Summary: dev-ruby/ruby-opengl-0.60.1-r2 fails configure with ruby1.9 - cannot load such file -- mkrf
Product: Gentoo Linux Reporter: Franz Trischberger <franz.trischberger>
Component: [OLD] UnspecifiedAssignee: Gentoo Ruby Team <ruby>
Status: RESOLVED OBSOLETE    
Severity: normal CC: dagger
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log

Description Franz Trischberger 2012-05-27 05:55:47 UTC
ruby-opengl-0.60.1-r2 should depend on >=dev-ruby/mkrf-0.2.3-r2, because that version introduces ruby_target ruby19.

Reproducible: Always
Comment 1 Franz Trischberger 2012-05-27 05:58:13 UTC
Created attachment 313207 [details]
build log
Comment 2 Hans de Graaff gentoo-dev 2012-05-27 06:13:48 UTC
(In reply to comment #0)
> ruby-opengl-0.60.1-r2 should depend on >=dev-ruby/mkrf-0.2.3-r2, because
> that version introduces ruby_target ruby19.

There is no need for this since this should be handled automatically by the RUBY_TARGETS USE flags. I've just verified that this happens for me when emerging ruby-opengl when the older revision of mkrf is already installed.

How did you try to install ruby-opengl?
Comment 3 Franz Trischberger 2012-05-27 06:28:57 UTC
Simply a rebuild (I think because ruby-1.9 got installed) (using paludis).
I have enabled both ruby18 and ruby19. ruby-opengl-0.60.1-r2 has both ruby targets, mkrf-0.2.3-r1 only has ruby18.

I retried (downgrade mkrf, reinstall ruby-opengl), and it failed, again, same error.
Comment 4 Hans de Graaff gentoo-dev 2012-05-27 06:43:59 UTC
Adding dagger since this works for me with portage. I'm wondering if this is perhaps a bug in paludis, or whether we are doing something wrong somewhere that portage happens to make work anyway.
Comment 5 Hans de Graaff gentoo-dev 2013-10-29 16:21:51 UTC
Closing this since ruby-opengl-0.8.0 no longer depends on mkrf and there was no further feedback on this issue.