Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 415913

Summary: games-sports/speed-dreams new version 2.0 available - please update
Product: Gentoo Linux Reporter: n1ghtmare
Component: Current packagesAssignee: Gentoo Games <games>
Status: UNCONFIRMED ---    
Severity: enhancement CC: bugs, orzel, pacho
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.speed-dreams.org/
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 578918    
Bug Blocks:    
Attachments: speed-dreams-2.0.0.ebuild
metadata.xml
speed-dreams-1.4-2.0.ebuild.diff
speed-dreams-2.2.0.ebuild

Description n1ghtmare 2012-05-14 11:24:33 UTC
games-sports/speed-dreams new version 2.0 available - please update

Reproducible: Always
Comment 1 Patrick McMunn 2013-01-24 02:31:18 UTC
Created attachment 336686 [details]
speed-dreams-2.0.0.ebuild

On my system, the program compiles fine, and it starts fine so that I can navigate the menus, change settings, and so on. However, when I actually try to start a race, the program segfaults. Also, when installing, Portage complains about several of the shared libraries having insecure RPATHS. I've tried several cmake options without finding a fix for it. From what I gather, all the shared libraries have an RPATH during the build phase, but a small number of them are given a null RPATH during installation.

I've also written a live ebuild for Speed Dreams, and I have had no problem with segfaults, so the segfault problem seems to be an upstream issue. However, the RPATH issue still exists.

One more thing, I'm wondering whether it would be proper to slot this ebuild with "2" because all of the upstream defaults append "-2" to the binaries and install paths so that it should be possible to have Speed Dreams 1.4 and Speed Dreams 2 simultaneously installed (if anyone wished to do so).
Comment 2 Patrick McMunn 2013-01-24 02:32:46 UTC
Created attachment 336688 [details]
metadata.xml
Comment 3 Julian Ospald 2013-01-24 12:08:12 UTC
please attach a diff to the old ebuild
Comment 4 Patrick McMunn 2013-01-28 02:09:16 UTC
Created attachment 337064 [details, diff]
speed-dreams-1.4-2.0.ebuild.diff
Comment 5 Julian Ospald 2013-01-28 08:07:00 UTC
the useflags confuse me, couldn't we just add a "addons" flag to pull in all the additional tracks/cars/whatever?

games.eclass has to be last in inherit line (don't forget to call cmake-utils_src_compile explicitly then)

DSD_BINDIR and DSD_DATADIR should not be hardcoded, but use $GAMES_BINDIR and $GAMES_DATADIR
if that is creating problems with CMAKE_INSTALL_PREFIX then you have to either patch or work around it

for the icon do:
newicon -s scalable data/data/icons/icon.png ${PN}-2.svg

and then inherit gnome2-utils and do:
pkg_preinst() { games_pkg_preinst ; gnome2_icon_savelist ; }
pkg_postinst() { games_pkg_postinst ; gnome2_icon_cache_update ; }
pkg_postrm() { gnome2_icon_cache_update ; }

did you test with media-libs/libpng:1.2 when media-libs/libpng:0 is _not_ installed? 1.2 does not even provide headers and is only available for backwardscompat, so in most cases we just want :0

It does not happen often that plain media-libs/libsdl suffices. Double check if we need any useflags for libsdl.
Also, libsdl, enet and jpeg only being build-time deps is uncommon, did you double check?

why SLOT=2? That means we are able to install them in parallel. Do we need/want that?

you need eutils inherited, because you are calling newicon/make_desktop_entry
Comment 6 Wojciech Myrda 2016-04-03 12:28:54 UTC
Created attachment 429556 [details]
speed-dreams-2.2.0.ebuild

There is new version 2.2 available. I tried to update the ebuild but I could not get it to configure as I only found "partial build patch" for version 2.0. Maybe other will have more luck.

I also did try to incorporate some of the below hints from Julian and also added stuff required by new INSTALL file instructions including out of tree library https://bugs.gentoo.org/show_bug.cgi?id=578918 for which I believe most appropriate place is dev-games/libsolid
Comment 7 Wojciech Myrda 2016-04-03 12:33:53 UTC
I just found that Arch Linux lists fewer dependencies than originaly included but has extra openscenegraph as dependency. https://www.archlinux.org/packages/community/i686/speed-dreams/

I didn't find any info at speed games about it but might be worth checking as well
Comment 8 Wojciech Myrda 2016-06-27 12:54:21 UTC
The update to the game has been released to version 2.2.1

What's new:
This is a maintenance release that primarily fixes a sticking throttle issue when driving with the keyboard. 

Please fix the ebuild to include that game in the tree
Comment 9 fuse809 2017-04-22 00:24:48 UTC
Version 2.1 is out now.
Comment 10 DrSlony 2018-08-17 08:42:05 UTC
The version of games-sports/speed-dreams in Portage is 1.4.0 from 2010! Please update to 2.1.
Comment 11 DrSlony 2018-08-17 08:43:11 UTC
In fact scratch that, 2.1 is very old as well. 2.2.2-rc2 would be a good choice until 2.2.2-final comes out.
https://sourceforge.net/p/speed-dreams/code/HEAD/tree/tags/