Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 415329

Summary: dev-util/kbuild-0.1.9998_pre20110817 - gcc: argument to '-o' is missing
Product: Gentoo Linux Reporter: Vladimir <v_2e>
Component: Current packagesAssignee: Alessio Cassibba (X-Drum) <swapon>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bkohler, polynomial-c
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: buld.log

Description Vladimir 2012-05-10 06:54:33 UTC
gcc: argument to '-o' is missing
kmk: *** [/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/out/linux.amd64/release/obj/kDep/kDep.o] Error 1
The failing command:
@gcc -c -O2 -g -O3 -m64 -I/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/src/lib -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=9998 -DKBUILD_OS_LINUX -DKBUILD_ARCH_AMD64 -DNDEBUG -Wp,-MD,/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/out/linux.amd64/release/obj/kDep/kDep.o.dep -Wp,-MT,/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/out/linux.amd64/release/obj/kDep/kDep.o -Wp,-MP -o /var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/out/linux.amd64/release/obj/kDep/kDep.o /var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/src/lib/kDep.c
kmk: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817'
make: *** [/var/tmp/portage/dev-util/kbuild-0.1.9998_pre20110817/work/kBuild-0.1.9998-pre20110817/out/linux.amd64/release/bootstrap/ts-stage2-build] Error 2
kBuild/env.sh: info: rc=2: make -f bootstrap.gmk AUTORECONF=true

Reproducible: Always




 emerge --info
Portage 2.2.0_alpha102 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.15-r1, 3.3.4-gentoo x86_64)
=================================================================
System uname: Linux-3.3.4-gentoo-x86_64-Mobile_AMD_Sempron-tm-_Processor_3800+-with-gentoo-2.1
Timestamp of tree: Wed, 09 May 2012 23:35:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p28
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo sage-on-gentoo local
Installed sets: 
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/home/Install/GNU-Linux/distfiles/"
FEATURES="assume-digests binpkg-logs distcc distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://portage.org.ua/ ftp://portage.org.ua/                 http://gentoo.iteam.net.ua/                 ftp://gentoo.kiev.ua/ http://gentoo.kiev.ua/ftp/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru uk"
MAKEOPTS="-j2"
PKGDIR="/home/Install/GNU-Linux/binpkg/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sage-on-gentoo /usr/local/overlays"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit 7zip X a52 aac aalib acpi alsa amd64 amrnb amrwb apm ass bash-completion bzip2 cairo cli consolekit cracklib crypt ctype curl cxx dbus dga djvu dri dts dvd encode exif expat faad fbcon fbcondecor festival ffmpeg fftw flac freetds fuse gd gdbm geoip gif git glut gmp gnuplot gnutls gsl gstreamer gtk gtk3 hddtemp iconv idn imagemagick imlib irc jabber jack jbig jpeg lame laptop latex libcaca libnotify libsamplerate lm_sensors lua lzo mad matroska mmap mmx mmxext mng modplug modules mudflap multilib nas ncurses nforce2 nls nptl nvidia ogg openal opencore-amr opengl openmp pam pdf plotutils pmu png policykit pppd profile python qt3support qt4 readline rtc samba sasl sdl session shorten skins slang sndfile sockets speex spell sse sse2 ssl startup-notification svg syslog systray taglib tcl tcpd theora threads timidity truetype udev unicode usb vorbis wavpack webkit wmf x264 xattr xcb xcomposite xinerama xml xorg xosd xpm xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru uk" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Vladimir 2012-05-10 06:55:14 UTC
Created attachment 311313 [details]
buld.log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-05-10 13:20:39 UTC
Needless to say it ought to respect CC as well.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2012-05-10 13:20:56 UTC
And CFLAGS.
Comment 4 Ben Kohler gentoo-dev 2012-05-24 12:48:04 UTC
This looks an awful lot like bug 255371.  It doesn't like distcc.
Comment 5 Greg Trigg 2012-09-17 21:31:05 UTC
What if you have '-distcc' and '-ccache' set, but still have the problem?
Comment 6 Greg Trigg 2012-09-17 21:34:02 UTC
Nevermind.  I forgot that make.conf moved.  I was editing the wrong one.  I guess I better delete/move the old one.
Comment 7 siebz0r 2012-09-24 05:41:01 UTC
Ben Kohler is right. I just ran into this problem, turning off distcc fixes the issue. I'm using ccache and distcc, so I'd like to confirm that this is a duplicate of #255371.
Comment 8 Patrick McMunn 2012-12-27 20:53:03 UTC
I ran into the same bug with kbuild-0.1.9998_pre20120806. I am not using ccache, but I am using distcc. Disabling FEATURES="distcc" allowed the build to complete successfully. Should this be considered an upstream bug (or at least reported to upstream)? I checked their bug tracker, and I did not see a ticket on this issue. In any case, I believe this is indeed a duplicate of bug 255371.
Comment 9 Konstantin M√ľnning 2013-03-11 10:21:45 UTC
(In reply to comment #7)
I just ran into this problem as well, turning off distcc fixes the issue for me. This seems to be a duplicate of #255371 so please mark one of the bugs accordingly.

If no better solution is known yet force disabling distcc feature in the ebuild should do.
Comment 10 Ben Kohler gentoo-dev 2013-03-11 15:00:09 UTC

*** This bug has been marked as a duplicate of bug 255371 ***