Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 415107

Summary: media-libs/gegl-0.2.0: suspect runtime-depend on dev-lang/perl
Product: Gentoo Linux Reporter: nzqr <candysnell>
Component: Current packagesAssignee: Hanno Böck <hanno>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info output

Description nzqr 2012-05-08 08:58:55 UTC
I haven't found any perl scripts in gegl package, this runtime dependency seems to be wrong.

Reproducible: Always
Comment 1 nzqr 2012-05-18 15:50:06 UTC
Created attachment 312201 [details]
emerge --info output
Comment 2 Sebastian Pipping gentoo-dev 2013-04-28 15:23:26 UTC
Had a closer look now:

# ebuild gegl-0.2.0-r1.ebuild manifest clean configure |& fgrep -i perl
checking for perl5... no
checking for perl... /usr/bin/perl
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.16.3
checking for perl5... /usr/bin/perl

# fgrep INTLTOOL_PERL /var/tmp/portage/media-libs/gegl-0.2.0-r1/work/gegl-0.2.0/m4/intltool.m4 
AC_PATH_PROG(INTLTOOL_PERL, perl)
if test -z "$INTLTOOL_PERL"; then
$INTLTOOL_PERL -e "use 5.8.1;" > /dev/null 2>&1
   IT_PERL_VERSION=`$INTLTOOL_PERL -e "printf '%vd', $^V"`
   if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then

So I dare closing as invalid for now.  Still, thanks for the report!
Comment 3 Sebastian Pipping gentoo-dev 2013-04-28 15:30:18 UTC
That was too quick...

+  28 Apr 2013; Sebastian Pipping <sping@gentoo.org> gegl-0.2.0-r1.ebuild,
+  gegl-9999.ebuild:
+  Move perl from RDEPEND to DEPEND (bug #415107), thanks to nzqr
+