Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 414901

Summary: net-dialup/ppp-2.4.5-r2 - mlppp/l2tp (openl2tp) support broken
Product: Gentoo Linux Reporter: Jaco Kroon <jaco>
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: CONFIRMED ---    
Severity: normal CC: base-system
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://http://forums.openl2tp.org/viewtopic.php?f=4&t=102
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: ppp-multilink-support.patch

Description Jaco Kroon 2012-05-06 17:18:05 UTC
Due to a bug in the openl2tp.so pppd plugin the slave pppd processes gets killed and torn down every two minutes.

Reproducible: Always
Comment 1 Jaco Kroon 2012-05-06 17:20:00 UTC
Created attachment 311003 [details, diff]
ppp-multilink-support.patch

Patch to fix the issue.

I've also reported upstream to samba/ppp, however, I have no idea how to dig those reports back out of the ticket system they've got, thus I just linked to the same issue I posted to openl2tp.org.
Comment 2 Pacho Ramos gentoo-dev 2015-01-07 12:23:19 UTC
is this still valid with 2.4.7?
Comment 3 Jaco Kroon 2015-01-14 15:05:28 UTC
Hi,

I have not tested, but a quick glance at the code shows that it's still valid, and I still "autopatch" all my ppp installs with this exact patch, and they are working correctly.  No new releases op openl2tpd has been released that I'm aware of so there were no changes on that side that would negate the need for this.

Kind Regards,
Jaco