Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 414857

Summary: net-firewall/iptables-1.4.12.1-r1 and -1.4.13: hack to use saner kernel-headers should be replaced by compile option --with-ksource
Product: Gentoo Linux Reporter: cilly <cilly>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alexanderyt
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: diff of iptables-1.4.12.1-r1.ebuild using ksource instead of remaking include/linux/{kernel,types}.h

Description cilly 2012-05-06 11:32:20 UTC
Created attachment 310955 [details, diff]
diff of iptables-1.4.12.1-r1.ebuild using ksource instead of remaking include/linux/{kernel,types}.h

The following code:


src_prepare() {
    # use the saner headers from the kernel
    rm -f include/linux/{kernel,types}.h

    # Only run autotools if user patched something
    epatch_user && eautoreconf || elibtoolize
}

should be removed and replaced by the configure option --with-ksource which let iptables compile against saner kernel headers.
Comment 1 SpanKY gentoo-dev 2013-04-27 17:46:32 UTC
(In reply to comment #0)

that's an even more unstable option than relying on userland headers

*** This bug has been marked as a duplicate of bug 276737 ***