Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 414133

Summary: =dev-libs/zthread-2.3.2-r2 not compiles with gcc-4.7
Product: Gentoo Linux Reporter: David Kredba <nheghathivhistha>
Component: [OLD] LibraryAssignee: C++ Team [disbanded] <cpp+disabled>
Status: RESOLVED FIXED    
Severity: normal CC: b.buschinski, dilfridge
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 390247    

Description David Kredba 2012-04-30 16:06:50 UTC
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../include -O2 -pipe -ggdb -march=native -Wall -DNDEBUG -O2 -pipe -ggdb -marc
h=native -Wall -DNDEBUG -c CountingSemaphore.cxx  -fPIC -DPIC -o .libs/CountingSemaphore.o
In file included from ../include/zthread/ConcurrentExecutor.h:26:0,
                 from ConcurrentExecutor.cxx:23:
../include/zthread/PoolExecutor.h:58:9: warning: 'ZThread::PoolExecutor' has a field 'ZThread::PoolExecutor::_impl' whose type uses the anonym
ous namespace [enabled by default]
In file included from ConditionImpl.h:26:0,
                 from Condition.cxx:24:
../include/zthread/Guard.h: In instantiation of 'ZThread::Guard<LockType, LockingPolicy>::Guard(ZThread::Guard<U, V>&) [with U = ZThread::Fast
Lock; V = ZThread::LockedScope; LockType = ZThread::FastLock; LockingPolicy = ZThread::UnlockedScope]':
ConditionImpl.h:235:45:   required from 'void ZThread::ConditionImpl<List>::wait() [with List = ZThread::fifo_list]'
Condition.cxx:52:17:   required from here
../include/zthread/Guard.h:431:5: error: 'extract' was not declared in this scope, and no declarations were found by argument-dependent lookup
 at the point of instantiation [-fpermissive]
../include/zthread/Guard.h:431:5: note: declarations in dependent base 'ZThread::LockHolder<ZThread::FastLock>' are not found by unqualified l
ookup
../include/zthread/Guard.h:431:5: note: use 'this->extract' instead
/bin/sh ../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../include   -O2 -pipe -ggdb -march=native -Wall -
DNDEBUG  -O2 -pipe -ggdb -march=native -Wall -DNDEBUG -c -o FastMutex.lo FastMutex.cxx
make[3]: *** [Condition.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../include -O2 -pipe -ggdb -march=native -Wall -DNDEBUG -O2 -pipe -ggdb -marc
h=native -Wall -DNDEBUG -c FastMutex.cxx  -fPIC -DPIC -o .libs/FastMutex.o
In file included from SemaphoreImpl.h:26:0,
                 from CountingSemaphore.cxx:24:
../include/zthread/Guard.h: In instantiation of 'ZThread::Guard<LockType, LockingPolicy>::Guard(ZThread::Guard<U, V>&) [with U = ZThread::Fast
Lock; V = ZThread::LockedScope; LockType = ZThread::FastLock; LockingPolicy = ZThread::UnlockedScope]':
SemaphoreImpl.h:159:45:   required from 'void ZThread::SemaphoreImpl<List>::acquire() [with List = ZThread::fifo_list]'
CountingSemaphore.cxx:51:20:   required from here
../include/zthread/Guard.h:431:5: error: 'extract' was not declared in this scope, and no declarations were found by argument-dependent lookup
 at the point of instantiation [-fpermissive]
../include/zthread/Guard.h:431:5: note: declarations in dependent base 'ZThread::LockHolder<ZThread::FastLock>' are not found by unqualified l
ookup
../include/zthread/Guard.h:431:5: note: use 'this->extract' instead
make[3]: *** [CountingSemaphore.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-libs/zthread-2.3.2-r2/work/ZThread-2.3.2/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/zthread-2.3.2-r2/work/ZThread-2.3.2/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/dev-libs/zthread-2.3.2-r2/work/ZThread-2.3.2/src'
make: *** [all-recursive] Error 1
 .[31;01m*.[0m ERROR: dev-libs/zthread-2.3.2-r2 failed (compile phase):
 .[31;01m*.[0m   emake failed

Reproducible: Always




Portage 2.2.0_alpha101 (default/linux/amd64/10.0/desktop, gcc-4.7.0, glibc-2.15-r1, 3.3.4-gentoo x86_64)                                      
=================================================================                                                                             
System uname: Linux-3.3.4-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.1                                           
Timestamp of tree: Sat, 28 Apr 2012 06:00:01 +0000                                                                                            
app-shells/bash:          4.2_p24-r1                                                                                                          
dev-java/java-config:     2.1.11-r3                                                                                                           
dev-lang/python:          2.7.3-r1, 3.2.3                                                                                                     
dev-util/cmake:           2.8.7-r5                                                                                                            
dev-util/pkgconfig:       0.26                                                                                                                
sys-apps/baselayout:      2.1                                                                                                                 
sys-apps/openrc:          0.9.9.3                                                                                                             
sys-apps/sandbox:         2.5                                                                                                                 
sys-devel/autoconf:       2.13, 2.69                                                                                                          
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5                                                                                            
sys-devel/binutils:       2.22-r1                                                                                                             
sys-devel/gcc:            4.6.3, 4.7.0                                                                                                        
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ggdb -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ggdb -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs compressdebug distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe -ggdb -march=native"
GENTOO_MIRRORS="ftp://gentoo.mirror.web4u.cz/"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="cs en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="echo"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gmp gpm gtk iconv idn ithreads java jpeg jpeg2k kde lcms ldap libnotify lzma mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly objc objc++ objc-gc odbc ogg openexr opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 quad readline samba sasl sdl session slang speex spell sqlite sse sse2 sse4_1 ssl ssse3 startup-notification svg sysfs tcl tcpd threads tiff tk truetype udev unicode usb v4l vorbis wavpack wxwidgets x264 xattr xcb xinerama xml xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2 canon hp215 sony_dscf1 sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en" LIRC_DEVICES="inputlirc pctv hauppauge hauppauge_dvb devinput" PHP_TARGETS="php5-4" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 David Kredba 2012-05-06 11:20:19 UTC
Google found Debian patch at http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1006697.html.
Comment 2 David Kredba 2012-05-06 11:26:38 UTC
With the patch gcc 4.7.0 is happy.
Comment 3 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-06-23 11:49:13 UTC
+  23 Jun 2012; Kacper Kowalik <xarthisius.kk@gmail.com>
+  +files/zthread-2.3.2-gcc47.patch, zthread-2.3.2-r2.ebuild:
+  Fix building with gcc4.7 wrt #414133 by David Kredba
+  <nheghathivhistha@gmail.com>
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2012-10-09 20:03:20 UTC
*** Bug 424279 has been marked as a duplicate of this bug. ***