Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 413467

Summary: app-emulation/virtualbox: .../cr_bufferobject.h:12:33: fatal error: state/cr_statefuncs.h: No such file or directory
Product: Gentoo Linux Reporter: Yann Leprince <y>
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED FIXED    
Severity: normal CC: admin, b4b1, binki, bkohler, patrick, swapon, zbox
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: End of build.log
virtualbox-4.1.24-build.log
emerge--info.txt
Build log for app-emulation/virtualbox-4.2.24

Description Yann Leprince 2012-04-25 09:00:47 UTC
app-emulation/virtualbox-4.1.12 sometimes fails to compile when parallel build is enabled (MAKEOPTS="-j5 -l4").

Reproducible: Sometimes

Steps to Reproduce:
1. Run `emerge =app-emulation/virtualbox-4.1.12' with MAKEOPTS set for parallel build
2a. with luck, enjoy the compilation failure
2b. otherwise, repeat step 1 until you get to step 2a
Actual Results:  
VirtualBox fails to compile (well, not always : in my experience, once in 3 tries).

Expected Results:  
VirtualBox should be compiled without error.

When using MAKEOPTS="-j1", the compilation succeeds (tried twice).

$ emerge -pqv =app-emulation/virtualbox-4.1.12
[ebuild   R   ] app-emulation/virtualbox-4.1.12  USE="alsa opengl pam qt4 -additions -doc -extensions -headless -java -pulseaudio -python -sdk -vboxwebsrv -vnc" 


$ emerge --info =app-emulation/virtualbox-4.1.12
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-_i5-2430M_CPU_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 25 Apr 2012 00:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE Ximian-logos"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb1"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch webrsync-gpg"
FFLAGS="-march=native -O2 -pipe -ggdb1"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr en"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-4"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/yann/portage-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdr eds emacs emboss encode epiphany evo exif fam fat fftw firefox flac fontconfig fortran ftp gdbm gdu gif gmp gnome gnome-keyring gnome-online-accounts gphoto2 graphviz gstreamer gtk gtk3 gtkstyle iconv ipv6 jbig jingle jpeg jpeg2k latex lcms ldap libnl libnotify lxde lzma mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib musepack nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcmcia pcre pdf png policykit ppds pppd qt3support qt4 readline scanner schroedinger sdl session smartcard smp socialweb speex spell sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg sysfs tcpd theora threads tiff truetype udev unicode usb vaapi vorbis wifi wmf wxwidgets x264 xcb xft xml xmp xorg xulrunner xv xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-4.1.12 was built with the following:
USE="alsa (multilib) opengl pam qt4 -additions -doc -extensions -headless -java -pulseaudio -python -sdk -vboxwebsrv -vnc"
Comment 1 Yann Leprince 2012-04-25 09:03:38 UTC
Created attachment 310001 [details]
End of build.log

The end of build.log, from the earliest error on.
Comment 2 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2013-02-27 23:45:21 UTC
Created attachment 340432 [details]
virtualbox-4.1.24-build.log

Still affects stable virtualbox-4.1.24.
Comment 3 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2013-02-27 23:56:49 UTC
Created attachment 340434 [details]
emerge--info.txt
Comment 4 Konstantin Münning 2013-05-06 20:45:22 UTC
It has probably the same cause - virtualbox-4.2.12 fails to compile (always) when distcc is used with same symptoms as this bug. Setting MAKEFLAGS="-j1" does not help but with FEATURES="-distcc" it compiles as expected. If interested I can add a build log and/or open a new bug.
Comment 5 Ben Kohler gentoo-dev 2013-11-18 19:42:10 UTC
I have not seen any parallel make failures in vbox in quite some time, is this still occurring?
Comment 6 Yann Leprince 2014-08-08 08:49:11 UTC
Created attachment 382510 [details]
Build log for app-emulation/virtualbox-4.2.24

This still happens here with app-emulation/virtualbox-4.2.24. The bug hit me during the 4th try, after 3 successful builds.

emerge --info =virtualbox-4.2.24
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.19-r1, 3.14.14-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.14.14-gentoo-x86_64-Intel-R-_Core-TM-_i5-2430M_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:     3925292 total,   1461068 free
KiB Swap:    3998716 total,   3990460 free
Timestamp of tree: Mon, 04 Aug 2014 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.7, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo yann-overlay
Installed sets: @brainvisa
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb1 -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb1 -frecord-gcc-switches"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-march=native -O2 -pipe -ggdb1 -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs cgroup collision-protect compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-march=native -O2 -pipe -ggdb1 -frecord-gcc-switches"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/     ftp://ftp.free.fr/mirrors/ftp.gentoo.org/     http://mirrors.linuxant.fr/distfiles.gentoo.org/     ftp://mirrors.linuxant.fr/distfiles.gentoo.org/     ftp://gentoo.imj.fr/pub/gentoo/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-4"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/yann/yann-overlay"
USE="X a52 aac acl acpi alsa amd64 avx bash-completion bazaar berkdb bluetooth branding bzip2 cairo caps cdda cdparanoia cdr cli colord consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdr emacs emboss encode exif fam fat ffmpeg fftw firefox flac fontconfig fortran gdbm gif git gnutls gphoto2 gpm graphviz gstreamer gtk gtk3 iconv idn inotify ipv6 jbig jingle jpeg jpeg2k ladspa latex lcms libnotify libsamplerate luatex lzma lzo mad man matroska mmx mng modules mp3 mp4 mpd mpeg mtp multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp opus pam pango pch pcmcia pcre pdf png policykit postscript ppds qt3support qt4 readline resolvconf rss scanner sdl session smp sound speex spell sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vorbis wifi wmf x264 xattr xcb xetex xft xml xmp xv xvid zlib" ABI_X86="64" CAMERAS="ptp2" CURL_SSL="gnutls" ELIBC="glibc" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LIBREOFFICE_EXTENSIONS="pdfimport presenter-console presenter-minimizer" LINGUAS="fr_FR fr en_GB en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-4.2.24 was built with the following:
USE="alsa opengl pam qt4 -additions -doc -extensions -headless -java -pulseaudio -python -sdk -vboxwebsrv -vnc" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
Comment 7 Alex Xu (Hello71) 2016-03-22 19:30:44 UTC
*** Bug 577716 has been marked as a duplicate of this bug. ***
Comment 8 Yarda 2016-03-22 19:33:04 UTC
Proposed fix:

https://577716.bugs.gentoo.org/attachment.cgi?id=428540

10x rebuild w/wo patch and MAKEOPTS=-j4, results:

without the patch: 8x build failure
with the patch: 0x build failure

So it seems the patch works.
Comment 9 Zentoo 2016-06-09 07:38:38 UTC
The problem still occurs with app-emulation/virtualbox-5.0.20.

Please include the proposed patch from Yarda:
https://577716.bugs.gentoo.org/attachment.cgi?id=428540

Tested and working with epatch on latest version too.
Comment 10 Richard Li 2017-02-01 12:26:10 UTC
Still happens here with stable ebuild app-emulation/virtualbox-5.0.32.

Applied Yarda's patch and it built fine:
https://577716.bugs.gentoo.org/attachment.cgi?id=428540
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2017-02-03 15:14:59 UTC
commit 5bd8521042bfc356fd20c4505a6c6780d9f4510b
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Fri Feb 3 16:12:23 2017

    app-emulation/virtualbox: Fixed parallel build issue (bug #413467).

    Also attempt to finally fix creation and installation of docs
    (bug #554932).

    Package-Manager: Portage-2.3.3, Repoman-2.3.1


Would be nice if someone could report back if the same problem needs to be fixed in virtualbox-5.1.x
Comment 12 Yarda 2017-02-08 10:53:40 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #11)
> commit 5bd8521042bfc356fd20c4505a6c6780d9f4510b
> Author: Lars Wendler <polynomial-c@gentoo.org>
> Date:   Fri Feb 3 16:12:23 2017
> 
>     app-emulation/virtualbox: Fixed parallel build issue (bug #413467).
> 
>     Also attempt to finally fix creation and installation of docs
>     (bug #554932).
> 
>     Package-Manager: Portage-2.3.3, Repoman-2.3.1
> 
> 
> Would be nice if someone could report back if the same problem needs to be
> fixed in virtualbox-5.1.x

Thanks. I tried to rebuild virtualbox-5.1.14 twice and it seems to work without patching. But maybe I am wrong, I didn't test it thoroughly, I only did two rebuilds. IIRC last virtualbox which I patches was 5.1.6.