Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 411803

Summary: x11-libs/qt-script fails to build with gcc-4.7
Product: Gentoo Linux Reporter: Andrew John Hughes <gnu_andrew>
Component: [OLD] LibraryAssignee: Qt Bug Alias <qt>
Status: RESOLVED FIXED    
Severity: normal Keywords: PATCH, REVIEWED, UPSTREAM
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://qt.gitorious.org/qt/qt/commit/7ac8d8597db1f58b11338f91fb27f6ad8696b34b
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 390247    

Description Andrew John Hughes 2012-04-12 23:22:22 UTC
A patch is available here:

http://www.linuxfromscratch.org/patches/blfs/svn/qt-everywhere-opensource-src-4.8.1-gcc_fix-1.patch

Reproducible: Always




Portage 2.2.0_alpha93 (default/linux/amd64/10.0/desktop, gcc-4.7.0-pre9999, glibc-2.14.1-r2, 3.3.1-gentoo.rivendell x86_64)
=================================================================
System uname: Linux-3.3.1-gentoo.rivendell-x86_64-Intel-R-_Xeon-R-_CPU_X5482_@_3.20GHz-with-gentoo-2.1
Timestamp of tree: Thu, 12 Apr 2012 01:15:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.7.0_pre9999::toolchain
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Comment 1 Andrew John Hughes 2012-04-12 23:22:41 UTC
Add gcc 4.7 blocker.
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2012-04-13 11:14:34 UTC
Patch available upstream as well

http://qt.gitorious.org/qt/qt/commit/7ac8d8597db1f58b11338f91fb27f6ad8696b34b
Comment 3 Davide Pesavento gentoo-dev 2012-04-13 12:11:37 UTC
The patch is for JavaScriptCore, so I guess x11-libs/qt-webkit is affected as well..
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2012-04-13 12:49:47 UTC
(In reply to comment #3)
> The patch is for JavaScriptCore, so I guess x11-libs/qt-webkit is affected
> as well..
Yes definitely. Personally, I'd rather avoid patching qt-webkit/qt-core once again and wait for Qt-4.8.2. GCC-4.7 porting is not an urgent issue
Comment 5 Davide Pesavento gentoo-dev 2012-04-13 13:14:57 UTC
Well, we can add the patch without revbumping, since it's just a build issue.
Comment 6 Davide Pesavento gentoo-dev 2012-04-15 13:31:39 UTC
(In reply to comment #3)
> The patch is for JavaScriptCore, so I guess x11-libs/qt-webkit is affected
> as well..

No, I was wrong. qt-webkit uses src/3rdparty/webkit/Source/JavaScriptCore, which has very different code (more recent I think), thus the patch doesn't apply to qt-webkit.
Comment 7 Davide Pesavento gentoo-dev 2012-04-15 13:41:43 UTC
Committed, thanks for reporting.