Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 410421

Summary: auth: PAM unable to resolve symbol: pam_sm_open_session
Product: Gentoo Linux Reporter: Yann Ormanns <yann>
Component: [OLD] Core systemAssignee: PAM Gentoo Team (OBSOLETE) <pam-bugs+disabled>
Status: RESOLVED OBSOLETE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Yann Ormanns 2012-04-01 10:58:28 UTC
one of my systems logs the following errors a few hundred times per day:
(I deleted timestamps and hostnames to keep the quotes short)
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session

An example how it looks in /var/log7auth:
sudo:   zabbix : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/sbin/iptstate -1
sudo: pam_unix(sudo:session): session opened for user root by (uid=103)
sudo: pam_unix(sudo:session): session closed for user root
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
auth: PAM unable to resolve symbol: pam_sm_open_session
auth: PAM unable to resolve symbol: pam_sm_close_session
sudo:   zabbix : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/sbin/iptstate -1

The problem seems to be not reproducable, it only occurs sporadically. Sometimes a few times per hour, sometimes only after some hours.

This are the pam-related packages I use:
sys-auth/pambase:  20101024-r2!b
(cracklib sha512 -consolekit -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -selinux)

sys-libs/pam-1.1.5
(berkdb cracklib elibc_glibc nls -audit -debug -elibc_FreeBSD -nis -selinux -test -vim-syntax)

virtual/pam-0

Of course, I rebuilt pam yet, but without success.

The output of emerge --info:
Portage 2.1.10.49 (hardened/linux/amd64, gcc-4.5.3, glibc-2.13-r4, 3.0.4-hardened-r1 x86_64)
=================================================================
System uname: Linux-3.0.4-hardened-r1-x86_64-AMD_Athlon-tm-_II_X2_240e_Processor-with-gentoo-2.0.3
Timestamp of tree: Sun, 01 Apr 2012 01:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync15.de.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 audioscrobbler berkdb bzip2 cli cracklib crypt cups cxx dri gdbm geoip gpm hardened iconv justify lastfm mmx modules mudflap multilib mysql ncurses nls nptl nptlonly openmp pam pax_kernel pcre php pppd readline sasl session smbclient sse sse2 ssl symlink sysfs syslog tcpd unicode urandom vhosts xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Best regards,
Yann
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-04-02 22:00:21 UTC
Can you please post your /etc/pam.d/sudo, /etc/pam.d/system-auth ? Thanks
Comment 2 Yann Ormanns 2012-04-03 05:41:14 UTC
/etc/pam.d/sudo

# File autogenerated by pamd_mimic in pam eclass


auth    include         system-auth
account include         system-auth
session include         system-auth
------
/etc/pam.d/system-auth

auth            required        pam_env.so 
auth            required        pam_unix.so try_first_pass likeauth nullok 
auth            optional        pam_permit.so
 
account         required        pam_unix.so 
account         optional        pam_permit.so
 
password        required        pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3 
password        required        pam_unix.so try_first_pass use_authtok nullok sha512 shadow 
password        optional        pam_permit.so
 
session         required        pam_limits.so 
session         required        pam_env.so 
session         required        pam_unix.so 
session         optional        pam_permit.so
Comment 3 Yann Ormanns 2012-05-22 05:00:57 UTC
On May 20th, I updated sudo to version 1.8.5. Since then, the error did not occur anymore.

Best regards,
Yann