Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 409691

Summary: media-gfx/blender-2.49b-r2 - In function ‘cinema_parameters’: source/blender/imbuf/intern/jp2.c:331:29: error: ‘false’ undeclared (first use in this function)
Product: Gentoo Linux Reporter: Mira Ressel <aranea>
Component: Current packagesAssignee: Luca Barbato <lu_zero>
Severity: normal CC: Bernd.Feige, graphics+disabled, nbowler, psdasilva, simon
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info
build log
Patch to source/blender/imbuf/intern/jp2.c

Description Mira Ressel 2012-03-25 19:55:54 UTC
Created attachment 306639 [details]
emerge --info

media-gfx/blender-2.49b-r2 fails in the src_compile phase with the following error message:

Compiling ==> 'jp2.c'
source/blender/imbuf/intern/jp2.c: In function ‘cinema_parameters’:
source/blender/imbuf/intern/jp2.c:331:29: error: ‘false’ undeclared (first use in this function)
source/blender/imbuf/intern/jp2.c:331:29: note: each undeclared identifier is reported only once for each function it appears in
source/blender/imbuf/intern/jp2.c: In function ‘imb_savejp2’:
source/blender/imbuf/intern/jp2.c:720:9: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
scons: *** [/var/tmp/portage/media-gfx/blender-2.49b-r2/work/build/linux2/source/blender/imbuf/intern/jp2.o] Error 1
scons: building terminated because of errors.
 * ERROR: media-gfx/blender-2.49b-r2 failed (compile phase):
 *   !!! Please add "${S}/scons.config" when filing bugs reports \
 *      to

There seems to be something wrong with includes.

Last time, 16 Nov 2011, everything went right. Unfortunately, I can't easily find out which packages where updated since then, as I did an #emerge -e world inbetween.

PS: I would like to attach the scons.config as mentioned in the error message, but I can't find it anywhere, neither in $S nor somewhere else in /var/tmp/portage.
Comment 1 Mira Ressel 2012-03-25 19:56:45 UTC
Created attachment 306641 [details]
build log
Comment 2 Krzysiek 2012-03-25 20:55:49 UTC
The same error with media-gfx/blender-2.60a.
Comment 3 Mira Ressel 2012-03-26 07:49:27 UTC
(In reply to comment #2)
> The same error with media-gfx/blender-2.60a.

media-gfx/blender-2.60a works for me.
Comment 4 aditsu 2012-03-28 22:07:10 UTC
blender-2.60a still fails for me:

Compiling ==> 'jp2.c'
source/blender/imbuf/intern/jp2.c: In function ‘cinema_parameters’:
source/blender/imbuf/intern/jp2.c:328:29: error: ‘false’ undeclared (first use in this function)
Comment 5 Bernd Feige 2012-03-31 13:00:16 UTC
This is a duplicate of, the 1-line patch given there would work for blender-2.49 as well if it wasn't for a 'static' keyword being added to the line above... I attach a patch for blender-2.49.
Comment 6 Bernd Feige 2012-03-31 13:01:11 UTC
Created attachment 307277 [details, diff]
Patch to source/blender/imbuf/intern/jp2.c
Comment 7 Mira Ressel 2012-03-31 16:09:11 UTC

*** This bug has been marked as a duplicate of bug 409283 ***