Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 407357

Summary: stabilize =app-emulation/spice-0.10.0 and =app-emulation/spice-protocol-0.10.1
Product: Gentoo Linux Reporter: Doug Goldstein (RETIRED) <cardoe>
Component: New packagesAssignee: Tiziano Müller (RETIRED) <dev-zero>
Status: RESOLVED FIXED    
Severity: normal CC: tomka
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 373997    

Description Doug Goldstein (RETIRED) gentoo-dev 2012-03-08 01:38:15 UTC
stabilize =app-emulation/spice-0.10.0

target keywords: amd64 x86
Comment 1 Tiziano Müller (RETIRED) gentoo-dev 2012-03-08 08:25:00 UTC
Please stabilize spice-0.10.1 since it satisfies the 30-day rule and is a bugfix-release
Comment 2 Doug Goldstein (RETIRED) gentoo-dev 2012-03-08 14:44:59 UTC
Problem is that it's not even keyworded on ~x86 due to the libcacard depend. We can have amd64 stabilize 0.10.1 and x86 stabilize 0.10.0. Frustrating thing is that 0.10.1 fixed many x86 things upstream.
Comment 3 Agostino Sarubbo gentoo-dev 2012-03-15 12:28:12 UTC
amd64 stable
Comment 4 Thomas Kahle (RETIRED) gentoo-dev 2012-03-16 16:31:20 UTC
There seem to be some missing static deps.  On x86, with USE="static static-libs" I get:

i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -D__STDC_LIMIT_MACROS -I../client/x11 -I../common -I/usr/include/alsa   -I/usr/include/CEGUI       -I/usr/include/pixman-1   -I/usr/include/spice-1        -Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations   -pthread -lm -lrt  -O2 -march=prescott -pipe -c -o gui/softtexture.o gui/softtexture.cpp
  CXXLD  spicec
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lasound
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: attempted static link of dynamic object `/usr/lib/libCEGUIBase.so'
collect2: ld returned 1 exit status
make[3]: *** [spicec] Error 1
Comment 5 Doug Goldstein (RETIRED) gentoo-dev 2012-03-23 05:01:51 UTC
(In reply to comment #4)
> There seem to be some missing static deps.

looks like your are right, dev-games/cegui doesn't provide static-libs and I'm not sure ALSA does. i'll check out a fix
Comment 6 Andreas Schürch gentoo-dev 2012-04-02 14:54:46 UTC
I do not get the same failure as Thomas, but it fails here on x86 with USE="static -gui"

i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -D__STDC_LIMIT_MACROS -I../client/x11 -I../common -I/usr/include/alsa        -I/usr/include/pixman-1   -I/usr/include/spice-1        -Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations   -pthread -lm -lrt  -O2 -march=i686 -pipe -c -o x11/x_icon.o x11/x_icon.cpp
  CXXLD  spicec
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lasound
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lcelt051
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -ljpeg
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lXext
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lXrender
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lX11
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lpixman-1
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lssl
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lcrypto
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lXfixes
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lXrandr
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgcc_s
red_peer.o: In function `RedPeer::connect_to_peer(char const*, int)':
red_peer.cpp:(.text+0xce6): warning: Using 'getaddrinfo' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgcc_s
collect2: ld returned 1 exit status
make[3]: *** [spicec] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-emulation/spice-0.10.0/work/spice-0.10.0/client'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-emulation/spice-0.10.0/work/spice-0.10.0/client'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-emulation/spice-0.10.0/work/spice-0.10.0'
make: *** [all] Error 2
Comment 7 Thomas Kahle (RETIRED) gentoo-dev 2012-04-29 15:38:45 UTC
It definitely needs the static version of libasound.  The .so is in 
app-emulation/emul-linux-x86-soundlibs but this package has no static USE-flag.
Comment 8 Tiziano Müller (RETIRED) gentoo-dev 2012-06-13 12:01:18 UTC
ok, USE=static is broken completely since alsa-lib does not provide the necessary .a file and can not be easily patched to do so.
How do we want to procede?

a) ignore the failures with USE=static (I dropped the USE flag in spice-0.11.0 already)
b) simply drop the USE flag on spice-0.10.0, resp. 0.10.1
c) correctly do a rev bump without the USE flag and stabilize that one in 30 days
Comment 9 Doug Goldstein (RETIRED) gentoo-dev 2012-07-08 02:37:43 UTC
Let's just go with how you did it by updates for 0.11.0. I'm honestly not sure that USE=static-libs will work either but I'll have to test.

x86 needs to get into gear and start stabilizing otherwise we're going to drop them due to a serious security lapse here.
Comment 10 Myckel Habets 2012-07-08 06:40:14 UTC
(In reply to comment #9)
> x86 needs to get into gear and start stabilizing otherwise we're going to
> drop them due to a serious security lapse here.

I'm going to have a look at it. However, it seems to downgrade cegui from 0.7.6-r1 to 0.6.2b. Is that correct?
Comment 11 Tiziano Müller (RETIRED) gentoo-dev 2012-07-08 07:55:19 UTC
@Cardoe: well, static-libs should work but it doesn't really help since the alsa-libs are still not available and anyone wanting to use the static-libs will end up with undefined symbols from alsa.

@Myckel: yes, that's (unfortunately) correct
Comment 12 Myckel Habets 2012-07-08 08:28:12 UTC
The following keyword changes are necessary to proceed:
#required by app-emulation/spice-0.11.0[smartcard], required by =app-emulation/spice-0.11.0 (argument)
=app-emulation/libcacard-0.1.2 ~x86

Stabilize that one as well?
Comment 13 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-09-23 08:32:05 UTC
x86 stable, closing