Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 40703

Summary: gentoo-dev-sources 2.6.2 and nvidia-5336 results in black screen under X
Product: Gentoo Linux Reporter: Max Loparev <laplandersan>
Component: [OLD] Core systemAssignee: x86-kernel (DEPRECATED) <x86-kernel>
Severity: critical CC: spock, x11
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Max Loparev 2004-02-07 03:59:22 UTC
gentoo-dev-sources-2.6.1-r1 works fine even with previous kernel module version 5328 on top of nvidia-glx version 5336
There is no error messages in Xfree.log.
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2004-02-07 04:02:48 UTC
did you reemerge nvidia-kernel ?
Comment 2 Max Loparev 2004-02-07 06:22:37 UTC
>did you reemerge nvidia-kernel ?
Comment 3 John Mylchreest (RETIRED) gentoo-dev 2004-02-07 09:30:07 UTC
have you changed anything in the framebuffer configuration?
Everything is working OK gere for me with 5336 and 2.6.2

I know theres some weirdness with the framebuffer/vga selection.
perhaps having a play with those options?
Comment 4 Max Loparev 2004-02-07 09:47:08 UTC
i did make oldconfig with .config from the 2.6.1-gentoo-r1
and yes I'm using framebuffer for bootsplash, and it works fine

I'd tried to not use vga=xxxx with the same results. ok i'll try to exclude it from kernel at compile time...
Comment 5 Max Loparev 2004-02-07 10:20:23 UTC
removing Framebuffer support from kernel hadn't helped. 
X is not switching to graphic mode, and last lines in the log are:
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
        compiled for 4.3.0, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "CursorShadow" "true"
(**) NVIDIA(0): Option "UseEdidFreqs" "true"
(**) NVIDIA(0): Enabling experimental RENDER acceleration
(**) NVIDIA(0): Enabling cursor shadow
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xE0000000

btw, KT400 GF2MX MX400
Comment 6 John Mylchreest (RETIRED) gentoo-dev 2004-02-07 10:44:29 UTC
could you try enabling AGPGART and adding the option for AGPGARt as neccessary in xf86config as in
Comment 7 Max Loparev 2004-02-07 12:45:14 UTC
NvAGP "3" hadn't helped

do you use NPTL?
Comment 8 John Mylchreest (RETIRED) gentoo-dev 2004-02-07 14:33:55 UTC
yes I do
Comment 9 Wojtek Sczygiol 2004-02-09 04:50:52 UTC
After emerging gentoo-dev-sources-2.6.2, nvidia-glx-1.0.5336 and nvidia-kernel-1.0.5336-r1 I had the same problem. I'm also using
vesafb an bootsplash.
Loading the nvidia module _before_ starting X solved the problem for me.
So the solution is:

echo "nvidia" >> /etc/modules.autoload.d/kernel-2.6
Comment 10 Max Loparev 2004-02-09 10:53:30 UTC
Adding nvidia to autoload helps me too.
It seems that something broken in module autoloading mechanizm.
I have another problem with the same strange results with alsa module loading with this kernel... 
Comment 11 Jason Cox (RETIRED) gentoo-dev 2004-03-25 15:11:04 UTC
Are those experiencing problems using udev instead of devfs?

I believe the problem lies there. The modules is loaded fine, but the devices aren't getting created fast enough.
Comment 12 Max Loparev 2004-03-27 01:41:06 UTC
No, i'm using devfs, and it's late now to talk about 2.6.2 because under 2.6.4 and maybe new ARCH="~x86" hotplug there is no such problems at all.
Comment 13 Jason Cox (RETIRED) gentoo-dev 2004-04-08 22:45:01 UTC
Ok, so an upgrade of the kernel fixed it. Closing the bug.
Comment 14 Jason Cox (RETIRED) gentoo-dev 2004-04-08 22:45:13 UTC