Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 405485 (respect_LINGUAS)

Summary: [TRACKER] Packages not respecting LINGUAS when installing locales
Product: Quality Assurance Reporter: Piotr Szymaniak <bugzie>
Component: TrackersAssignee: Gentoo Quality Assurance Team <qa>
Status: CONFIRMED ---    
Severity: QA CC: andreis.vinogradovs, gurligebis, tech31842
Priority: Normal Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 205957, 402293, 402303, 403045, 403623, 403627, 403631, 403637, 403655, 408761, 469440, 205956, 326653, 337780, 339589, 401525, 401563, 402295, 402297, 402299, 402301, 402305, 402307, 402309, 402311, 402313, 402673, 402675, 402677, 402679, 402681, 402683, 402685, 402689, 402691, 402701, 402703, 402891, 402893, 403037, 403041, 403043, 403049, 403595, 403597, 403599, 403603, 403605, 403621, 403625, 403629, 403633, 403635, 403639, 403641, 403643, 403645, 403647, 403649, 403651, 403653, 406409, 406413, 406415, 406417, 406419, 406433, 406435, 406549, 406551, 407175, 407197, 407853, 407857, 407859, 408093, 408097, 408099, 408101, 408103, 408763, 408765, 408767, 408769, 408771, 408773, 408873, 408875, 408877, 409965, 409969, 439930, 452840, 454584, 469410, 469418, 469422, 469428, 469432, 469438, 471072, 548330, 561664, 577814    
Bug Blocks:    

Description Piotr Szymaniak 2012-02-23 21:01:11 UTC
No comments here.

Reproducible: Always
Comment 1 Piotr Szymaniak 2012-02-23 21:38:44 UTC
(In reply to comment #0)
> No comments here.

Sorry for the noise. I hope now everything will be just fine.
Comment 2 Piotr Szymaniak 2012-03-01 12:16:41 UTC
@qa
What about bugs closed as WONTFIX (like #403643 and #402307)? I suppose they should stay open (with needpatch? or whatever status) until some solution (like proposed here [1]) to the issue where its not-so-easy-to-fix is implemented?

Closing as WONTFIX won't solve the issue, just will hide it.

[1] http://archives.gentoo.org/gentoo-dev/msg_f36ab9a9ce334cd79a08099643877e88.xml
Comment 3 Mike Gilbert gentoo-dev 2016-11-13 01:15:12 UTC
Given the recent developments regarding LINGUAS and the L10N USE_EXPAND, I'm not sure this tracker is relevant any longer.

Build systems are not required to support LINGUAS, and L10N is intended more for use-conditional distfiles.

Unwanted translations can be removed via INSTALL_MASK. In the future GLEP 69 might make this easier to manage.

https://wiki.gentoo.org/wiki/GLEP:69