Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 405151

Summary: app-emulation/virtualbox-guest-additions-4.1.4-r1: Failure to build with 3.2 kernel
Product: Gentoo Linux Reporter: Luis M Wesolowski <luis.wesolowski>
Component: Current packagesAssignee: Patrick Lauer <patrick>
Severity: normal CC: bkohler, gentoo-bugs, polynomial-c, proxy-maint, rossi.f, swapon
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Luis M Wesolowski 2012-02-21 14:32:27 UTC
After updating to the latest stable gentoo-sources (currently 3.2.1-r2) and reemerging virtualbox-guest-additions, the latter package fails to build.

In the meantime, I'm running the previous stable kernel version so that I don't lose the functionality afforded by the virtualbox kernel modules.

The exact error is:

/var/tmp/portage/app-emulation/virtualbox-guest-additions-4.1.4-r1/work/VirtualBox-4.1.4_OSE/src/VBox/Additions/linux/sharedfolders/utils.c: In function ‘sf_init_inode’:
/var/tmp/portage/app-emulation/virtualbox-guest-additions-4.1.4-r1/work/VirtualBox-4.1.4_OSE/src/VBox/Additions/linux/sharedfolders/utils.c:113:9: error: assignment of read-only member ‘i_nlink’
/var/tmp/portage/app-emulation/virtualbox-guest-additions-4.1.4-r1/work/VirtualBox-4.1.4_OSE/src/VBox/Additions/linux/sharedfolders/utils.c:122:9: error: assignment of read-only member ‘i_nlink’
/var/tmp/portage/app-emulation/virtualbox-guest-additions-4.1.4-r1/work/VirtualBox-4.1.4_OSE/src/VBox/Additions/linux/sharedfolders/utils.c:132:9: error: assignment of read-only member ‘i_nlink’

Apparently, this happens with every version currently in portage, and has been solved upstream with a brief patch:

As a regular Gentoo user, I don't know if this bug should be solved by masking the package, by supplying patches for the current stable version, or maybe by simply waiting for upstream.


Reproducible: Always

Steps to Reproduce:
1. Emerge gentoo-sources version >= 3.2
2. Emerge virtualbox-guest-additions
3. Watch it fail to build
Actual Results:  
virtualbox-guest-additions does not emerge.

Expected Results:  
virtualbox-guest-additions should have emerged correctly.
Comment 1 Ben Kohler gentoo-dev 2013-10-02 14:33:41 UTC
Closing since these versions are long gone from the tree, please reopen if you have problems with the current versions.