Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 40389

Summary: glibc 2.3.2-r9 doesn't compile with NPTL although kernel 2.6.2 installed
Product: Gentoo Linux Reporter: Sven <sven.koehler>
Component: New packagesAssignee: Please assign to toolchain <gcc-porting>
Severity: normal    
Priority: High    
Version: 1.4   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Sven 2004-02-04 09:23:03 UTC

i'm trying to upgrade to glibc with NPTL enabled. When running
  emerge glibc
it says:
  Calculating dependencies ...done!
>>> emerge (1 of 1) sys-libs/glibc-2.3.2-r9 to /
>>> md5 src_uri ;-) glibc-2.3.2.tar.bz2
>>> md5 src_uri ;-) glibc-linuxthreads-2.3.2.tar.bz2
>>> md5 src_uri ;-) glibc-2.3.2-branch-update-20031115.patch.bz2

 * Checking kernel headers for broken sysctl.h... no

 * You have "nptl" in your USE, but your kernel version or
 * architecture does not support it!

Reproducible: Always
Steps to Reproduce:

emerge info:
Portage 2.0.49-r20 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r9, 2.6.2)
System uname: 2.6.2 i686 Pentium III (Katmai)
Gentoo Base System version
CFLAGS="-march=i686 -O3 -pipe -funroll-loops"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=i686 -O3 -pipe -funroll-loops"
FEATURES="autoaddcvs ccache sandbox"
USE="aalib acpi alsa apache2 apm avi berkdb crypt cups encode foomaticdb gd
gd-external gdbm gif gtk2 imlib java jpeg libg++ libwww mad mikmod mpeg mysql
ncurses nls nptl odbc oggvorbis oss pam pdflib perl png postgres ppds python
quicktime readline ruby sasl sdl slang spell ssl tcpd truetype x86 xml2 zlib"

while running emerge glibc, the KERNEL-HEADERS in the ebuild seems to have to
value /lib/modules/2.6.2/build/include which is quite correct.
Comment 1 Sven 2004-02-04 13:13:36 UTC
i just took a look at the ebuild again.
it doesn't even download NPTL etc.

what's going on?
is the 2.3.2-r9 ebuild completly broken what NPTL concerns?
Comment 2 SpanKY gentoo-dev 2004-02-04 17:31:44 UTC
your gcc isnt new enough

*** This bug has been marked as a duplicate of 38622 ***
Comment 3 Sven 2004-02-04 18:12:52 UTC
The answer is not "my gcc is not new enough". the answer is, that NPTL has been disbled in the gcc-2.3.2-r9 ebuild.

The only way of using NPTL seems to be to use some very unstable ebuilds.
See for further information.
Comment 4 SpanKY gentoo-dev 2004-02-04 18:17:50 UTC
yes, i know about that bug, if you read it, you'll see i wrote about half the comments and that i'm the one who removed nptl from the ebuild

your gcc isnt new enough, you need 3.3.2, you have 3.2.3
Comment 5 Sven 2004-02-04 18:32:16 UTC
yes, you wrote a bunch of comments and fixed the other bug by removing NPTL-support from the ebuild. i read that. (BTW: should should remove it 100% and/or add a warning that NPTL has been removed from the ebuild).

Anyway: you didn't mention the reason why one must have gcc3.3 to use NPTL, yet.

It's not that i don't believe you, but you didn't give any hint what the reason might be. What do you think other users might ask themselfs? You should also keep in mind, that there might be users out there that are using glibc-2.3.2-r3 at the moment (compiled with gcc-3.2.3-r3 and NPTL).

What do you think they will experience when upgrading to glibc-2.3.2-r9?
Comment 6 SpanKY gentoo-dev 2004-02-04 18:39:36 UTC
i doubt any users out there are using glibc-2.3.2-r3 with NPTL enabled because all glibc ebuilds that have NPTL option have always required gcc-3.3

if a user edited the ebuild to remove those checks and somehow got nptl on their system and upgrading breaks their system, well it's kinda their fault in the first place

when that DEPEND was put in place it was because the documentation lists that either the latest development gcc (i.e. 3.3.x) is required or the redhat 3.2 (i.e. redhat ports a lot of patches from dev back into stable versions ... you can see nptl in their 2.4 kernels for instance)

whether it really works with our 3.2.3 gcc i dont think anyone has tested and i dont think anyone will ... not worth our time questioning the documentation in this case, plus we plan on moving 3.3.2-rX to stable soon
Comment 7 Sven 2004-02-05 01:16:04 UTC
gcc-2.3.2-r3 ebuild does not require gcc-3.3, only >=gcc-3.2.2-r1
Comment 8 Sven 2004-02-05 01:22:58 UTC
perhaps that is a typo in the glibc-2.3.2-r3 ebuild?
and it should really depend on >=gcc-3.3.2-r1 with USE=nptl
Comment 9 SpanKY gentoo-dev 2004-02-05 19:44:54 UTC
regardless, it's a moot point and the glibc-2.3.2-r9 ebuild wont be changed until gcc-3.3.2-rX hits stable
Comment 10 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-08 00:43:58 UTC
We need 3.3.x (think 3.3.2) for unroll, etc support. Now that 3.3.2 is stable,
I guess we might enable it again ... although I would like not to do it until
all arches are on 3.3.2 ...
Comment 11 Sven 2004-02-09 13:28:03 UTC
you could modify the ebuild so that it does:

if (NPTL in use-flags)
  if (gcc <3.3.2 installed)
    einfo "NPTL needs gcc 3.3.2"
  enable NPTL-support