Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 402379

Summary: net-analyzer/openvas-* version bumps
Product: Gentoo Linux Reporter: Alexander Petrenas <bugs.gentoo.org>
Component: New packagesAssignee: Hanno Böck <hanno>
Status: RESOLVED FIXED    
Severity: enhancement CC: alexanderyt, david+gentoo.org, gentoo, l.alebarde2, mark+gentoobugs, paula.gonzalez, samuel.cuella, silvio.gerli
Priority: Normal Keywords: EBUILD
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 385303, 387841, 407729, 430870    
Attachments: openvas-libraries-4.0.6.ebuild
ebuild for version 5.0.3
openvas-libraries-5.0.3.ebuild
Set of openvas ebuilds, patches, etc for the current beta
Set of OpenVAS ebuild for rc1
Set of OpenVAS ebuilds for rc1
openvas-6-ebuilds-tree.tar.bz2
openvas-6-ebuilds-tree.tar.bz2

Description Alexander Petrenas 2012-02-06 11:49:28 UTC
Hi!

Please find attached openvas-libraries-4.0.6.ebuild that just compiles somehow.
Not that disabling a -Werror & -Wall is a good solution, but at least the library will compile that way.



Reproducible: Always
Comment 1 Alexander Petrenas 2012-02-06 11:49:57 UTC
Created attachment 301017 [details]
openvas-libraries-4.0.6.ebuild
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-02-06 20:38:53 UTC
-Wall should be fine - -Werror makes trivial issues break the build process.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-12 14:13:51 UTC
*** Bug 414687 has been marked as a duplicate of this bug. ***
Comment 4 Alexandr Tiurin 2012-09-24 11:50:33 UTC
Created attachment 324802 [details]
ebuild for version 5.0.3
Comment 5 Alexandr Tiurin 2012-09-24 12:47:47 UTC
Created attachment 324814 [details]
openvas-libraries-5.0.3.ebuild

some fix
Comment 6 Hanno Böck gentoo-dev 2013-02-17 13:47:11 UTC
*** Bug 402381 has been marked as a duplicate of this bug. ***
Comment 7 Hanno Böck gentoo-dev 2013-02-17 13:47:18 UTC
*** Bug 402385 has been marked as a duplicate of this bug. ***
Comment 8 Hanno Böck gentoo-dev 2013-02-17 13:47:24 UTC
*** Bug 402387 has been marked as a duplicate of this bug. ***
Comment 9 Hanno Böck gentoo-dev 2013-02-17 13:47:30 UTC
*** Bug 436104 has been marked as a duplicate of this bug. ***
Comment 10 Hanno Böck gentoo-dev 2013-03-10 16:33:38 UTC
Just to give everyone interested a quick status: I'm working on getting up-to-date openvas ebuilds done based on the latest upstream 6.0 beta versions (6.0 is scheduled to be released soon), but there are a lot of issues arising.

What's currently stopping me from getting anything to work is this upstream bug:
https://wald.intevation.org/tracker/index.php?func=detail&aid=6426&group_id=29&atid=220
Comment 11 Christian Schmidt 2013-03-15 12:43:36 UTC
Created attachment 342120 [details]
Set of openvas ebuilds, patches, etc for the current beta

net-analyzer/openvas/
net-analyzer/openvas/ChangeLog
net-analyzer/openvas/openvas-6.ebuild
net-analyzer/openvas/metadata.xml
net-analyzer/openvas/Manifest
net-analyzer/openvas-administrator/
net-analyzer/openvas-administrator/ChangeLog
net-analyzer/openvas-administrator/metadata.xml
net-analyzer/openvas-administrator/Manifest
net-analyzer/openvas-administrator/openvas-administrator-1.3_beta1.ebuild
net-analyzer/openvas-administrator/files/
net-analyzer/openvas-administrator/files/openvasad
net-analyzer/openvas-libraries/
net-analyzer/openvas-libraries/ChangeLog
net-analyzer/openvas-libraries/metadata.xml
net-analyzer/openvas-libraries/Manifest
net-analyzer/openvas-libraries/openvas-libraries-6.0_beta5.ebuild
net-analyzer/openvas-libraries/files/
net-analyzer/openvas-libraries/files/openvas-libraries-6.0_beta5_gpgme_cflags.patch
net-analyzer/openvas-manager/
net-analyzer/openvas-manager/ChangeLog
net-analyzer/openvas-manager/openvas-manager-4.0_beta5.ebuild
net-analyzer/openvas-manager/metadata.xml
net-analyzer/openvas-manager/Manifest
net-analyzer/openvas-manager/files/
net-analyzer/openvas-manager/files/openvasmd
net-analyzer/openvas-scanner/
net-analyzer/openvas-scanner/ChangeLog
net-analyzer/openvas-scanner/metadata.xml
net-analyzer/openvas-scanner/Manifest
net-analyzer/openvas-scanner/openvas-scanner-3.4_beta2.ebuild
net-analyzer/openvas-scanner/files/
net-analyzer/openvas-scanner/files/openvassd
net-analyzer/greenbone-security-assistant/
net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0_beta5.ebuild
net-analyzer/greenbone-security-assistant/ChangeLog
net-analyzer/greenbone-security-assistant/metadata.xml
net-analyzer/greenbone-security-assistant/Manifest
net-analyzer/greenbone-security-assistant/files/
net-analyzer/greenbone-security-assistant/files/gsad
Comment 12 Christian Schmidt 2013-03-15 12:47:48 UTC
The attached set of openvas ebuilds contains:
- restriction to working gnutls version (>=2.8, <3.0)
- some init script updates for dependencies and messages
- added post-install config to openvas ebuild, and updated the manual steps
- removed cli and greenbone security desktop (gsd doesn't compile, both are outdated with the beta)
Comment 13 Christian Schmidt 2013-03-24 14:55:37 UTC
Created attachment 343098 [details]
Set of OpenVAS ebuild for rc1

Updated batch tarball to release candidates versions. cli now included, desktop client still dropped since upstream confirmed it's outdated and does not compile.
Comment 14 Christian Schmidt 2013-03-24 14:56:57 UTC
Created attachment 343100 [details]
Set of OpenVAS ebuilds for rc1
Comment 15 Jeroen Roovers (RETIRED) gentoo-dev 2013-04-19 16:25:57 UTC
*** Bug 466448 has been marked as a duplicate of this bug. ***
Comment 16 Samuel CUELLA 2013-04-23 10:01:16 UTC
Created attachment 346368 [details]
openvas-6-ebuilds-tree.tar.bz2

Set of OpenVAS-6 ebuilds. Works for me.
Comment 17 Samuel CUELLA 2013-04-26 20:07:01 UTC
Created attachment 346668 [details]
openvas-6-ebuilds-tree.tar.bz2

Added support for libssh and WMI via use flags. Also provide net-libs/libwmi package from zenoss/openvas.
Comment 18 lalebarde 2013-05-07 14:36:55 UTC
openvas-6-ebuilds-tree.tar.bz2 installation ok for me. Seems to work. Great job. Thanks. (Adding openvas-client would be a plus).
Comment 19 Hanno Böck gentoo-dev 2013-07-01 10:33:49 UTC
committed now a set of openvas-6 ebuilds.