Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 401887

Summary: app-text/stardict-3.0.3-r2 fails to build against >=sys-libs/zlib-1.2.5.2 (due to api change)
Product: Gentoo Linux Reporter: Attila Stehr <as.gentoo>
Component: Current packagesAssignee: Spell checking utilities and dictionaries -- related bugs (OBSOLETE) <app-dicts+disabled>
Status: VERIFIED FIXED    
Severity: normal CC: bugzie, javran.c, liparinai, ssuominen, v_2e, wolfpythonlondon, zima
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info stardict
build log as requested
The build log of stardict-3.0.3-r2
emerge --info =app-text/stardict-3.0.3-r2

Description Attila Stehr 2012-02-02 07:57:49 UTC
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -Wall -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/libdrm -I/usr/include/libxml2 -I.. -I.. -O1 -pipe -march=core2 -ggdb -MT libcommon.lo -MD -MP -MF .deps/libcommon.Tpo -c libcommon.cpp  -fPIC -DPIC -o .libs/libcommon.o
In file included from ifo_file.h:26:0,
                 from ifo_file.cpp:27:
libcommon.h:191:50: Fehler: Templateargument »gzclose« konnte nicht in »int (*)(void*)« umgewandelt werden
libcommon.h:191:58: Fehler: invalid type in declaration before »;« token
In file included from libcommon.cpp:30:0:
libcommon.h:191:50: Fehler: Templateargument »gzclose« konnte nicht in »int (*)(void*)« umgewandelt werden
libcommon.h:191:58: Fehler: invalid type in declaration before »;« token
libcommon.cpp: In Funktion »int unpack_zlib(const char*, const char*)«:
libcommon.cpp:602:45: Fehler: ungültige Umwandlung von »gzFile_s*« in »zip::gzFile«
libcommon.cpp:617:27: Fehler: »get_impl« wurde in diesem Gültigkeitsbereich nicht definiert
make[3]: *** [ifo_file.lo] Fehler 1
make[3]: *** Warte auf noch nicht beendete Prozesse...
libcommon.cpp: In Funktion »std::string create_temp_file()«:
libcommon.cpp:691:20: Warnung: ignoring return value of »ssize_t write(int, const void*, size_t)«, declared with attribute warn_unused_result
make[3]: *** [libcommon.lo] Fehler 1
make[3]: Leaving directory `/var/tmp/portage/app-text/stardict-3.0.3-r2/work/stardict-3.0.3/lib/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/app-text/stardict-3.0.3-r2/work/stardict-3.0.3/lib'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/var/tmp/portage/app-text/stardict-3.0.3-r2/work/stardict-3.0.3/lib'
make: *** [all-recursive] Fehler 1
 * ERROR: app-text/stardict-3.0.3-r2 failed (compile phase):
 *   emake failed


Reproducible: Always

Steps to Reproduce:
emerge stardict
Actual Results:  
 * ERROR: app-text/stardict-3.0.3-r2 failed (compile phase):
 *   emake failed
Comment 1 Attila Stehr 2012-02-02 07:58:36 UTC
Created attachment 300741 [details]
emerge --info stardict
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-02-02 17:20:03 UTC
Please attach the entire build log to this bug report.
Comment 3 Attila Stehr 2012-02-03 13:32:25 UTC
Created attachment 300853 [details]
build log as requested
Comment 4 Attila Stehr 2012-02-03 13:33:35 UTC
 $ emerge -pqv =app-text/stardict-3.0.3-r2
[ebuild     U ] app-text/stardict-3.0.3-r2 [3.0.1-r3] USE="gucharmap spell -espeak -gnome -pronounce -qqwry -tools% (-debug%) (-festival%)"
Comment 5 akira wu 2012-02-03 13:49:46 UTC
Created attachment 300855 [details]
The build log of stardict-3.0.3-r2

I have the same problem. This is the entire build log of stardict-3.0.3-r2.
Comment 6 akira wu 2012-02-03 13:52:32 UTC
Created attachment 300857 [details]
emerge --info =app-text/stardict-3.0.3-r2
Comment 7 Samuli Suominen gentoo-dev 2012-03-10 06:51:35 UTC
*** Bug 407615 has been marked as a duplicate of this bug. ***
Comment 8 Samuli Suominen gentoo-dev 2012-03-10 12:35:06 UTC
+  10 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> stardict-3.0.3-r2.ebuild,
+  +files/stardict-3.0.3-zlib-1.2.5.2.patch:
+  Fix compability with sys-libs/zlib >= 1.2.5.2 wrt #401887 by Sergei
+  Trofimovich. Thanks to Attila Stehr for reporting.
Comment 9 Attila Stehr 2012-03-20 21:04:25 UTC
Thanks for fixing!
Comment 10 Samuli Suominen gentoo-dev 2012-03-20 21:14:30 UTC
(In reply to comment #9)
> Thanks for fixing!

No problem but why did you reopen the bug? Assuming by accident and closing again.
Comment 11 Attila Stehr 2012-03-20 21:21:42 UTC
Oh - looks like I mixed it up with "VERIFIED FIXED" which was no option before. Setting that state now - hopefully doing it right this time. ;)