Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 401823

Summary: www-client/seamonkey - desktop file lists unhandled mimetype associations
Product: Gentoo Linux Reporter: kavol
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED OBSOLETE    
Severity: normal CC: mozilla
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description kavol 2012-02-01 16:04:37 UTC
In /usr/share/applications/seamonkey.desktop there is

MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;text/x-vcard;text/directory;application/mbox;message/rfc822;x-scheme-handler/mailto;

But seamonkey doesn't seem to handle some of these types.

I've found about this issue while trying to open a .mbox file from Dolphin - I've expected it to be viewed in kmail, but seamonkey association got preference, so seamonkey started but it was unable to view the file, asking me what application it should use to open the file, having preselected ... seamonkey again!

Reproducible: Always

Steps to Reproduce:
(0. uninstall anything else which may handle application/mbox)
1. install KDE (kmail, dolphin)
2. install www-client/seamonkey-2.6.1
3. start dolphin
4. try to open some.mbox file
Actual Results:  
seamonkey starts, asking which application to use to view the file

in that dialogue, seamonkey is preselected, and if you choose it, you get another tab in seamonkey opened with the same file, and the same dialogue asking how to open the file appears again ...

Expected Results:  
the contents of some.mbox is viewed via kmail

this doesn't seem to happen elsewhere (well, I've tried just in Fedora :-)), hence I report for Gentoo and not upstream
Comment 1 Jory A. Pratt gentoo-dev 2012-02-10 20:38:50 UTC
The problem is the desktop file is generic, unless you build seamonkey with mail support your gonna have a misassoaction until you change the pref.
Comment 2 kavol 2012-02-16 12:48:55 UTC
(In reply to comment #1)
> The problem is the desktop file is generic, unless you build seamonkey with
> mail support your gonna have a misassoaction until you change the pref.

but my point is not to have the files supported by Seamonkey - even if Seamonkey would be built with mail support I wouldn't want it to handle these but that is another story

yep, the point of the bug is that the file is generic - so, please, change this, do not use "one size fits them all" when it obviously doesn't fit, filter the list of mimetypes based on compile options


btw, I thought mail support was dropped ... once upon a time, there was an USE flag "moznomail" or something like that to disable building mailclient, but the current list of flags:

"alsa chatzilla crypt custom-cflags custom-optimization dbus debug ipc methodjit libnotify startup-notification system-sqlite roaming webm wifi"

doesn't seem to have to do anything with mailclient feature ...
Comment 3 Jory A. Pratt gentoo-dev 2017-08-26 17:55:41 UTC
If you feel I have closed your bug and it is still a current issue, please reopen and update it completely. We will not work bugs that have no ebuild in tree any longer or can not be reproduced with a current system.

Thank You for your support and understanding
The Mozilla Team