Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 401617

Summary: sys-kernel/gentoo-sources-3.2.1-r2 produces a lot of "BUG: using smp_processor_id() in preemptible ..." on PPC64
Product: Gentoo Linux Reporter: dehua.yang
Component: [OLD] Core systemAssignee: ppc64 architecture team <ppc64>
Severity: normal CC: kernel
Priority: Normal    
Version: unspecified   
Hardware: PPC64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: Bug messages in dmesg

Description dehua.yang 2012-01-31 10:25:07 UTC
I installed gentoo-sources-3.2.1-r2 successfully on my PowerMac G5, and it seems to work without problems. But I noticed a lot of bug messages in dmesg:

BUG: using smp_processor_id() in preemptible [00000000] code: init/1
caller is .decrementer_check_overflow+0x28/0x70
Call Trace:
[c00000015a09b1a0] [c000000000013648] .show_stack+0x78/0x1b0 (unreliable)
[c00000015a09b250] [c0000000003bf790] .debug_smp_processor_id+0x100/0x120
[c00000015a09b2f0] [c00000000001b9b8] .decrementer_check_overflow+0x28/0x70
[c00000015a09b380] [c00000000000dc78] .arch_local_irq_restore+0x48/0x70
[c00000015a09b3f0] [c000000000005870] .do_hash_page+0x70/0x74
--- Exception: 301 at .__clear_user+0x14/0x7c
    LR = .padzero+0x68/0x110
... ...

I also tried gentoo-sources-3.2.0, and it does not have this messages with the same option: CONFIG_DEBUG_PEEMPT=y.
The whole messages are in the attachment.

Reproducible: Always

Steps to Reproduce:
1. Install gentoo-sources-3.2.1-r2
2. Run the system
3. View the messages in dmesg
Actual Results:  
A lot of bug and trace messages.

Expected Results:  
No bug messages

Emerge --info 
Portage (default/linux/powerpc/ppc64/10.0/64bit-userland, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 ppc64)
System uname: Linux-3.2.1-gentoo-r2-ppc64-PPC970,_altivec_supported-with-gentoo-2.0.3
Timestamp of tree: Mon, 30 Jan 2012 01:00:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
CFLAGS="-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -mpowerpc64 -fno-strict-aliasing -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -mpowerpc64 -fno-strict-aliasing -fomit-frame-pointer -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib accessibility acl aiglx alsa altivec asf aspell automount berkdb browserplugin bzip2 cairo cdr chardet cjk cli consolekit cpdflib cracklib crypt css cups curl cxx dba dbus device-mapper dri dts dvd dvdnav dvdr eds emerald encode exif extras faac faad2 fb ffmpeg flac fontconfig foomaticdb fortran gallium gd gd-external gdbm gdu gimpprint glitz gmp gnome gnome-keyring gnomecd gnutls gpm gstreamer gtk gtk2 hal ibm iconv imagemagick imlib ipv6 java jpeg jpeg2k kdrive kms lcms ldap mad mbox mng modules mp3 mpeg mpg mudflap mysql nas nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf png policykit ppc64 ppds pppd qt qt3support readline samba saslradeon sdl secure-delete session sip skins slang spell sql sqlite sqlite3 ssl svg sysfs tcpd theora threads tiff tordns truetype udev unicode v4l2 vcd vidix vorbis wav webkit wma xanim xcb xcomposite xine xml xml2 xmms xorg xulrunner xv xvid zlib" ALSA_CARDS="aoa" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US zh_CN" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="ati radeon fbdev nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 dehua.yang 2012-01-31 10:28:10 UTC
Created attachment 300519 [details]
Bug messages in dmesg
Comment 2 dehua.yang 2012-02-05 03:20:56 UTC
I tried vanilla-sources-3.2.2, it has the same bug messages.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-11-16 15:56:22 UTC
Can you try a recent kernel to see if you can still reproduce this?