Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 401615

Summary: dev-qt/qthelp-4.8.x - Bus error in ${S}/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf
Product: Gentoo Linux Reporter: Graham Murray <gmurray>
Component: [OLD] LibraryAssignee: Qt Bug Alias <qt>
Status: RESOLVED WORKSFORME    
Severity: normal CC: rainer, rono, simoncion, xmw
Priority: Normal Keywords: REGRESSION
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Build log
build.log

Description Graham Murray 2012-01-31 10:18:00 UTC
Created attachment 300515 [details]
Build log

/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0/doc/src/legal/licenses.qdoc:40: Cannot link to 'Qt Commercial Edition' in licenses.html
/bin/sh: line 1:  7608 Bus error               (core dumped) QT_BUILD_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0 QT_SOURCE_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0 /var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf
make: *** [qch_docs] Error 135
emake failed
 * ERROR: x11-libs/qt-assistant-4.8.0 failed (compile phase):
 *   emake qch_docs failed 
 * 
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 3105:  Called die
 * The specific snippet of code:
 *           emake qch_docs || die "emake qch_docs failed ";

I get this same error on 2 ~x86 systems (so I do not think the bus error is a hardware error)
 emerge --info
Portage 2.2.0_alpha84 (default/linux/x86/10.0/desktop/gnome, gcc-4.6.2, glibc-2.14.1-r2, 3.2.1-gentoo i686)
=================================================================
System uname: Linux-3.2.1-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E8200_@_2.66GHz-with-gentoo-2.1
Timestamp of tree: Tue, 31 Jan 2012 07:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.7-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.2-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2, 4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo sunrise x11 betagarden Grahams_local_portage
Installed sets: @system
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -mtune=native -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -mtune=native -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --autounmask-write y"
FEATURES="assume-digests binpkg-logs buildsyspkg distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://gentoo.tiscali.nl/ http://mirror.ovh.net/gentoo-distfiles/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/x11 /var/lib/layman/betagarden /usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 avahi bash-completion berkdb branding bzip2 cairo caps cdda cdr cli colord consolekit cracklib crypt cups curl cvs cxx dbus doc dri dts dvd dvdr eds emacs emboss encode evo examples exif expat fam ffmpeg flac fortran gd gdbm gdu geoip gif gnome gnome-keyring gnome-online-accounts gnutls gpm gstreamer gtk gtkhtml hardened htmlhandbook iconv icu idn imagemagick imlib ipv6 java jpeg kde kdehiddenvisibility lcms libnotify libsamplerate logrotate lzma lzo mad mmap mmx mng modules mono mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl pic png policykit postgres ppds pppd pulseaudio python qt3support qt4 readline samba sdl semantic-desktop session socialweb speex spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs tcl tcpd theora threads tiff tk truetype udev unicode usb vim-syntax vorbis x264 x86 xattr xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nv nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Franz Trischberger 2012-01-31 14:09:35 UTC
Is it reproducable?
Does dmesg contain something at about that time?
If you are lucky, this was just bad luck, but it also could be a hardware error...
Comment 2 Graham Murray 2012-01-31 14:35:45 UTC
(In reply to comment #1)
> Is it reproducable?
> Does dmesg contain something at about that time?
> If you are lucky, this was just bad luck, but it also could be a hardware
> error...

Yes, it is reproducible and shows the same error on two system (I have tried 3 tines on each). There is nothing in dmesg at the time. Because it happens on 2 systems, I think it would be too much of a co-incidence for both to have the same hardware error causing it to be reproducible on both systems - always failing in the same place.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2012-01-31 19:24:19 UTC
/bin/sh: line 1:  7608 Bus error               (core dumped) QT_BUILD_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0 QT_SOURCE_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0 /var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-4.8.0/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf
Comment 4 Davide Pesavento gentoo-dev 2012-01-31 20:17:07 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Is it reproducable?
> > Does dmesg contain something at about that time?
> > If you are lucky, this was just bad luck, but it also could be a hardware
> > error...
> 
> Yes, it is reproducible and shows the same error on two system (I have tried 3
> tines on each). There is nothing in dmesg at the time. Because it happens on 2
> systems, I think it would be too much of a co-incidence for both to have the
> same hardware error causing it to be reproducible on both systems - always
> failing in the same place.

Are both systems x86?
Comment 5 Graham Murray 2012-02-01 07:47:08 UTC
(In reply to comment #4)

> Are both systems x86?

Yes, both are ~x86.
Comment 6 Graham Murray 2012-02-06 14:26:29 UTC
If it is any help, here is the start and end of the stack trace from the core file generated. As far as I can see, all the intervening stack frames are the same - so as a first guess it looks to me as though it is in an infinite recursion.

Core was generated by `/var/tmp/portage/x11-libs/qt-assistant-4.8.0/work/qt-everywhere-opensource-src-'.
Program terminated with signal 7, Bus error.
#0  0xb76fe85b in compareNodes (n1=0xba97b768, n2=0xabf29924) at tree.cpp:1554
1554	{
(gdb) bt
#0  0xb76fe85b in compareNodes (n1=0xba97b768, n2=0xabf29924) at tree.cpp:1554
#1  0xb77133c9 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:351
#2  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#3  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#4  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#5  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#6  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#7  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#8  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#9  0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#10 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#11 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#12 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#13 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#14 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#15 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#16 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#17 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#18 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#19 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#20 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#21 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#22 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#23 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#24 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#25 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
.
.
.#4807 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#4808 0xb7713520 in QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)> (start=..., end=..., t=@0xabf27ed4: 0xaf92cdd8, 
    lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:385
#4809 0xb7711ab5 in qSort<QList<Node*>::iterator, bool (*)(Node const*, Node const*)> (lessThan=0xb76fe840 <compareNodes(Node const*, Node const*)>, end=..., start=...)
    at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:187
#4810 Tree::generateIndexSections (this=0xb961d828, writer=..., node=0xb961d828, generateInternalNodes=false) at tree.cpp:1623
#4811 0xb7711e5e in Tree::generateIndex (this=0xb961d828, fileName=..., url=..., title=..., generateInternalNodes=false) at tree.cpp:1675
#4812 0xb769cbc1 in HtmlGenerator::generateIndex (this=0xbf97ee80, fileBase=..., url=..., title=...) at htmlgenerator.cpp:3613
#4813 0xb76b9550 in HtmlGenerator::generateTree (this=0xbf97ee80, tree=0xbf97eccc) at htmlgenerator.cpp:264
#4814 0xb75ee419 in processQdocconfFile (fileName=...) at main.cpp:336
#4815 main (argc=-1410164444, argv=0xabf2bd1c) at main.cpp:445
Comment 7 Davide Pesavento gentoo-dev 2012-04-01 16:22:05 UTC
Still reproducible with qt 4.8.1?
Comment 8 Graham Murray 2012-04-02 09:52:13 UTC
(In reply to comment #7)
> Still reproducible with qt 4.8.1?

No it is not reproducable with qt 4.8.1. qt-assistant-4.8.1 builds and installs correctly.
Comment 9 Johannes Huber gentoo-dev 2012-04-02 09:56:32 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Still reproducible with qt 4.8.1?
> 
> No it is not reproducable with qt 4.8.1. qt-assistant-4.8.1 builds and
> installs correctly.

Thank you for feedback.
Comment 10 Graham Murray 2012-05-22 21:53:25 UTC
Unfortunately, the problem has returned with qt-assistant-4.8.2
Comment 11 Davide Pesavento gentoo-dev 2012-05-22 22:01:35 UTC
(In reply to comment #10)
> Unfortunately, the problem has returned with qt-assistant-4.8.2

:(

Could you bisect between 4.8.1 and 4.8.2 to identify the bad commit that introduced the regression? I think you can consider just the commits to QtCore and qdoc3.
Comment 12 Graham Murray 2012-05-29 09:50:33 UTC
(In reply to comment #11)
> 
> Could you bisect between 4.8.1 and 4.8.2 to identify the bad commit that
> introduced the regression? I think you can consider just the commits to
> QtCore and qdoc3.

I would if I knew how! I know (and have done) to bisect kernel and other builds where the sequence is 'bisect, make' and repeat. However, I do not know how to use bisect together with emerge or ebuild.
Comment 13 Davide Pesavento gentoo-dev 2012-06-02 17:32:56 UTC
Uhm right, it's not straightforward. You can probably try with qt-assistant-4.8.9999 from the qt overlay, *with* USE=doc, using `emerge --nodeps` or the `ebuild` command directly.

Remember to export qt_assistant_LIVE_COMMIT="v4.8.2" in your environment to checkout the v4.8.2 tag instead of the branch HEAD.

You also have to set EGIT_NONBARE=1 to force git-2.eclass to clone the full repo to ${S} instead of simply copying the files there.

You should limit the bisection to tools/qdoc3 directory and rerun `ebuild qt-assistant-4.8.9999 compile` each time.
Comment 14 Davide Pesavento gentoo-dev 2012-06-02 17:39:36 UTC
However, seeing that the backtrace involves QtCore stuff, before starting the bisection, it would probably be a good idea to find out whether the regression is in libQtCore or in qdoc3.

To do that you can try to emerge (ignoring deps) qt-assistant-4.8.1 against qt-core-4.8.2: if that fails the bug is in qt-core, otherwise the bug is in qdoc3.
Comment 15 Michael Weber (RETIRED) gentoo-dev 2012-06-18 13:30:35 UTC
I see an infinite loop on ppc (trying to stabilize bug 408711)
Comment 16 Davide Pesavento gentoo-dev 2012-06-18 13:46:28 UTC
(In reply to comment #15)
> I see an infinite loop on ppc (trying to stabilize bug 408711)

Which Qt version are you talking about?
Comment 17 Michael Weber (RETIRED) gentoo-dev 2012-06-18 16:45:46 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > I see an infinite loop on ppc (trying to stabilize bug 408711)
> 
> Which Qt version are you talking about?

Right,

[ebuild  N     ] x11-libs/qt-assistant-4.7.4  USE="exceptions glib qt3support (-aqua) -compat -debug -doc -pch -trace" 0 kB
Comment 18 Davide Pesavento gentoo-dev 2012-06-18 17:37:33 UTC
Since this was reported as fixed in 4.8.1 (and then regressed in 4.8.2), would you mind stabilizing Qt 4.8.1 in bug 414241?
Comment 19 Simon C. Ion 2012-06-18 20:40:23 UTC
(In reply to comment #14)
> To do that you can try to emerge (ignoring deps) qt-assistant-4.8.1 against
> qt-core-4.8.2: if that fails the bug is in qt-core, otherwise the bug is in
> qdoc3.

emerge --nodeps -1 =qt-assistant-4.8.1-r1

builds and installs successfully. I built against qt-core-4.8.2.

qt-assistant-4.8.2 fails to build for me in the same way that is reported in this bug.
Comment 20 Davide Pesavento gentoo-dev 2012-06-18 22:34:40 UTC
(In reply to comment #19)
> (In reply to comment #14)
> > To do that you can try to emerge (ignoring deps) qt-assistant-4.8.1 against
> > qt-core-4.8.2: if that fails the bug is in qt-core, otherwise the bug is in
> > qdoc3.
> 
> emerge --nodeps -1 =qt-assistant-4.8.1-r1
> 
> builds and installs successfully. I built against qt-core-4.8.2.
> 
> qt-assistant-4.8.2 fails to build for me in the same way that is reported in
> this bug.

Thanks a lot. This means that the bug is in qt-core...
Comment 21 Michael Weber (RETIRED) gentoo-dev 2012-06-18 23:08:29 UTC
(In reply to comment #18)
> Since this was reported as fixed in 4.8.1 (and then regressed in 4.8.2),
> would you mind stabilizing Qt 4.8.1 in bug 414241?

aye aye, sir.
Comment 22 Simon C. Ion 2012-06-18 23:11:26 UTC
(In reply to comment #20)
> Thanks a lot. This means that the bug is in qt-core...

Just be sure that I've not been misunderstood:

qt-assistant-4.8.1-r1 + qt-core-4.8.2 = successful build.
qt-assistant-4.8.2 + qt-core-4.8.2 = failed build.

If the version of qt-core didn't change, is it the source of the problem? (A "yes" would be a quite sufficient reply. :) )
Comment 23 Davide Pesavento gentoo-dev 2012-06-18 23:21:22 UTC
(In reply to comment #22)
> (In reply to comment #20)
> > Thanks a lot. This means that the bug is in qt-core...
> 
> Just be sure that I've not been misunderstood:
> 
> qt-assistant-4.8.1-r1 + qt-core-4.8.2 = successful build.
> qt-assistant-4.8.2 + qt-core-4.8.2 = failed build.
> 
> If the version of qt-core didn't change, is it the source of the problem? (A
> "yes" would be a quite sufficient reply. :) )

Ah yes sorry... I totally misread your comment :P
The bug must be in qt-assistant, not in qt-core.
Comment 24 Simon C. Ion 2012-07-11 05:17:00 UTC
The build *still* *fails* as of qt-assistant-4.8.2-r1.

Backtrace from core file generated by qdoc3:

Core was generated by `/var/tmp/portage/x11-libs/qt-assistant-4.8.2-r1/work/qt-everywhere-opensource-s'.
Program terminated with signal 7, Bus error.
#0  0xb771db1c in compareNodes(Node const*, Node const*) ()
(gdb) bt
#0  0xb771db1c in compareNodes(Node const*, Node const*) ()
#1  0xb7732526 in void QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)>(QList<Node*>::iterator, QList<Node*>::iterator, Node* const&, bool (*)(Node const*, Node const*)) ()
#2  0xb7732685 in void QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)>(QList<Node*>::iterator, QList<Node*>::iterator, Node* const&, bool (*)(Node const*, Node const*)) ()

<Very Many identical stack frames snipped>

#3900 0xb7732685 in void QAlgorithmsPrivate::qSortHelper<QList<Node*>::iterator, Node*, bool (*)(Node const*, Node const*)>(QList<Node*>::iterator, QList<Node*>::iterator, Node* const&, bool (*)(Node const*, Node const*)) ()
#3901 0xb7730d09 in Tree::generateIndexSections(QXmlStreamWriter&, Node const*, bool) const ()
#3902 0xb7731095 in Tree::generateIndex(QString const&, QString const&, QString const&, bool) const ()
#3903 0xb76ba983 in HtmlGenerator::generateIndex(QString const&, QString const&, QString const&) ()
#3904 0xb76d96a2 in HtmlGenerator::generateTree(Tree const*) ()
#3905 0xb76f04a7 in main ()
(gdb) 

Hope this helps!
Comment 25 Agostino Sarubbo gentoo-dev 2012-07-11 08:40:08 UTC
Created attachment 317902 [details]
build.log

@qt: I'm unable to reproduce this bug with the same useflag. So we can proceed to stabilize too on x86
Comment 26 Davide Pesavento gentoo-dev 2012-12-28 20:09:08 UTC
*** Bug 449004 has been marked as a duplicate of this bug. ***
Comment 27 Ron OHara 2012-12-29 06:12:59 UTC
(In reply to comment #26)
> *** Bug 449004 has been marked as a duplicate of this bug. ***

Thanks for that investigation. I missed the Bus Error line .. I had seen this bug but did not realize it was relevant.

Does anyone have any idea what is triggering this?
Comment 28 Rainer Ruecker 2013-04-16 03:09:26 UTC
I had a successful build of qthelp-4.8.4 on  several ~x86 Systems that showed this bug with 

# ulimit -s unlimited ; emerge qthelp

The build of this and earlier versions (qt-assistant-4.8.2-r1, qt-assistant-4.8.3)
failed on all these systems with a stacksize of 8192 kbytes and the error described 
in this bug (/bin/sh: line 1:  7608 Bus error) 

This might, however, be seen as a crude circumvention and not a fix of the real cause.
Comment 29 Ron OHara 2013-04-18 14:59:07 UTC
I can confirm that using this workaround


# ulimit -s unlimited ; emerge qthelp

is effective for me as well...


Thanks Rainer
Comment 30 Michael Palimaka (kensington) gentoo-dev 2015-03-05 10:11:53 UTC
Can anybody confirm this is still happening? There are much newer versions in the tree now and we haven't heard anything about this bug for a long time.