Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 398885

Summary: x11-libs/qt-assistant-4.7.4 qdoc3 loops forever on arm & ppc
Product: Gentoo Linux Reporter: Markus Meier <maekke>
Component: Current packagesAssignee: Qt Bug Alias <qt>
Status: RESOLVED FIXED    
Severity: major CC: johannes.geiss, kripton, madcored
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 390963    
Attachments: x11-libs:qt-assistant-4.7.4:20120103-051204.log
x11-libs:qt-assistant-4.7.4:20120129-212453.log

Description Markus Meier gentoo-dev 2012-01-14 15:02:30 UTC
Created attachment 298923 [details]
x11-libs:qt-assistant-4.7.4:20120103-051204.log

the qdoc3 ran for a few days and never finished (I killed the process manually, that's the reason of the build failure). this seems to be an arm specific issue, as I don't see this problem with x86.

 * Package:    x11-libs/qt-assistant-4.7.4
 * Repository: gentoo
 * Maintainer: qt@gentoo.org
 * USE:        arm elibc_glibc exceptions glib kernel_linux qt3support test userland_GNU
 * FEATURES:   sandbox test userpriv usersandbox

make[1]: Entering directory `/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3'
make[1]: Nothing to be done for `first'.
make[1]: Leaving directory `/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3'
(cd /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3/test && QT_BUILD_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 QT_SOURCE_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf) && (cd /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 && cp -f -r /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/examples/webkit/webkit-guide /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/doc-build/html-qt && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qt/qt.qhp -o doc/qch/qt.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-assistant/assistant.qhp -o doc/qch/assistant.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-designer/designer.qhp -o doc/qch/designer.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-linguist/linguist.qhp -o doc/qch/linguist.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qmake/qmake.qhp -o doc/qch/qmake.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qml/qml.qhp -o doc/qch/qml.qch )
/bin/sh: line 1:  2461 Terminated              QT_BUILD_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 QT_SOURCE_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf
make: *** [qch_docs] Error 143
emake failed
 * ERROR: x11-libs/qt-assistant-4.7.4 failed (compile phase):
 *   emake qch_docs failed
 * 
 * Call stack:
 *     ebuild.sh, line  75:  Called src_compile
 *   environment, line 3129:  Called die
 * The specific snippet of code:
 *       emake qch_docs || die "emake qch_docs failed";

Portage 2.1.10.41 (default/linux/arm/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.0.6 armv5tel)
=================================================================
System uname: Linux-3.0.6-armv5tel-Feroceon_88FR131_rev_1_-v5l-with-gentoo-2.0.3
Timestamp of tree: Wed, 04 Jan 2012 19:30:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.1_p9
dev-lang/python:          2.5.4-r4, 2.6.6-r2, 2.7.2-r3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv5tel-softfloat-linux-gnueabi"
CFLAGS="-O2 -march=armv5te -pipe"
CHOST="armv5tel-softfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=armv5te -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://minil/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 arm berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dts dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm gtk iconv jpeg kpathsea lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd test tiff truetype udev unicode usb vorbis xcb xml xorg xulrunner xv xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev omapfb dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Davide Pesavento gentoo-dev 2012-01-26 23:34:45 UTC
Please try building qt manually (i.e. outside portage) and see if the problem persists. Use the following commands:

$ ./configure -opensource -confirm-license -shared -fast -largefile -stl -verbose -platform linux-g++ -nomake examples -nomake demos -release -no-separate-debug-info -exceptions -no-pch -reduce-relocations -arch arm -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-multimedia -no-svg -qt3support -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -lgthread-2.0 -lrt -lglib-2.0 -I/usr/include/freetype2
$ make qch_docs
Comment 2 Markus Meier gentoo-dev 2012-01-29 21:23:34 UTC
(In reply to comment #1)
> Please try building qt manually (i.e. outside portage) and see if the problem
> persists. Use the following commands:
> 
> $ ./configure -opensource -confirm-license -shared -fast -largefile -stl
> -verbose -platform linux-g++ -nomake examples -nomake demos -release
> -no-separate-debug-info -exceptions -no-pch -reduce-relocations -arch arm
> -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor
> -no-xinerama -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -iconv
> -no-cups -no-nis -no-gif -no-libpng -no-libmng -no-libjpeg -no-openssl
> -system-zlib -no-phonon -no-xmlpatterns -no-freetype -no-libtiff
> -no-accessibility -no-fontconfig -no-multimedia -no-svg -qt3support
> -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -lgthread-2.0 -lrt
> -lglib-2.0 -I/usr/include/freetype2
> $ make qch_docs

which qmake command is required to have a useable Makefile?
and should I use ebuild $foo unpack, prepare or vanilla tarball?
Comment 3 Davide Pesavento gentoo-dev 2012-01-29 21:52:03 UTC
Wait, this issue might be caused by bug #348034, could you retry emerging qt-assistant with the patch attached to that bug please?
Comment 4 Markus Meier gentoo-dev 2012-01-30 20:12:42 UTC
(In reply to comment #3)
> Wait, this issue might be caused by bug #348034, could you retry emerging
> qt-assistant with the patch attached to that bug please?

it looks like this didn't fix the issue, hangs here since yesterday...

make -j2 qch_docs
(cd tools/qdoc3 && make)
make[1]: Entering directory `/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3'
make[1]: Nothing to be done for `first'.
make[1]: Leaving directory `/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3'
(cd /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/tools/qdoc3/test && QT_BUILD_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 QT_SOURCE_TREE=/var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qdoc3 qt-api-only.qdocconf assistant.qdocconf designer.qdocconf linguist.qdocconf qmake.qdocconf qdeclarative.qdocconf) && (cd /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4 && cp -f -r /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/examples/webkit/webkit-guide /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/doc-build/html-qt && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qt/qt.qhp -o doc/qch/qt.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-assistant/assistant.qhp -o doc/qch/assistant.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-designer/designer.qhp -o doc/qch/designer.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-linguist/linguist.qhp -o doc/qch/linguist.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qmake/qmake.qhp -o doc/qch/qmake.qch && /var/tmp/portage/x11-libs/qt-assistant-4.7.4/work/qt-everywhere-opensource-src-4.7.4/bin/qhelpgenerator doc-build/html-qml/qml.qhp -o doc/qch/qml.qch )
Comment 5 Davide Pesavento gentoo-dev 2012-01-30 22:01:41 UTC
:-(
Could you attach the new build.log please?
Comment 6 Markus Meier gentoo-dev 2012-01-31 05:34:22 UTC
Created attachment 300507 [details]
x11-libs:qt-assistant-4.7.4:20120129-212453.log
Comment 7 Davide Pesavento gentoo-dev 2012-02-09 17:23:26 UTC
*** Bug 402761 has been marked as a duplicate of this bug. ***
Comment 8 Davide Pesavento gentoo-dev 2012-04-17 18:02:49 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Please try building qt manually (i.e. outside portage) and see if the problem
> > persists. Use the following commands:
> > 
> > $ ./configure -opensource -confirm-license -shared -fast -largefile -stl
> > -verbose -platform linux-g++ -nomake examples -nomake demos -release
> > -no-separate-debug-info -exceptions -no-pch -reduce-relocations -arch arm
> > -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor
> > -no-xinerama -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -iconv
> > -no-cups -no-nis -no-gif -no-libpng -no-libmng -no-libjpeg -no-openssl
> > -system-zlib -no-phonon -no-xmlpatterns -no-freetype -no-libtiff
> > -no-accessibility -no-fontconfig -no-multimedia -no-svg -qt3support
> > -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -lgthread-2.0 -lrt
> > -lglib-2.0 -I/usr/include/freetype2
> > $ make qch_docs
> 
> which qmake command is required to have a useable Makefile?
> and should I use ebuild $foo unpack, prepare or vanilla tarball?

Unpack the vanilla tarball somewhere, run the above configure line, and then 'qmake && make qch_docs'. Let me know how it goes.
Comment 9 Davide Pesavento gentoo-dev 2012-05-07 17:02:08 UTC
Is this reproducible with qt 4.8.1?
Comment 10 Johannes Geiss 2012-05-12 15:21:31 UTC
(In reply to comment #9)
> Is this reproducible with qt 4.8.1?

Not really, "ebuild /usr/portage/x11-libs/qt-assistant/qt-assistant-4.8.1-r1.ebuild compile" produces the following error:

powerpc-unknown-linux-gnu-g++ -c -O2 -fno-strict-aliasing -fomit-frame-pointer -pipe -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -O2 -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_SHARED -DQHELP_LIB -DQT_CLUCENE_SUPPORT -DQT_NO_CAST_TO_ASCII -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../../mkspecs/linux-g++ -I. -I../../../include/QtCore -I../../../include/QtNetwork -I../../../include/QtGui -I../../../include/QtSql -I../../../include -I../../../include/QtHelp -I.rcc/release-shared -I.moc/release-shared -o .obj/release-shared/qhelpsearchengine.o qhelpsearchengine.cpp
In file included from qhelpsearchengine.cpp:206:0:
.moc/release-shared/qhelpsearchengine.moc:13:2: error: #error "This file was generated using the moc from 4.7.4. It"
.moc/release-shared/qhelpsearchengine.moc:14:2: error: #error "cannot be used with the include files from this version of Qt."
.moc/release-shared/qhelpsearchengine.moc:15:2: error: #error "(The moc has changed too much.)"
make[1]: *** [.obj/release-shared/qhelpsearchengine.o] Error 1
Comment 11 Davide Pesavento gentoo-dev 2012-05-12 19:40:10 UTC
You obviously have to install all other Qt 4.8.1 modules before that, you cannot mix qt-assistant-4.8.1 with qt-core-4.7.4

And please use emerge(1), not ebuild(1), unless you really know what you're doing.
Comment 12 Markus Meier gentoo-dev 2012-05-13 08:59:14 UTC
(In reply to comment #9)
> Is this reproducible with qt 4.8.1?

no, this is fixed in 4.8.1 on arm. I guess if it's also okay for ppc, we can close this bug.
Comment 13 Johannes Geiss 2012-05-18 04:06:59 UTC
(In reply to comment #11)
> You obviously have to install all other Qt 4.8.1 modules before that, you
> cannot mix qt-assistant-4.8.1 with qt-core-4.7.4

Yes, you're right. My bad.

Now I compiled and installed 4.8.1 successfully on my PPC Hardware. So this bug is fixed in version 4.8.1 for PPC.
Comment 14 Davide Pesavento gentoo-dev 2012-05-18 10:18:22 UTC
(In reply to comment #13)
> Now I compiled and installed 4.8.1 successfully on my PPC Hardware. So this
> bug is fixed in version 4.8.1 for PPC.

Great! Thanks a lot for testing, both you and Markus.
Closing as fixed in 4.8.1