Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 397391

Summary: x11-misc/lightdm doesn't work properly with gnome-base/gdm installed.
Product: Gentoo Linux Reporter: Marek Sapota <marek>
Component: Current packagesAssignee: Markos Chandras (RETIRED) <hwoarang>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: gnome, kaikaikai, nikoli, ssuominen, x11
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Marek Sapota 2012-01-02 13:44:42 UTC
I have =gnome-base/gdm-2.20.11 and =x11-misc/lightdm-1.0.6-r3 installed.  If I use LightDM applications needing DBUS won't work.  This is because GDM installs "/etc/X11/xinit/xinitrc.d/50-ssh-agent" which sets "$command", so "/etc/X11/xinit/xinitrc.d/80-dbus" extends the "$command" variable instead of running "dbus-launch" directly.  I'm not sure what would be a proper fix, maybe running "50-ssh-agent" only if "$command" is defined, as "80-dbus" already does?

Reproducible: Always
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2012-02-04 19:56:27 UTC
I am not sure I understand the bug so CC'ing gnome people
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-04 20:23:01 UTC
gdm's /etc/X11/xinit/xinitrc.d/50-ssh-agent, dbus's /etc/X11/xinit/xinitrc.d/80-dbus, and consolekit's /etc/X11/xinit/xinitrc.d/90-consolekit all assume that the environment variable $command is used to hold the command needed to launch the user's X session, and accordingly prepend various necessary stuff to it.

I assume that the bug report implies that lightdm fails to respect $command, unlike other display managers. However, I do not use lightdm, so cannot check.
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2012-02-04 21:05:35 UTC
Err if this is the case, it does not look Gentoo specific and it needs to be reported upstream right?
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-02-04 21:30:38 UTC
(In reply to comment #3)

Since Gentoo's lightm package uses custom /etc/lightdm/Xsession file, I would guess that the problem lies there and not in upstream :)

Take a look at gdm's /etc/gdm/Xsession for an example of something that works.
Comment 5 Marek Sapota 2012-02-04 22:17:48 UTC
(In reply to comment #2)
> gdm's /etc/X11/xinit/xinitrc.d/50-ssh-agent, dbus's
> /etc/X11/xinit/xinitrc.d/80-dbus, and consolekit's
> /etc/X11/xinit/xinitrc.d/90-consolekit all assume that the environment variable
> $command is used to hold the command needed to launch the user's X session, and
> accordingly prepend various necessary stuff to it.
> 
> I assume that the bug report implies that lightdm fails to respect $command,
> unlike other display managers. However, I do not use lightdm, so cannot check.

Yeah, it seems like LightDM's Xsession ignores "$command", but 80-dbus actually can run dbus-launch directly if "$command" is empty (not set by 50-ssh-agent for example).
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2012-02-05 22:28:56 UTC
Right. Well, I don't have free time to play with gdm and lightdm configs at the moment so if you have a proposed patch feel free to attach it. I am cc'ing Samuli as he may be familiar with this sort of stuff. He may have some time to fix it sooner than I will.
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2012-03-04 20:08:39 UTC
If anyone cares to provide a patch for this bug then feel free to do so. I don't see myself trying gdm+lightdm in the near future.
Comment 8 Gilles Dartiguelongue gentoo-dev 2013-01-22 22:35:31 UTC
lightdm must comply to the $command logic. This is not something specific to gdm at all or at least not to gentoo since this setup is found in debian and maybe still is in fedora and ubuntu.

This is how X sessions select some actions to chain before starting the binary that will run your desktop in order to setup the proper environment for it.

If you want something different, you will have to ask x11 team to finally come up with something as there are quite a few tickets opened about xinitrc.d (or related) lack of homogeneity in gentoo.
Comment 9 Gilles Dartiguelongue gentoo-dev 2013-01-22 22:35:59 UTC
Adding x11 herd per my last comment.
Comment 10 Pacho Ramos gentoo-dev 2014-03-19 22:34:44 UTC
I can't reproduce this with 3.10 and lightdm (neither with 3.8)
Comment 11 Pacho Ramos gentoo-dev 2014-05-30 19:35:42 UTC
(In reply to Pacho Ramos from comment #10)
> I can't reproduce this with 3.10 and lightdm (neither with 3.8)

Please confirm if you are still suffering this with an updated system