Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 395587

Summary: media-video/ffmpeg-0.9 links against libx264.so.118 when .119 is also there
Product: Gentoo Linux Reporter: jannis <kripton>
Component: [OLD] LibraryAssignee: media-video herd <media-video>
Status: RESOLVED OBSOLETE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: "emerge --info media-video/ffmpeg" from host ayanta
"emerge --info media-video/ffmpeg" from host mio

Description jannis 2011-12-21 19:27:22 UTC
On my ~amd64 (and portage-2.2) system, I recently updated media-libs/x264 from version 0.0.20111017 to 0.0.20111218. This installed the library /usr/lib64/libx264.so.119 and changed the "default version" symlink: /usr/lib64/libx264.so -> libx264.so.119
Since I have portage-2.2, the old library (.118) was still kept around. Then I remerged all packages still linking to .118 so it could then be deleted. This worked for all packages but media-video/ffmpeg-0.9 which still linked against .118 afterwards.
Manually (re)moving the .118-library and then re-emerging ffmpeg worked.

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-12-22 15:16:18 UTC
Please post your `emerge --info' output too.
Comment 2 jannis 2011-12-22 17:36:29 UTC
Created attachment 296675 [details]
"emerge --info media-video/ffmpeg" from host ayanta

Yes, sorry, forgot that. Info from first host. Meanwhile, I deleted the old x264 so.118 and re-emerged ffmpeg
Comment 3 jannis 2011-12-22 17:42:27 UTC
Created attachment 296677 [details]
"emerge --info media-video/ffmpeg" from host mio

emerge --info from the other host. I just saw that x264-0.0.20111220 is out. Let's see wether there is a new .so-file (.120?) and how that behaves :)
Comment 4 jannis 2011-12-23 11:13:30 UTC
Ok, here's news:
I updated from x264-0.0.20111218 to x264-0.0.20111220. That introduced a new .so file ending with .120. Portage detected it correctly and told me that packages needed to be rebuilt. I rebuilt all packages but ffmpeg and verified with revdep-rebuild that only ffmpeg needed the .119-library. Then I rebuilt ffmpeg and this time it used the new library (.120) and portage deleted the old one.
So everything is fine and I close this bug as OBSOLETE