Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 395495

Summary: dev-lang/python-3.2.2 failed (test phase)
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Python Gentoo Team <python>
Status: RESOLVED OBSOLETE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log

Description Toralf Förster gentoo-dev 2011-12-21 09:01:07 UTC
Within a chrooted user-mode-linux I got :

FAIL: test_unwritable_directory (test.test_import.PycacheTests)


Reproducible: Always




n22 / # emerge --info
Portage 2.1.10.41 (default/linux/x86/10.0, gcc-4.6.2, glibc-2.14.1-r1, 3.1.5 i686)
=================================================================
System uname: Linux-3.1.5-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Wed, 21 Dec 2011 07:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 cli cracklib crypt cups cxx dri fam fastbuild gdbm gmp gpm iconv ipv6 logrotate mmx modules mudflap mysql mysqli ncurses nls nptl nptlonly openmp pam pcre pppd readline session sse sse2 sse3 ssl ssse3 sysfs tcpd threads unicode userlocales webmail x86 xml xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Toralf Förster gentoo-dev 2011-12-21 09:01:56 UTC
Created attachment 296549 [details]
build log
Comment 2 Arfrever Frehtes Taifersar Arahesis 2011-12-21 17:28:47 UTC
Build log shows unrelated failures in 4 files:
"320 tests OK.
4 tests failed:
    test_argparse test_dbm test_httpservers test_import"

At least some of them have been reported in other bugs. Failures in at least 2 files have been already fixed by upstream. Could you try test suite of dev-lang/python-3.2.3_pre20111218 from Progress Overlay?
Comment 3 Toralf Förster gentoo-dev 2011-12-21 19:30:59 UTC
(In reply to comment #2)
> Build log shows unrelated failures in 4 files:
> "320 tests OK.
> 4 tests failed:
>     test_argparse test_dbm test_httpservers test_import"
> 
> At least some of them have been reported in other bugs. Failures in at least 2
> files have been already fixed by upstream. Could you try test suite of
> dev-lang/python-3.2.3_pre20111218 from Progress Overlay?

Hhm, seems I need mercurial before ? Because I get :

$> ebuild python-3.2.3_pre20111218.ebuild test
Forcing test.
...
 * Cloning http://hg.python.org/cpython to /usr/portage/distfiles/hg-src/python/cpython
/var/tmp/portage/dev-lang/python-3.2.3_pre20111218/temp/environment: line 3365: hg: command not found
 * ERROR: dev-lang/python-3.2.3_pre20111218 failed (unpack phase):
 *   failed to clone http://hg.python.org/cpython
 * 
 * Call stack:


/me just wondering whether in this case mercurial should be a dependency of the python package ?
Comment 4 Arfrever Frehtes Taifersar Arahesis 2011-12-21 19:32:36 UTC
(In reply to comment #3)

`ebuild` command ignores dependencies.
Comment 5 Toralf Förster gentoo-dev 2011-12-21 22:15:43 UTC
(In reply to comment #2)
> Could you try test suite of
> dev-lang/python-3.2.3_pre20111218 from Progress Overlay?

much better, now I get :

328 tests OK.
22 tests skipped:
    test_codecmaps_cn test_codecmaps_hk test_codecmaps_jp
    test_codecmaps_kr test_codecmaps_tw test_curses test_kqueue
    test_msilib test_ossaudiodev test_smtpnet test_socketserver
    test_sqlite test_startfile test_timeout test_tk test_ttk_guionly
    test_urllib2net test_urllibnet test_winreg test_winsound
    test_xmlrpc_net test_zipfile64
2 skips unexpected on linux2:
    test_tk test_ttk_guionly
Comment 6 Toralf Förster gentoo-dev 2011-12-21 22:17:35 UTC
2nd note - tk is installed, but I got :

[305/352] test_tk
Invalid MIT-MAGIC-COOKIE-1 keytest_tk skipped -- tk not available: couldn't connect to display ":0"
[306/352] test_tokenize
[307/352] test_trace
[308/352] test_traceback
[309/352] test_ttk_guionly
test_ttk_guionly skipped -- tk not available: couldn't connect to display ":0"
Comment 7 Arfrever Frehtes Taifersar Arahesis 2011-12-21 22:35:52 UTC
(In reply to comment #6)

These tests are skipped, because ebuilds don't use virtualx.eclass to start Xvfb server, which would require dependencies on x11-base/xorg-server[xvfb] and x11-apps/xhost.
Comment 8 Toralf Förster gentoo-dev 2011-12-22 08:56:37 UTC
ok, so current python version 3.2.3_pre20111218 passes test fine - should this bug report be closed ? Or better let it be open to avoid duplicates ?
Comment 9 Toralf Förster gentoo-dev 2016-01-31 15:27:58 UTC
obsolete