Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 39493

Summary: emerge portage fails
Product: Gentoo Linux Reporter: Michele Alzetta <michele.alzetta>
Component: New packagesAssignee: Portage team <dev-portage>
Severity: major    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Michele Alzetta 2004-01-26 13:26:56 UTC
As suggested, I tried to emerge portage, but the build fails-

Reproducible: Always
Steps to Reproduce:
1.emerge portage

Actual Results:  
emerge portage
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/portage-2.0.49-r21 to /
>>> md5 src_uri ;-) portage-2.0.49-r21.tar.bz2
>>> Unpacking source...
>>> Unpacking portage-2.0.49-r21.tar.bz2 to /var/tmp/portage/portage-2.0.49-r21/work
>>> Source unpacked.
Checking truncate argument type... off_t
Checking libc version...
Checking glibc subversion...
gcc -march=i386 -O1 -pipe -Wall -c -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
gcc -march=i386 -O1 -pipe -Wall -c -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
gcc libsandbox.o sandbox_futils.o -shared -fPIC -ldl -lc -o
-nostdlib -lgcc
gcc -march=i386 -O1 -pipe -Wall -c sandbox.c
gcc sandbox.o sandbox_futils.o getcwd.c -ldl -lc -o sandbox
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.3/../../../ undefined reference
to `_dl_rtld_di_serinfo@GLIBC_PRIVATE'
collect2: ld returned 1 exit status
make: *** [sandbox] Error 1

!!! ERROR: sys-apps/portage-2.0.49-r21 failed.
!!! Function src_compile, Line 43, Exitcode 2
!!! (no error message)
Comment 1 Michele Alzetta 2004-01-26 13:28:09 UTC
emerge -V portage
Portage 2.0.49-r20 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r9, 2.4.22-gentoo-r5)
Comment 2 SpanKY gentoo-dev 2004-01-26 18:26:30 UTC
could you try re-emering glibc please

and if that doesnt work, try re-emerging gcc
Comment 3 Michele Alzetta 2004-01-27 11:48:52 UTC
I reemerged glibc successfully; however, that did not solve the problem.
I then tried to emerge gcc, which failed.
Here is the error message:

./.libs/ undefined reference to `dlopen'
collect2: ld returned 1 exit status
make[3]: *** [jv-convert] Error 1
make[3]: *** Waiting for unfinished jobs....
./.libs/ undefined reference to `dlopen'
collect2: ld returned 1 exit status
make[3]: *** [gij] Error 1
make[3]: Leaving directory `/var/tmp/portage/gcc-3.2.3-r3/work/build/i686-pc-linux-gnu/libjava'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gcc-3.2.3-r3/work/build/i686-pc-linux-gnu/libjava'
make[1]: *** [all-target-libjava] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.2.3-r3/work/build'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-3.2.3-r3 failed.
!!! Function src_compile, Line 411, Exitcode 2
!!! (no error message)

Now what ?
Comment 4 Michele Alzetta 2004-01-29 04:04:04 UTC
I also upgraded gcc-config and retried emerging gcc, but I keep getting the same mistake.
Comment 5 Michele Alzetta 2004-01-29 08:38:49 UTC
I managed to re-emerge gcc with
USE="-java" emerge gcc
however the problem with portage persists.
Comment 6 Brian Harring (RETIRED) gentoo-dev 2004-07-16 02:15:01 UTC
Michele, are you still having issues w/ sandbox compilation?
Reopen if the issue still exists.
Comment 7 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 11:01:00 UTC
Closing due to old age