Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 394875

Summary: media-sound/pulseaudio - module-tunnel-sink is unreliable
Product: Gentoo Linux Reporter: Victor Mataré <matare>
Component: Current packagesAssignee: Gentoo Sound Team <sound>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: christoph.gysin, sound
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Victor Mataré 2011-12-15 23:32:05 UTC
as of pulseaudio-1.0, module-tunnel-sink is the only usable way of putting the sound through a networked sound server. It does have the theoretically nice feature of live stream migration, but in practice it's just unstable as hell. Youtube plays only the sound while the video is frozen. Xine crashes after switching between networked and local sound twice. Note that when using a direct connection to the networked server without a tunnel sink, everything works fine (apart from the occasional glitch).

I think this should be fixed before >=media-sound/pulseaudio-1.0 stabilization since it's a major regression. I haven't checked what upstream knows about this issue yet, but I do know about this other bug which also breaks module-zeroconf-discover (which should automatically add local tunnel sinks for networked sinks) in conjunction with IPv6-enabled avahi:

http://pulseaudio.org/ticket/694

This has been sitting there for two years now, which looks to me like upstream is neglecting network functionality a bit. See also http://lists.freedesktop.org/archives/pulseaudio-discuss/2011-December/012474.html .

The IPv6 issue seems trivial enough, but right now I don't have enough time to investigate those pretty serious playback issues.

Reproducible: Always
Comment 1 Arun Raghavan (RETIRED) gentoo-dev 2011-12-30 03:11:08 UTC
You can read the reply to the email you pointed to for upstream's take on the issue -- http://lists.freedesktop.org/archives/pulseaudio-discuss/2011-December/012478.html

(tl;dr: misbehaving clients become much more apparent on network sinks, and there's a lot of those that we have no control over. Also, the network sink needs some love, but there isn't anyone volunteering to work on it at the moment.)

With that out of the way, are you saying that stream moves to a tunnel sink worked fine at some point? If yes, some more information (like what what version it last worked in) would be helpful.
Comment 2 Victor Mataré 2011-12-30 15:04:46 UTC
> With that out of the way, are you saying that stream moves to a tunnel sink
> worked fine at some point? If yes, some more information (like what what
> version it last worked in) would be helpful.

Nope, I never tried tunneling a network sink before, but as I read it, the unreliability is simply due to the current status of tunnel and client code. I think the shortcut to fixing the issue is in this forum post: http://forums.gentoo.org/viewtopic.php?p=6914120#6914120

Colin also stated on pulseaudio-discuss that re-implementing the old, reliable functionality of telling the client to connect to a networked server via the PULSE_SERVER property of the X11 root window should be straightforward. This could be easily implemented in pasystray and we'd have a quick solution while module-tunnel-sink is being fixed (which will take some time I think).
Comment 3 Pacho Ramos gentoo-dev 2012-12-15 12:50:15 UTC
Is this still valid with latest pulseaudio?
Comment 4 Pacho Ramos gentoo-dev 2014-02-16 19:34:38 UTC
(In reply to Pacho Ramos from comment #3)
> Is this still valid with latest pulseaudio?