Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 392437

Summary: net-misc/remmina-9999: Build system moved to cmake
Product: Gentoo Linux Reporter: Chris Smith <chris>
Component: New packagesAssignee: Tristan Heaven (RETIRED) <tristan>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: dustin, floppym, hwoarang
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: aclocal.out
build log with libappindicator failure
build log with libvncserver failure

Description Chris Smith 2011-11-29 17:04:30 UTC
remmina-9999 fails during prepare stage

Reproducible: Always

Steps to Reproduce:
1.emerge =remmina-9999
2.
3.
Actual Results:  
>>> Unpacked to /var/tmp/portage/net-misc/remmina-9999/work
>>> Source unpacked in /var/tmp/portage/net-misc/remmina-9999/work
>>> Preparing source in /var/tmp/portage/net-misc/remmina-9999/work/remmina ...
 * Running eautoreconf in '/var/tmp/portage/net-misc/remmina-9999/work/remmina' ...
 * Running aclocal ...                                                                                 [ !! ]

 * Failed Running aclocal !
Comment 1 Chris Smith 2011-11-29 17:09:10 UTC
Created attachment 294205 [details]
aclocal.out
Comment 2 Chris Smith 2011-11-29 17:11:09 UTC
(In reply to comment #0)

Corrected output:

>>> Unpacked to /var/tmp/portage/net-misc/remmina-9999/work
>>> Source unpacked in /var/tmp/portage/net-misc/remmina-9999/work
>>> Preparing source in /var/tmp/portage/net-misc/remmina-9999/work/remmina ...
intltoolize: neither 'configure.ac' nor 'configure.in' exists
Try 'intltoolize --help' for more information.
 * Running eautoreconf in '/var/tmp/portage/net-misc/remmina-9999/work/remmina' ...
 * Running aclocal ...                                                                                 [ !! ]

 * Failed Running aclocal !
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2012-02-12 10:02:05 UTC
*** Bug 392439 has been marked as a duplicate of this bug. ***
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2012-02-12 10:46:38 UTC
Fixed
Comment 5 Chris Smith 2012-02-12 21:33:07 UTC
(In reply to comment #4)
> Fixed

Not working here:
======================================
-- Finding suggested package APPINDICATOR.
--   Disable this using "-DWITH_APPINDICATOR=OFF".
-- checking for module 'appindicator3-0.1'
--   package 'appindicator3-0.1' not found
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find APPINDICATOR (missing: APPINDICATOR_LIBRARY
  APPINDICATOR_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindAPPINDICATOR.cmake:30 (find_package_handle_standard_args)
  cmake/FindOptionalPackage.cmake:37 (find_package)
  remmina/CMakeLists.txt:127 (find_suggested_package)
======================================

I then installed dev-libs/libappindicator and got:
======================================
-- Finding suggested package APPINDICATOR.
--   Disable this using "-DWITH_APPINDICATOR=OFF".
-- checking for module 'appindicator3-0.1'
--   found appindicator3-0.1, version 0.4.1
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find APPINDICATOR (missing: APPINDICATOR_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindAPPINDICATOR.cmake:30 (find_package_handle_standard_args)
  cmake/FindOptionalPackage.cmake:37 (find_package)
  remmina/CMakeLists.txt:127 (find_suggested_package)
======================================
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2012-02-12 21:38:21 UTC
I need a full build.log. I can't figure out the problem this way. In any case, i did a minor modification. Sync in a couple of hours and try again
Comment 7 Chris Smith 2012-02-13 19:10:11 UTC
Apparently remmina only looks for libappindicator if gtk3 is found. The problem is, is that it doesn't find it even if it's installed.

If I:
=====================
cd /usr/include
ln -s libappindicator3-0.1/libappindicator libappindicator
=====================
then all is well. Either we must pass the proper location of the libappindicator include headers to remmina or have the libappindicator ebuild create the symlink as above (or place the headers a more "standard" location so apps can locate the information).

Also with the git master build, unlike the packaged release, it seems that libvncserver is a dependency.

To sum up, installing libappindicator and libvncserver, and creating the symlink as above allows remmina-9999 to build.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2012-02-13 19:33:16 UTC
I said that I need a build.log. Without that I can't do much
Comment 9 Chris Smith 2012-02-13 19:49:17 UTC
Created attachment 301803 [details]
build log with libappindicator failure

shows the libappindicator failure - seems this is looked for if GTK3 is found
Comment 10 Chris Smith 2012-02-13 19:51:13 UTC
Created attachment 301805 [details]
build log with libvncserver failure

shows the failure to find libvncserver - this ships in the release tarball, apparently not in git master and needs to be a dependency
Comment 11 Chris Smith 2012-02-13 19:53:36 UTC
Also get no menu item anywhere in applications.