Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 392401

Summary: media-gfx/mypaint-0.9.1 (and 1.0.0) Can't paint after focus change
Product: Gentoo Linux Reporter: Yaroslav Klyuev <imposeren>
Component: Current packagesAssignee: Markos Chandras (RETIRED) <hwoarang>
Severity: normal CC: gentoo-bugz
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---

Description Yaroslav Klyuev 2011-11-29 14:29:09 UTC
After changing focus to any other application mypaint stops working correct: lines are drawn oly when mouse hits window edge.

Reproducible: Always

Steps to Reproduce:
1. start mypaint
2. draw something (fine)
3. change window to something else
4. change back to mypaint and try to draw
Actual Results:  
lines are drawn only when mouse hits window edge

Expected Results:  
Lines should be drawn under cursor

Tried using in awesomeWM and in plain startx — same results.

Have already posted to mypaint bugtracker but user with debian and awesomeWM sais that everything works fine.
Tried remerging gtk, cairo, pygtk, pycairo, numpy, python, protobuf, scons, swig
Comment 1 Sebastian Parborg 2011-11-30 22:34:00 UTC
I also use awesomeWM and I don't have (and never had) this problem.
I'm currently running awesome 3.4.10 on ~amd64.

This won't be much help, but at least now you know it works on a different gentoo system.

Does this happen in say GIMP or any other graphics software?
Comment 2 Yaroslav Klyuev 2011-12-01 07:32:21 UTC
>> Does this happen in say GIMP or any other graphics software?
GIMP and Inkscape work just fine
Comment 3 Jan Kuemmel 2012-10-09 19:17:00 UTC
I can reproduce it with metacity and compiz. Not only when focus leaves the application, also when focus is transferred to a popup window like the brush list editor.
Comment 4 Jan Kuemmel 2012-10-09 21:09:58 UTC
I can see this line several times on the console when mypaint is running:
Ignoring "Logitech Gaming Mouse G400" (probably a mouse, but it reports extra axes)

This line is printed in line 374 (in mypaint 1.0.0)
If I remove the "continue" in the following line, the bug is gone. is mentioned there.
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2016-03-06 11:25:24 UTC
This versions is no longer in the tree