Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 389591

Summary: media-gfx/zgv-5.9 fails to build with libpng15
Product: Gentoo Linux Reporter: Navid Zamani <navid.zamani>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal CC: ssuominen
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 354479    
Attachments: zgv-5.9-libpng15.patch

Description Navid Zamani 2011-11-05 02:58:56 UTC
On my hardened home server (the only one I use zgv on), zgv fails to compile because of a error in the code:

Reproducible: Always

Steps to Reproduce:
1. (Only it isn’t reproducible withougt:) Be sure you are on the hardened/linux/x86 profile
2. emerge media-gfx/zgv # this will emerge zgv-5.9, as it is the only available version.
Actual Results:  
… (The relevant part of the build log:)
readpng.c: In Funktion »my_png_error«:
readpng.c:66:16: Fehler: Dereferenzierung eines Zeigers auf unvollständigen Typen
readpng.c: In Funktion »read_png_file«:
readpng.c:135:4: Fehler: Dereferenzierung eines Zeigers auf unvollständigen Typen
make[1]: *** [readpng.o] Fehler 1


Expected Results:  
Normal compilation and installation of zgv.
Comment 1 Navid Zamani 2011-11-05 03:00:25 UTC
emerge --info:

Portage 2.1.10.32 (hardened/linux/x86, gcc-4.5.3, glibc-2.12.2-r0, 3.0.4-hardened-r4 i686)
=================================================================
System uname: Linux-3.0.4-hardened-r4-i686-Intel-R-_Xeon-TM-_CPU_3.06GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 04 Nov 2011 17:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.68
sys-devel/automake:       1.8.5-r4, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo gentoo-haskell amielke-overlay java-overlay roslin sunrise dfreise local
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4      -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium4      -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs candy ccache collision-protect compress-build-logs distlocks ebuild-locks fail-clean fixlafiles metadata-transfer news nostrip parallel-fetch protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="de en en_GB fr"
MAKEOPTS="-j3 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/p2p/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/haskell /var/lib/layman/amielke-overlay /var/lib/layman/java-overlay /var/lib/layman/roslin /var/lib/layman/sunrise /var/lib/layman/dfreise /usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="a52 aac acl acpi afs aim alsa ao apache2 audiofile bash-completion bluetooth branding bzip2 calendar cdda cddb cdinstall cdparanoia cdr cgi clamav cli cracklib crypt css cups curl curlwrappers cxx dbm dbus dedicated djvu doc dri dts dvb dvd dvdr encode examples exif fam fastcgi fbcon ffmpeg fftw flac flatfile fontconfig foomaticdb ftp gd gdbm geoip gif gmp gnuplot gnutls gpm graphviz gsm hardened hddtemp hscolour iconv icq idn ieee1394 imagemagick imap imlib inifile ipv6 jabber jack java java6 javascript jingle joystick jpeg jpeg2k kerberos lame lcms ldap libsamplerate libwww lirc lm_sensors lzma lzo mad maildir matroska matrox memlimit mime mmap mms mmx mng modules mp3 mp4 mpeg msn mtp mudflap musepack musicbrainz ncurses nls nocd nptl nptlonly offensive ogg openal openmp oscar oss pam pax_kernel pcre pdf php pic png posix postgres ppds pppd prelude python quicktime readline rss samba sasl scanner session sharedext sharedmem smartcard smp sndfile sockets sound sox speex spell sse sse2 ssl sysfs syslog sysvipc taglib tcpd theora threads tidy tiff timidity tokenizer truetype udev unicode urandom usb v4l v4l2 vcd vhosts vim-syntax vorbis win32codecs x264 x86 xattr xface xml xmpp xorg xvid yahoo zlib zsh-completion" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FRITZCAPI_CARDS="fcpci" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse lirc joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_GB fr" LIRC_DEVICES="livedrive_midi" MISDN_CARDS="avmfritz" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="mga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Samuli Suominen gentoo-dev 2011-11-05 04:32:50 UTC
Created attachment 291723 [details, diff]
zgv-5.9-libpng15.patch

epatch "${FILESDIR}"/zgv-5.9-libpng15.patch to the ebuild

note: untested because I don't have x86 system to try this and the package is 32bit compatible only because of svgalib
Comment 3 Samuli Suominen gentoo-dev 2011-11-05 04:36:32 UTC
CCing x86 in case one of the AT's could help me out here and try this patch. A bit unorthodox, sorry about that.
Comment 4 Navid Zamani 2011-11-05 06:05:07 UTC
(In reply to comment #3)
Hey, thanks man. No need to be sorry, I appreciate your help. :)

I’m experienced with making local version of ebuilds and adding patches to them. I’ll try your patch right now.
Comment 5 Navid Zamani 2011-11-05 06:30:26 UTC
Ok, that worked nicely. Problem solved. Thanks. :)
Comment 6 Samuli Suominen gentoo-dev 2011-11-05 06:54:47 UTC
Don't close bugs as "RESOLVED, FIXED" before the fix is in portage again.

Anyway, applied in portage now so leaving closed.
Comment 7 Navid Zamani 2011-11-05 08:03:57 UTC
Oh, sorry … I forgot.
Usually I’m the one complaining about that. ^^