Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 386539

Summary: sys-boot/grub-1.99-r2 doesn't detect framebuffer resolutions if /usr is not mounted
Product: Gentoo Linux Reporter: Joel <joel>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Severity: normal CC: bkohler
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info

Description Joel 2011-10-09 16:08:27 UTC
I'm using an EFI system (not mac) with an /usr separated partition. If that partition is not mounted, grub is not able to detect any efi-framebuffer resolution and the boot process shows a black screen. If the partition is mounted before boot (I've moved it), everything works ok. 
I tried to build grub2 with "static" USE Flag, but the problem still exists. 

Reproducible: Always
Comment 1 Joel 2011-10-09 16:09:28 UTC
Created attachment 289371 [details]
emerge --info
Comment 2 SpanKY gentoo-dev 2011-10-09 16:16:26 UTC
what exactly are you running ?
Comment 3 Joel 2011-10-09 16:21:48 UTC
(In reply to comment #2)
> what exactly are you running ?

Gentoo ~amd64 on a Intel i5 2500K
Comment 4 SpanKY gentoo-dev 2011-10-09 17:04:05 UTC
sorry, i meant what grub commands
Comment 5 Joel 2011-10-09 19:11:56 UTC
Sorry, I didn't understand you. I won't be able to upload the grub config until Friday night (the computer is on different town and with no Internet connection), but I installed grub-1.99-r2 with USE="grub_platforms_efi-64 device-mapper nls sdl truetype" (tried also with static), and the only change I made was in /etc/defaults/grub gfxmode to 1024x768x32 (as I said, works with mounted /usr). 

When installing grub, I made:

emerge grub
grub2-mkconfig -o /boot/grub2/grub.cfg
Comment 6 Joel 2011-10-10 12:22:28 UTC
Happens also with no EFI system. videoinfo is not able to find any resolutions, but luckily, on this other system Intel KMS works ok.
Comment 7 Ben Kohler gentoo-dev 2014-08-08 17:19:36 UTC
I don't understand how /usr is related at all to how grub2 behaves @ boot. Are the files in /boot/grub/x86_64-efi symlinks to stuff in /usr perhaps?