Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 383491

Summary: app-cdr/dvdisaster-0.72.2 fails to emerge because of dropped patch
Product: Gentoo Linux Reporter: Jean-Francois Ostiguy <jfostiguy>
Component: Current packagesAssignee: Steve Dibb (RETIRED) <beandog>
Status: RESOLVED FIXED    
Severity: normal CC: hsggebhardt, media-optical, qa, rose, zeekec
Priority: Normal Keywords: REGRESSION
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 354479    
Attachments: build log
dvdisaster.patch add libpng15 to ebuild

Description Jean-Francois Ostiguy 2011-09-18 13:39:51 UTC
dvdisaster-0.72.2 fails during the install phase. 

....
install -d /var/tmp/portage/app-cdr/dvdisaster-0.72.2/image//usr/share/doc/dvdisaster-0.72.2/$i/thumbnails; \
  (cd documentation/$i; install -m 644 thumbnails/*.png /var/tmp/portage/app-cdr/dvdisaster-0.72.2/image//usr/share/doc/dvdisaster-0.72.2/$i/thumbnails); \
done
install: cannot stat `images/*.png': No such file or directory
install: cannot stat `thumbnails/*.png': No such file or directory
install: cannot stat `images/*.png': No such file or directory
install: cannot stat `thumbnails/*.png': No such file or directory
install: cannot stat `images/*.png': No such file or directory
install: cannot stat `thumbnails/*.png': No such file or directory
make: *** [install] Error 1
emake failed
 * ERROR: app-cdr/dvdisaster-0.72.2 failed (install phase):
 *   emake install failed
 * 
 * Call stack:
 *     ebuild.sh, line  91:  Called src_install
 *   environment, line 2727:  Called die
 * The specific snippet of code:
 *       emake install || die "emake install failed";


Reproducible: Always
Comment 1 Jean-Francois Ostiguy 2011-09-18 13:58:24 UTC
Created attachment 286895 [details]
build log



A closer look suggests that the problem is caused by a the fact that  
"Z_BEST_COMPRESSION" is undefined. Not sure where this comes from (libz ?).
The relevant lines are (full build log is attached):

  ngio.c: In function ‘SavePNG’:
pngio.c:207:45: error: ‘Z_BEST_COMPRESSION’ undeclared (first use in this function)
pngio.c:207:45: note: each undeclared identifier is reported only once for each function it appears in
pngio.c: In function ‘LoadPNG’:
pngio.c:84:9: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
gmake[1]: *** [pngio.o] Error 1
gmake[1]: *** Waiting for unfinished jobs....
Unpacking images (may take a while) ... /bin/bash: line 6: /var/tmp/portage/app-cdr/dvdisaster-0.72.2/work/dvdisaster-0.72.2/tools/pngp
ack: No such file or directory
Comment 2 Samuli Suominen gentoo-dev 2011-09-18 15:27:16 UTC
beandog, please stop dropping patches. this is the second package now, after dvdauthor.

i didn't add the zlib.h include for fun.

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-cdr/dvdisaster/dvdisaster-0.72.1.ebuild?r1=1.2&r2=1.3
Comment 3 Samuli Suominen gentoo-dev 2011-09-19 07:51:38 UTC
*** Bug 383597 has been marked as a duplicate of this bug. ***
Comment 4 Joerg Neikes 2011-09-20 15:30:44 UTC
Created attachment 287175 [details, diff]
dvdisaster.patch add libpng15 to ebuild

wget "http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild?revision=1.1" -O dvdisaster-0.72.2.ebuild

cp dvdisaster-0.72.2.ebuild /usr/portage/app-cdr/dvdisaster/
cp /usr/portage/app-cdr/dvdisaster/files/dvdisaster-0.72.1-libpng15.patch /usr/portage/app-cdr/dvdisaster/files/dvdisaster-0.72.2-libpng15.patch
cd  /usr/portage/app-cdr/dvdisaster/

patch -p1 < dvdisaster.patch

ebuild /usr/portage/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild digest
Comment 5 Juergen Rose 2011-09-20 16:23:16 UTC
The dvdisaster-0.72.2.ebuild from http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild?revision=1.1 is identical with dvdisaster-0.72.2.ebuild from the portage tree (/usr/portage/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild).

I then tried to follow the recipe of Comment 4 with except that, I copied /usr/portage/app-cdr/dvdisaster to /usr/local/portage/app-cdr/dvdisaster.
The patch command failed then with:

root@moose:/usr/local/portage/app-cdr/dvdisaster(56)# patch -p1 <  ~rose/Txt/Patches/dvdisaster.patch 
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- /usr/portage/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild    2011-09-20 16:55:08.106419049 +0200
|+++ /usr/portage/app-cdr/dvdisaster/dvdisaster-0.72.1.ebuild    2011-09-20 17:06:20.053318543 +0200
--------------------------
File to patch:

If I then try 'patch -p5 <  ~rose/Txt/Patches/dvdisaster.patch', it fails with:

patching file dvdisaster-0.72.2.ebuild
Hunk #3 FAILED at 51.
1 out of 3 hunks FAILED -- saving rejects to file dvdisaster-0.72.2.ebuild.rej

In dvdisaster-0.72.2.ebuild.rej I then find the following:

root@moose:/usr/local/portage/app-cdr/dvdisaster(64)# cat dvdisaster-0.72.2.ebuild.rej
--- dvdisaster-0.72.2.ebuild 2011-09-20 16:55:08.106419049 +0200
+++ dvdisaster-0.72.1.ebuild 2011-09-20 17:06:20.053318543 +0200
@@ -51,12 +55,11 @@
                --localedir=/usr/share/locale \
                --buildroot="${D}" \
                --with-nls=no \
-               ${myconf} \
-               || die "./configure failed"
+               ${myconf} || die
 }
 
 src_install() {
-       emake install || die "emake install failed"
+       emake install
 
        newicon contrib/${PN}48.png ${PN}.png
        make_desktop_entry ${PN} ${PN} ${PN} "System;Utility"

Any hint is appreciated.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-23 08:47:04 UTC
+  23 Sep 2011; Lars Wendler <polynomial-c@gentoo.org> dvdisaster-0.72.2.ebuild:
+  non-maintainer commit: Readded libpng15 patch. Moved ebuild back to EAPI-4.
+  Should fix bug #383491 reported by Jean-Francois Ostiguy.
+