Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 383113

Summary: www-client/lynx-2.8.8_pre9 fails to build
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: Current packagesAssignee: Tim Harder <radhermit>
Status: RESOLVED FIXED    
Severity: normal CC: bug, realnc, ulm, wormo, zeekec
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 383179    
Bug Blocks:    
Attachments: build.log
Patch against Lynx 2.8.8_pre9

Description Dennis Schridde 2011-09-15 14:54:15 UTC
In file included from ../../../WWW/Library/Implementation/HTTP.c:14:0:
../../../src/LYUtils.h:525:0: warning: "ON" redefined [enabled by default]
/usr/include/zconf.h:250:0: note: this is the location of the previous definition
In file included from ../../../WWW/Library/Implementation/HTAccess.c:68:0:
../../../src/LYUtils.h:525:0: warning: "ON" redefined [enabled by default]
/usr/include/zconf.h:250:0: note: this is the location of the previous definition
In file included from ../../../WWW/Library/Implementation/HTFormat.h:31:0,
                 from ../../../WWW/Library/Implementation/HTAnchor.h:28,
                 from ../../../src/LYStructs.h:8,
                 from ../../../src/LYGlobalDefs.h:15,
                 from ../../../WWW/Library/Implementation/HTParse.c:15:
/usr/include/zlib.h:1283:32: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before numeric constant
make[1]: *** [HTParse.o] Error 1

Full build.log attached.

Reproducible: Always




Portage 2.2.0_alpha58 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.1, glibc-2.13-r4, 3.0.4-gentoo x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.0.3
Timestamp of tree: Thu, 15 Sep 2011 11:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1, 4.6.1-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo kde sunrise local
Installed sets: @kdebase
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3 -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3 -ftree-vectorize"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check n --with-bdeps y --keep-going"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/layman/kde /var/cache/portage/layman/sunrise /var/cache/portage/local"
[...]
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dennis Schridde 2011-09-15 14:54:32 UTC
Created attachment 286557 [details]
build.log
Comment 2 Ian Abbott 2011-09-15 18:16:08 UTC
It looks like the incompatibility is with zlib-1.2.5.1.  It affects older versions of lynx too!

I must say that 'ON' is a stupid name for a macro in the zlib header files!
Comment 3 Nikos Chantziaras 2011-09-15 19:57:07 UTC
Created attachment 286575 [details]
Patch against Lynx 2.8.8_pre9

I patched the sources of Lynx 2.8.8_pre9 to rename ON to LON and OFF to LOFF. It should now build and work fine.

I am attaching the patch. I did not send this upstream.
Comment 4 Tim Harder gentoo-dev 2011-09-15 20:39:05 UTC
Fixed in CVS.
Comment 5 Nikos Chantziaras 2011-09-18 10:47:55 UTC
I now sent this upstream, but we will have to wait and see whether upstream zlib (they are now aware of the issue) will fix this and use more appropriate identifiers for those macros. So this patch might not be needed in the future.

Also, SpanKY has patched zlib itself (1.2.5.1-r1, see bug 383179). So the lynx patch is actually not needed right now.  But I guess we need to wait and see how this whole thing will resolve.
Comment 6 SpanKY gentoo-dev 2011-09-24 05:25:25 UTC
this was actually a dupe of Bug 383179