Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 382951

Summary: Please stabilise app-text/ghostscript-gpl-9.04-r4
Product: Gentoo Linux Reporter: Timo Gurr (RETIRED) <tgurr>
Component: [OLD] Keywording and StabilizationAssignee: Printing Team <printing>
Status: RESOLVED FIXED    
Severity: enhancement CC: ct
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://ghostscript.com/pipermail/gs-devel/2011-August/009019.html
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 383625    
Bug Blocks: 384701    
Attachments: ghostscript-gpl.report

Description Timo Gurr (RETIRED) gentoo-dev 2011-09-14 13:07:13 UTC
* Recommended version by upstream
* Improved compatibility over old versions
* No known regressions in functionality (finally)
* Works with libpng15
* Remaining open bugs are cosmetic

Please stabilise and thanks in advance!
Comment 1 Agostino Sarubbo gentoo-dev 2011-09-14 18:30:17 UTC
--- !empty   dir /etc/cups
--- !empty   dir /etc
 * One or more symlinks to directories have been preserved in order to
 * ensure that files installed via these symlinks remain accessible:
 * 
 *      /usr/share/fonts/default/ghostscript
 * 
>>> Regenerating /etc/ld.so.cache...


Is that expected? tell me if I should file a new bug
Comment 2 Myckel Habets 2011-09-14 18:35:54 UTC
All ebuilds that could satisfy ">=app-text/poppler-data-0.4.4" have been masked.

stabilizing poppler-data-0.4.4 as well?
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2011-09-15 06:13:09 UTC
would have to.

emerges ok. rdeps ok. however

gentoo64 / # ls -ld /usr/share/fonts/default/ghostscript
ls: cannot access /usr/share/fonts/default/ghostscript: No such file or directory

* One or more symlinks to directories have been preserved in order to
* ensure that files installed via these symlinks remain accessible:

implies it ought to have been preserved.
Comment 4 Timo Gurr (RETIRED) gentoo-dev 2011-09-15 09:08:04 UTC
(In reply to comment #2)
> stabilizing poppler-data-0.4.4 as well?

Yes, please (it contains the cMap's which we strip from ghostscript).

(In reply to comment #3)
> gentoo64 / # ls -ld /usr/share/fonts/default/ghostscript
> ls: cannot access /usr/share/fonts/default/ghostscript: No such file or
> directory
> 
> implies it ought to have been preserved.

That's perfectly fine. Previously the files were installed by gnu-gs-fonts-std which has been replaced by urw-fonts nowadays and the old ghostscript ebuild symlinked the location for compatibility reasons. The recent ghostscript ebuild has the urw-fonts search path directly appended, so a symlink /usr/share/fonts/default/ghostscript which points to urw-fonts isn't needed anymore.
Comment 5 Agostino Sarubbo gentoo-dev 2011-09-15 09:23:00 UTC
Thanks Timo for the info.


both ok on amd64 for me.
Comment 6 Tony Vroon gentoo-dev 2011-09-16 13:17:51 UTC
+  16 Sep 2011; Tony Vroon <chainsaw@gentoo.org> ghostscript-gpl-9.04-r3.ebuild:
+  Marked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Ian
+  "idella4" Delaney in bug #382951.
Comment 7 David Abbott gentoo-dev 2011-09-16 23:22:35 UTC
Arch tested on x86, all good here ...
Comment 8 David Abbott gentoo-dev 2011-09-16 23:24:40 UTC
Created attachment 286719 [details]
ghostscript-gpl.report

Tested with HP Deskjet 6940 series
Works Fine ...
Comment 9 Myckel Habets 2011-09-17 07:15:44 UTC
(In reply to comment #7)
> Arch tested on x86, all good here ...

+1
Comment 10 Markus Meier gentoo-dev 2011-09-18 22:00:54 UTC
x86 stable, thanks Myckel and David
Comment 11 Markus Meier gentoo-dev 2011-10-05 05:50:50 UTC
arm stable
Comment 12 Jeroen Roovers gentoo-dev 2011-10-05 16:55:09 UTC
Amazing that bug #367239 isn't fixed yet.
Comment 13 Jeroen Roovers gentoo-dev 2011-10-06 17:41:34 UTC
Stable for HPPA.
Comment 14 Samuli Suominen gentoo-dev 2011-10-12 16:24:23 UTC
ppc* stable (both compile tested)
Comment 15 Timo Gurr (RETIRED) gentoo-dev 2011-10-19 21:17:03 UTC
Please proceed with -r4 instead of -r3, it contains a small fix/workaround (pstoraster symlink) for bug #383831 which affects stable users.
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2011-10-30 17:20:26 UTC
alpha/ia64/s390/sh/sparc stable
Comment 17 Raúl Porcel (RETIRED) gentoo-dev 2011-10-30 17:22:52 UTC
Closing
Comment 18 Samuli Suominen gentoo-dev 2011-10-31 00:06:21 UTC
(In reply to comment #16)
> alpha/ia64/s390/sh/sparc stable

reopening since nothing was ever committed:

ghostscript-gpl-9.04-r4.ebuild:KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
Comment 19 Raúl Porcel (RETIRED) gentoo-dev 2011-10-31 06:07:28 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > alpha/ia64/s390/sh/sparc stable
> 
> reopening since nothing was ever committed:
> 
> ghostscript-gpl-9.04-r4.ebuild:KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc
> ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"

you weren't commited!

done, closing