Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 38155

Summary: genkernel fails: compile of modules failed
Product: Gentoo Hosted Projects Reporter: nicholas Blackaby <n.blackaby>
Component: genkernelAssignee: x86-kernel (DEPRECATED) <x86-kernel>
Severity: normal CC: luke-jr+gentoobugs
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 34948    
Bug Blocks:    

Description nicholas Blackaby 2004-01-14 03:48:35 UTC
linux # genkernel all
GenKernel v3.0.1_beta4-3
* ARCH: x86
* KERNEL VER: 2.4.22-gentoo-r4
* kernel: configuring source
* kernel: running mrproper
* kernel: using config from /usr/share/genkernel/x86/kernel-config-2.4
* kernel: running oldconfig
* kernel: running clean
* kernel: Making dependencies for linux 2.4.22-gentoo-r4
* kernel: Starting compile of linux 2.4.22-gentoo-r4 bzImage
* kernel: Starting compile of linux 2.4.22-gentoo-r4 modules
* gen_die(): compile of modules failed

Reproducible: Always
Steps to Reproduce:
1.emerge -D world /usr/src; rm linux; ln -s linux-2.4.22-gentoo-r4 linux
3.genkernel all

Actual Results:  
Genkernel does not complete; see details above.

Expected Results:  
Genkernel should have run to completion.

Portage 2.0.49-r21 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r3, 2.4.22-gentoo-
System uname: 2.4.22-gentoo-r2 i686 Pentium III (Coppermine)
Gentoo Base System version
CFLAGS="-O3 -march=pentium3 -fprefetch-loop-arrays -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/s
hare/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -fprefetch-loop-arrays -funroll-loops -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X apm arts avi berkdb crypt cups encode esd foomaticdb gdbm gif gnome gpm 
gtk gtk2 imlib java jpeg libg++ libwww mad mikmod motif mozilla mpeg ncurses 
nls oggvorbis opengl oss pam pdflib perl png python quicktime readline sdl 
slang spell ssl svga tcpd truetype x86 xml2 xmms xv zlib"
Comment 1 nicholas Blackaby 2004-01-14 05:16:12 UTC
Please ignore and close this report. I ran genkernel with -debug options and got different result.
Comment 2 nicholas Blackaby 2004-01-14 05:17:04 UTC
Cannot reproduce error.
Comment 3 nicholas Blackaby 2004-01-19 04:49:49 UTC
I have chosen to re-open this bug since I have still not been able to complile the latest Gentoo Kernel using genkernel.
This morning, I have run emerge sync and then emerge -D world but it still fails at the same place:

chilly linux # genkernel --clean all
GenKernel v3.0.1_beta6
* ARCH: x86
* KERNEL VER: 2.4.22-gentoo-r5
* kernel: configuring source
* kernel: running mrproper
* kernel: using config from /usr/share/genkernel/x86/kernel-config-2.4
* kernel: running oldconfig
* kernel: running clean
* kernel: Making dependencies for linux 2.4.22-gentoo-r5
* kernel: Starting compile of linux 2.4.22-gentoo-r5 bzImage
* kernel: Starting compile of linux 2.4.22-gentoo-r5 modules
* gen_die(): compile of modules failed
chilly linux #
Comment 4 Aaron Peterson 2004-01-19 06:05:15 UTC
read the /var/log/genkernel.log file

I ran into problems that the configurator (menuconfig)
allowed me to select a component having to do with netfilter... that happened to need something with  QoS or other...  without selecting the quality of service monitoring stuff.

The log will tell you how to do it

This is a duplicate of/or depends on:

Comment 5 Brad House 2004-01-19 07:02:14 UTC
ok, who reopened this bug?
this is freaking closed!
This is in no way a genkernel issue
Comment 6 Aaron Peterson 2004-01-20 06:13:38 UTC
This was reopened because the end user had a problem.

I am an end user, and attempting to fix my percieved issues.  problem statements and understanding the problem is part of this.

genkernel is the tool for building kernels.
the kernel compile failed.

The user was baffeled.
but the user found --debug

why isnt' --debug on by default?

I haven't used --debug yet
but I will try it... because I haven't been able to get the kernel to compile

Oh wait...
The problem came back and the user reported reoppened the bug.

I know there is an IRC channel, and forums... but this bugzilla seems to fit the problem a bit better.

bugzilla sends email, shows lots of discussion on a page (unlike the forums), has the possiblity of becomming assigned, and is less realtime than IRC... It is a great place to discuss possible solutions to the bugs.

As this bug is a duplicate/depends on bug... It doen't really matter that it is closed...   but it should be closed as Duplicate or similar
Comment 7 Gunnar Koppel 2004-01-22 11:42:57 UTC
I have same bug. When i try build a new gentoo system and try "genkernel all", i got same "compile of modules failed" message. I have not made any modification in kernel config, it is the same oldconfig which comes with 2.4.22-gentoo-r5 kernel package. 

log says:
Knoppix / # tail /var/log/genkernel.log
ld -m elf_i386  -r -o linux_xfs.o xfs_stats.o xfs_sysctl.o xfs_aops.o xfs_behavior.o xfs_file.o xfs_fs_subr.o xfs_globals.o xfs_ioctl.o xfs_iomap.o xfs_iops.o xfs_lrw.o xfs_super.o xfs_vfs.o xfs_vnode.o
make[3]: Leaving directory `/usr/src/linux-2.4.22-gentoo-r5/fs/xfs/linux'
rm -f xfs_quota.o
ld -m elf_i386  -r -o xfs_quota.o xfs_qm_stats.o xfs_dquot.o xfs_dquot_item.o xfs_trans_dquot.o xfs_qm_syscalls.o xfs_qm_bhv.o xfs_qm.o
make[3]: Leaving directory `/usr/src/linux-2.4.22-gentoo-r5/fs/xfs/quota'
rm -f xfs.o
ld -m elf_i386  -r -o xfs.o xfs_alloc.o xfs_alloc_btree.o xfs_attr.o xfs_attr_leaf.o xfs_bit.o xfs_bmap.o xfs_bmap_btree.o xfs_btree.o xfs_buf_item.o xfs_da_btree.o xfs_dir.o xfs_dir2.o xfs_dir2_block.o xfs_dir2_data.o xfs_dir2_leaf.o xfs_dir2_node.o xfs_dir2_sf.o xfs_dir2_trace.o xfs_dir_leaf.o xfs_error.o xfs_extfree_item.o xfs_fsops.o xfs_ialloc.o xfs_ialloc_btree.o xfs_iget.o xfs_inode.o xfs_inode_item.o xfs_iocore.o xfs_itable.o xfs_dfrag.o xfs_log.o xfs_log_recover.o xfs_macros.o xfs_mount.o xfs_rename.o xfs_trans.o xfs_trans_ail.o xfs_trans_buf.o xfs_trans_extfree.o xfs_trans_inode.o xfs_trans_item.o xfs_utils.o xfs_vfsops.o xfs_vnodeops.o xfs_rw.o pagebuf/pagebuf.o linux/linux_xfs.o support/support_xfs.o quota/xfs_quota.o xfs_dmops.o xfs_qmops.o
make[2]: Leaving directory `/usr/src/linux-2.4.22-gentoo-r5/fs/xfs'
make[1]: Leaving directory `/usr/src/linux-2.4.22-gentoo-r5/fs'
* gen_die(): compile of modules failed

I understand, there is problem with kernel modules, not with genkernel, but it is still problem, which need a solution. 

With genkernel i had still problem. When i used options --debuglevel=5 and --debugfile=debug.genkernel.txt i got no file with debug information. And if genkernel just fails without saying anything (like: look /var/log/genkernel.log for information) for first time installer like me, i think it is still bug.
Comment 8 Daniel Briley 2004-01-24 16:01:31 UTC
I managed to work around this problem by using 'genkernel --menuconfig all' and removing "VIA CLE266" from "Character devices". I also set my processor type, although I don't think this matters...

I tried this after viewing /var/log/genkernel.log and seeing that compilation failed at via_drv.c.
Comment 9 Daniel Briley 2004-01-24 16:12:04 UTC
I realise this bug is marked as RESOLVED INVALID as this isn't a genkernel issue, but I thought I'd post my findings for the benefit of anyone searching bugzilla in the hope of a fix. 
Comment 10 Tim Yamin (RETIRED) gentoo-dev 2004-03-21 07:55:56 UTC
Sidenote: Error grepping is in genkernel-3.0.2_rc1 so that errors can be easily detected. Changing to "CLOSED" from "RESOLVED INVALID".