Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 380987

Summary: abiword 2.8.6 fails to build with libpng 1.5
Product: Gentoo Linux Reporter: Andrew John Hughes <gnu_andrew>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 354479    
Attachments: Patch for libpng 1.5 issues

Description Andrew John Hughes 2011-08-28 22:58:06 UTC
Patch attached.

Reproducible: Always




Portage 2.2.0_alpha51 (default/linux/amd64/10.0/desktop, gcc-4.6.1, glibc-2.13-r4, 3.0.3-gentoo.rivendell x86_64)
=================================================================
System uname: Linux-3.0.3-gentoo.rivendell-x86_64-Intel-R-_Xeon-R-_CPU_X5482_@_3.20GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 28 Aug 2011 01:15:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo xmmsroot2_overlay java-overlay fixes-overlay kde-sunset gcc-porting proaudio kde3-overlay
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FSF-APPROVED-EXT @X11-LICENSES @PRESUMED-FOSS @CREATIVE-COMMONS TeX MOTIF popt unRAR"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -ggdb -mno-tls-direct-seg-refs"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2 -ggdb -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/ ftp://mirror.bytemark.co.uk/gentoo/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ ftp://mirror.qubenet.net/mirror/gentoo/ http://gentoo.virginmedia.com/ ftp://gentoo.virginmedia.com/sites/gentoo "
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/builder/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/gentoo/xmmsroot2-overlay /usr/local/gentoo/java-overlay /usr/local/gentoo/fixes-overlay /var/lib/layman/kde-sunset /var/lib/layman/gcc-porting /var/lib/layman/pro-audio /usr/local/gentoo/kde3-overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 asyncns avahi bazaar berkdb bindist bluetooth bluray branding bzip2 cairo caps cdda cddb cdparanoia cdr celt cli consolekit cracklib crypt cups curl cvs cxx darcs dbus dga dirac djvu dri dts dv dvb dvd dvdr eds emacs emboss encode evo exif fam ffmpeg fftw firefox flac fontconfig fortran ftp fuse gcj gd gdbm gdu gif gimp git glib gmp gnome gnome-keyring gnutls gpm graphviz gs gstreamer gtk gtk3 gtkhtml hddtemp iconv idn ieee1394 imagemagick imap ipv6 java java5 java6 javascript jbig jpeg jpeg2k kde kerberos ladspa lame latex lcms libass libcaca libnotify libsamplerate lm_sensors lzma lzo mad mbox mercurial mmap mmx mng modules mp3 mp4 mpeg mpi msn mudflap multilib musepack musicbrainz ncurses nis nls nntp nptl nptlonly ntp ogg openexr opengl openmp pam pango pch pcre pdf perl png policykit postgres ppds pppd pulseaudio python qt3 qt3support qt4 readline realtime rtmp sasl scanner schroedinger sdl semantic-desktop session sndfile sox speex spell sqlite sse sse2 ssl ssse3 startup-notification subversion svg sysfs taglib tcpd tga theora threads tiff truetype udev unicode upnp urandom usb vorbis vpx wavpack webkit webm webp wmf x264 xattr xcb xcomposite xft xml xmmsroot2 xmp xorg xosd xprint xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="hauppauge_dvb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrew John Hughes 2011-08-28 22:58:38 UTC
Created attachment 284953 [details, diff]
Patch for libpng 1.5 issues
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-08-29 21:27:02 UTC
Please make sure you have synced your tree. This should have been fixed in bug #356287.

*** This bug has been marked as a duplicate of bug 356287 ***