Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 376697

Summary: dev-util/eclipse-sdk-3.5.1-r1 freezes at splash screen
Product: Gentoo Linux Reporter: Alexander Lopatin <alopatindev>
Component: Current packagesAssignee: Java team <java>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info

Description Alexander Lopatin 2011-07-28 09:19:23 UTC
After executing of eclipse-3.5 I see a splash screen and nothing else. I'm wating a few minutes for processes that eat CPU (different cores up to 100%) called "/opt/icedtea6-bin-1.10.2/bin/java -Xms128m -Xmx512m -XX:MaxPermSize=256m -jar /usr/lib64/eclipse-3.5//plugins/org.eclipse.equinox.lancher_1.0.201.R35x_v20090715.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /usr/lib64/eclipse-3.5/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse-3.5//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.200.v20090519/ -startup /usr/lib64/eclipse-3.5//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar -exitdata 24a0005 -vm /opt/icedtea6-bin-1.10.2/bin/java -vmargs -Xms128m..." to eat a small amount of CPU, and still I see a splash screen.

Reproducible: Always

Steps to Reproduce:
1. run eclipse-3.5
Comment 1 Alexander Lopatin 2011-07-28 09:20:03 UTC
Created attachment 281231 [details]
emerge --info
Comment 2 Alexander Lopatin 2011-07-28 09:22:03 UTC
Created attachment 281233 [details]

Eclipse's been stopped after waiting for java's processes.
Comment 3 Pacho Ramos gentoo-dev 2011-07-28 10:16:29 UTC
Have you tried to run it from a new created user account? Maybe this is related with bug 373105
Comment 4 Alexander Lopatin 2011-07-29 05:24:53 UTC
(In reply to comment #3)
> Have you tried to run it from a new created user account? Maybe this is related
> with bug 373105

I tried to run it from the user with almost clean home dir, now I see

skype@laptop ~ $ eclipse-3.5
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=lcd
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fffe1dda79a, pid=26840, tid=140737353877248
# JRE version: 6.0_22-b22
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.10.2
# Distribution: Built on Gentoo Base System release 2.0.2 (Thu Jun  9 16:08:40 CEST 2011)
# Problematic frame:
# C  []  js_fgets+0x4a2a
# An error report file with more information is saved as:
# /home/skype/hs_err_pid26840.log
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
Comment 5 Alexander Lopatin 2011-07-29 05:25:46 UTC
Created attachment 281377 [details]
Comment 6 James Le Cuirot gentoo-dev 2016-02-17 13:37:04 UTC
Closing as this version is ancient and the package has been removed from the
tree. If the package ever returns and this issue persists, please reopen.