Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 376201

Summary: x11-themes/murrine-themes-0.98.0: NOX theme shows "Murrine configuration option 'gradients' is no longer supported and will be ignored"
Product: Gentoo Linux Reporter: Anton Kochkov <anton.kochkov>
Component: Current packagesAssignee: Marek Szuba <marecki>
Status: RESOLVED FIXED    
Severity: normal CC: anton.kochkov
Priority: Normal Keywords: NeedPatch
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Anton Kochkov 2011-07-24 12:34:29 UTC
/usr/share/themes/NOX/gtk-2.0/gtkrc:233 Murrine configuration option 'gradients' is no longer supported and will be ignored

x11-themes/murrine-themes - 0.98.0 version
x11-themes/gtk-engines-murrine - 0.98.0 version
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-08-14 07:18:18 UTC
Please report this with upstream. I don't use GNOME 2 anymore and hence can't reproduce this.
Comment 2 Faustus 2011-08-27 23:06:28 UTC
Seems easy to patch:
http://web.archiveorange.com/archive/v/LLXmLJLul0sJ2Hj4o5Rh
https://bugs.launchpad.net/ubuntu/+source/human-theme/+bug/345417
http://www.khattam.info/solved-murrine-configuration-option-scrollbar_color-gradients-is-no-longer-supported-and-will-be-ignored-2010-02-11.html

Apparently, there are 4 offending options: the unsupported "scrollbar_color" and "gradients" (only for gtk+-2?) and the deprecated "hilight_ratio" and "highlight_ratio", for which "highlight_shade" needs to be used instead. Apparently, "lightborder_ratio" can be changed to "lightborder_shade", too.

My setup:
gtk+-2.24.4 (introspection, xinerama)
gtk-engines-murrine-0.98.1.1 (themes)
murrine-themes-0.98.0
Comment 3 Marek Szuba (RETIRED) archtester gentoo-dev 2021-11-28 00:46:56 UTC
Fixed in 0.98.11.