Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 373847

Summary: media-gfx/gimp-2.6.11-r1: crash on startup with error GLib-WARNING ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Product: Gentoo Linux Reporter: Plüss Roland <roland>
Component: Current packagesAssignee: Sebastian Pipping <sping>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Plüss Roland 2011-07-02 19:25:31 UTC
Update done on 2.7.2011 . Since then GIMP fails to start. Worked a week ago hence some updates in this time frame broke GIMP. rev-dep showed no dependency problems.

Trying to run GIMP the following error appears in the terminal and GIMP crashes.

(gimp:1740): GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Segmentation fault

I tried already re-ermeging media-libs/libpng-1.4.5, dev-libs/glib-2.28.8, x11-libs/gtk+-2.24.4 but the problem persists.

The backtrace looks like this ( gimp --stack-trace-mode=always ):
#0  0x00007fad02f09e7e in waitpid () from /lib64/
#1  0x00007fad0194fa12 in g_on_error_stack_trace () from /usr/lib64/
#2  0x00000000004719a3 in ?? ()
#3  0x0000000000471aed in gimp_fatal_error ()
#4  0x000000000047247f in ?? ()
#5  <signal handler called>
#6  0x00007fad019743e0 in g_source_is_destroyed () from /usr/lib64/
#7  0x00007fad04c8e259 in ?? () from /usr/lib64/
#8  0x00007fad01976711 in g_main_context_dispatch () from /usr/lib64/
#9  0x00007fad0197ad68 in ?? () from /usr/lib64/
#10 0x00007fad0197af1c in g_main_context_iteration () from /usr/lib64/
#11 0x00007fad05059361 in gtk_main_iteration () from /usr/lib64/
#12 0x00007fad05176665 in gtk_widget_show_now () from /usr/lib64/
#13 0x0000000000476347 in splash_create ()
#14 0x00000000004740e5 in gui_init ()
#15 0x00000000004713f4 in app_run ()
#16 0x00000000004722d0 in main ()

Reproducible: Always

Steps to Reproduce:
1. Update portage to snapshot of 2.7.2011
2. run "gimp" in console

Portage (default/linux/amd64/10.0/desktop, gcc-4.4.5, libc-0-r0, 2.6.32-gentoo-r7 x86_64)
System uname: Linux-2.6.32-gentoo-r7-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6400+-with-gentoo-2.0.2
Timestamp of tree: Sat, 02 Jul 2011 01:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
dev-util/pkgconfig:  0.25-r2
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.82
sys-libs/glibc:      2.12.2
virtual/os-headers:  0
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 AdobeFlash-10 AdobeFlash-10.1"
CFLAGS="-O2 -pipe -march=athlon64"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LINGUAS="en de"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 arts audiofile berkdb bluetooth branding browserplugin bzip2 cairo cdaudio cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dssi dts dv dvd dvdr dvdread emboss encode exif expat fam ffmpeg firefox flac fontconfig fortran gd gdbm gdu geoip gif gimp gimpprint gpm gtk hddtemp iconv ipv6 jabber jack java javascript jingle jpeg kde ladspa lame lcms libnotify libsamplerate live lm_sensors lua mad melt mmx mng modplug modules mp3 mp4 mpeg mudflap multilib mysql ncurses network nls noamazon nptl nptlonly nsplugin ogg openal openexr opengl openmp pam pango pcre pdf perl php plotutils png policykit ppds pppd python qt3support qt4 quicktime readline ruby sane sdl semantic-desktop session sndfile sox spell sql sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tiff timidity tk truetype udev unicode usb video visualization vorbis webkit wma wxwindows x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse aiptek" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx vesa radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Plüss Roland 2011-07-10 17:20:42 UTC
I find it a bit hard to understand this is flagged UNCONFIRMED if there is even a forum topic about it which at least one affected person :/
Comment 2 Plüss Roland 2011-07-10 20:59:44 UTC
This might help tracking down the problem. Concerning confirmed or not in Ubuntu it is found confirmed affecting over 20 or so people. I tried some experimenting around and this is what I found.

Using system settings => application appearance => gtk config . Various themes crash GIMP including "Rodent" and "Raleigh". With "bubble" though GIMP looks ugly but it does not crash.

This leads me to the conclusion that something including the GTK Theme engine (or whatever ebuild is responsible for this) is bugged. Hence the crash reproduction step would look like this now:

1) Go to system settings => application appearance => gtk config
2) Set Theme to "Rodent" or "Raleigh"
3) Run GIMP
4) GIMP crashes

1) Go to system settings => application appearance => gtk config
2) Set Theme to "bubble"
3) Run GIMP
4) GIMP works (but looks ugly)
Comment 3 Plüss Roland 2011-07-10 21:39:47 UTC
It looks like it is a GIMP specific crash. Other apps like Firefox work properly with the "Raleigh" theme but GIMP crashes. I don't know where to look more specifically for the problem.
Comment 4 Plüss Roland 2011-07-16 20:19:08 UTC
I re-compiled now various libs and I guess I found the buggy one. After re-compiling media-libs/gegl-0.1.6 it works again. So something on this ebuild is incorrect (incorrect dependency thus not re-compiled with rev-dep).
Comment 5 Ivan Iraci 2011-08-31 10:29:58 UTC
Neither recompiling gegl nor changing gtk theme fixed this problem for me.
There's a lot of people complaining about it, you can try googling for "GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8)", so I don't understand how this bug could be UNCONFIRMED...
Comment 6 Ivan Iraci 2011-08-31 10:36:22 UTC
Strangely, I only can start gimp by `strace gimp`.
Obviously it's not a viable solution, but I hope this info could help solve this bug.
Comment 7 Agostino Sarubbo gentoo-dev 2011-08-31 23:37:19 UTC
PLease do not CC arch team by yourself
Comment 8 Ivan Iraci 2011-09-01 08:57:44 UTC
(In reply to comment #7)

> PLease do not CC arch team by yourself

I CCed the arch team because this bug seems completely abandoned.
After two months maybe someone should give a look at it. Or not?
Comment 9 Ivan Iraci 2011-09-01 19:54:29 UTC
Comment 10 Ivan Iraci 2011-09-04 09:49:57 UTC
Is there anybody out there?..
Comment 11 Ivan Iraci 2011-09-07 09:13:42 UTC
Comment 12 Ivan Iraci 2011-09-09 08:53:58 UTC
(In reply to comment #7)

> PLease do not CC arch team by yourself

There is no active maintainer for this package, as far as I can understand by looking at this bug report. Then, please assign this bug to someone else. I think it would be appropriate to CC the arch team, but I leave it to you...
Comment 13 Ivan Iraci 2011-09-12 20:40:04 UTC
Comment 14 Ivan Iraci 2011-09-17 19:01:59 UTC
Please, reassign this bug to someone else. Thanks.
Comment 15 Ivan Iraci 2011-09-17 19:22:33 UTC
Another hint from dmesg:
gimp[32699]: segfault at 7fde2091f4d0 ip 00007fde2091f4d0 sp 00007fffe7ac28e8 error 14 in[7fde21288000+43000]

Rebuilding ncurses doesn't help.
Comment 16 Ivan Iraci 2011-09-23 11:39:05 UTC
I don't know which one between net-libs/webkit-gtk-1.4.3-r200 and x11-drivers/nvidia-drivers-285.03 fixed this issue, but gimp now works.
I thank myself for my invaluable support. I'm welcome.
Comment 17 Elijah "Armageddon" El Lazkani (amd64 AT) 2011-09-23 13:32:33 UTC
We already asked you once before not to CC arches on your own.
Comment 18 Ivan Iraci 2011-09-23 14:13:21 UTC
(In reply to comment #17)
> We already asked you once before not to CC arches on your own.

Yes, sorry. I should have CC myself, since no help nor the least advice came from this bug assignee. And all the arch team had to say is just to not CC them on my own. The first post in this thread is dated 2011-07-02. Do you know what "QA" mean? By the way... Sorry again.
Comment 19 Ivan Iraci 2011-09-23 14:17:30 UTC
Oh, I forgot... And this bug is still UNCONFIRMED! LOL. :D
Comment 20 Paul McDermott 2011-10-22 18:15:20 UTC
I'm getting this too, in case anyone is wondering whether this bug in confirmed or not...

XFCE 4.6

GIMP was working fine for me a few days ago, before an world upgrade...

Can I do anything to help diagnose?
Comment 21 Pacho Ramos gentoo-dev 2016-05-24 10:46:40 UTC
Please retry with current versions in the tree